summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorOskar Grunning2018-10-25 08:33:11 +0200
committerOskar Grunning2018-10-25 08:33:11 +0200
commit2f747fd17c629f92b16fedeb5c80b91fa632ef4e (patch)
tree44e5b9790ba38ffbd4d5900aa6503a1de02cd73e
downloadaur-2f747fd17c629f92b16fedeb5c80b91fa632ef4e.tar.gz
Initial commit
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD25
2 files changed, 39 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..fa98bfd7b20c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = weechat-emoji-git
+ pkgdesc = Weechat plugin to replace emoji in the "colon" format with unicode equivalents!
+ pkgver = r5.b6c25b2
+ pkgrel = 1
+ url = https://github.com/kattrali/weemoji
+ arch = any
+ license = BSD2
+ makedepends = git
+ depends = weechat
+ source = git+https://github.com/kattrali/weemoji.git
+ sha512sums = SKIP
+
+pkgname = weechat-emoji-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..91e3ac82e10b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+arch=('any')
+depends=('weechat')
+license=('BSD2')
+sha512sums=('SKIP')
+pkgdesc='Weechat plugin to replace emoji in the "colon" format with unicode equivalents!'
+pkgname=weechat-emoji-git
+pkgrel=1
+pkgver=r5.b6c25b2
+source=('git+https://github.com/kattrali/weemoji.git')
+makedepends=('git')
+url='https://github.com/kattrali/weemoji'
+
+_gitname='weemoji'
+
+pkgver() {
+ cd "${_gitname}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd "${_gitname}"
+
+ install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ install -Dm644 weemoji.py "${pkgdir}/usr/lib/weechat/python/weemoji.py"
+}