summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJonas Witschel2022-04-07 09:21:02 +0000
committerJonas Witschel2022-04-07 09:21:02 +0000
commite67a645eed051cd88c07cca3a0768317e91c7dcb (patch)
tree0772e97146f2585cf573b081ee70e82d8cbf3486
parent2fa44e58d3598cc188cc775f6cc251dff248d482 (diff)
downloadaur-e67a645eed051cd88c07cca3a0768317e91c7dcb.tar.gz
weechat-matrix: use git cherry-pick instead of patch
The package already uses git sources, so there is no need to download patch files separately.
-rw-r--r--PKGBUILD8
1 files changed, 3 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 384587c39ccb..b93e367e8e4e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -16,10 +16,8 @@ optdepends=('python-aiohttp: matrix_sso_helper support'
'python-requests: matrix_decrypt and matrix_upload support'
'xdg-utils: default plumber for matrix_decrypt')
install='weechat-matrix.install'
-source=("git+$url.git?signed#tag=$_tag"
- "weechat-matrix-0.3.0_remove-set_npn_protocols.patch::$url/commit/4e585d5f4628e6fbeba9ec4560b440d731e076f5.patch")
-sha512sums=('SKIP'
- 'a374aae0e3df0c47476ea100bd7bb570a46530a6daa5318a445e1c0becff64cdb0a62368e18c076bdb7a06a05e7ba8f02f806f0aa0062b4dacc98af3a26d978f')
+source=("git+$url.git?signed#tag=$_tag")
+sha512sums=('SKIP')
validpgpkeys=('689A3B5BC6560AB4C99A2A0581314DA807EF4E22') # Damir Jelić (poljar) <poljar@termina.org.uk>
pkgver() {
@@ -36,7 +34,7 @@ prepare() {
# SSLContext.set_npn_protocols broken in Python 3.10
# (https://github.com/poljar/weechat-matrix/issues/308)
- patch --forward --strip=1 --input="$srcdir/weechat-matrix-0.3.0_remove-set_npn_protocols.patch"
+ git cherry-pick --no-commit 4e585d5f4628e6fbeba9ec4560b440d731e076f5
}
build() {