summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorVincent Grande2021-02-25 16:47:10 -0500
committerVincent Grande2021-02-25 16:47:10 -0500
commit89d75182894df6940a93f2141611e37f2717a428 (patch)
treebe955c42344dc0aabe6c2da841f29871560674b9
downloadaur-89d75182894df6940a93f2141611e37f2717a428.tar.gz
initial upload
-rw-r--r--.SRCINFO36
-rw-r--r--PKGBUILD78
2 files changed, 114 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2f803dde7cee
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,36 @@
+pkgbase = weechat-git
+ pkgdesc = Fast, light and extensible IRC client (curses UI). Development version.
+ pkgver = 2.7.125.gc29b45a0f
+ pkgrel = 1
+ url = https://www.weechat.org/
+ arch = i686
+ arch = x86_64
+ arch = armv7h
+ arch = aarch64
+ license = GPL
+ makedepends = git
+ makedepends = source-highlight
+ makedepends = cmake
+ makedepends = pkg-config
+ makedepends = asciidoctor
+ depends = gnutls
+ depends = ncurses
+ depends = curl
+ depends = zlib
+ depends = libgcrypt
+ depends = hicolor-icon-theme
+ optdepends = perl
+ optdepends = python
+ optdepends = lua
+ optdepends = tcl
+ optdepends = ruby
+ optdepends = aspell
+ optdepends = guile
+ optdepends = python2
+ provides = weechat=2.7.125.gc29b45a0f
+ conflicts = weechat
+ source = git+https://github.com/weechat/weechat.git
+ sha512sums = SKIP
+
+pkgname = weechat-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4de97ff3dd99
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,78 @@
+# Maintainer: Vincent Grande <shoober420@gmail.com>
+# Contributor: Alfredo Ramos <alfredo dot ramos at yandex dot com>
+# Contributor: Christian Rebischke <Chris.Rebischke@archlinux.org>
+# Contributor: Giovanni Scafora <giovanni@archlinux.org>
+# Contributor: lucke <lucke at o2 dot pl>
+# Contributor: dacoit <dacoit at tuta.io>
+# Contributor: Daniel Wallace <danielwallace at gtmanfred dot com>
+# Contributor: Dmitry Korzhevin <dkorzhevin AT gmail DOT com>
+# Contributor: Mark Foxwell <fastfret79@archlinux.org.uk>
+# Contributor: tigrmesh <tigrmesh at aol dot com>
+# Contributor: Tim Zebulla <amon at faumrahrer dot de>
+
+_pkgname=weechat
+pkgname=${_pkgname}-git
+pkgver=2.7.125.gc29b45a0f
+pkgrel=1
+pkgdesc='Fast, light and extensible IRC client (curses UI). Development version.'
+arch=('i686' 'x86_64' 'armv7h' 'aarch64')
+url='https://www.weechat.org/'
+license=('GPL')
+
+depends=('gnutls' 'ncurses' 'curl' 'zlib' 'libgcrypt' 'hicolor-icon-theme')
+makedepends=(
+ 'git' 'source-highlight' 'cmake' 'pkg-config' 'asciidoctor'
+ #'php' 'v8'
+)
+optdepends=(
+ 'perl' 'python' 'lua' 'tcl' 'ruby'
+ 'aspell' 'guile' 'python2'
+ #'php' 'v8'
+)
+provides=("${_pkgname}=${pkgver}")
+conflicts=("${_pkgname}")
+
+source=("git+https://github.com/${_pkgname}/${_pkgname}.git")
+sha512sums=('SKIP')
+
+pkgver() {
+ cd "${srcdir}"/${_pkgname}
+ git describe --long --tags 2>/dev/null | sed -r 's/^v//;s/-/./g'
+}
+
+prepare() {
+ mkdir -p "${srcdir}"/build
+}
+
+build() {
+ cd "${srcdir}"/build
+ cmake -Wno-dev ../${_pkgname} \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DENABLE_MAN=OFF \
+ -DENABLE_DOC=OFF \
+ -DENABLE_JAVASCRIPT=OFF \
+ -DENABLE_PHP=OFF #\
+ -DENABLE_EXEC=OFF \
+ -DENABLE_FIFO=OFF \
+ -DENABLE_GUILE=OFF \
+ -DENABLE_LUA=OFF \
+ -DENABLE_PERL=OFF \
+ -DENABLE_PYTHON=OFF \
+ -DENABLE_RUBY=OFF \
+ -DENABLE_TCL=OFF \
+ -DENABLE_XFER=OFF \
+ -DENABLE_LOGGER=OFF \
+ -DENABLE_RELAY=OFF \
+ -DENABLE_HEADLESS=OFF \
+ -DENABLE_PYTHON2=OFF \
+ -DENABLE_SPELL=OFF \
+ -DENABLE_ENCHANT=OFF \
+ -DENABLE_DEBUG=OFF \
+ -DENABLE_TESTS=OFF
+ make
+}
+
+package() {
+ cd "${srcdir}"/build
+ make DESTDIR="${pkgdir}" install
+}