summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBenjamin Denhartog2019-03-12 16:44:55 -0700
committerBenjamin Denhartog2019-03-12 16:44:55 -0700
commit435c0baf3ed703a035f8b139f80da7767502482d (patch)
tree8abbefe9eeb57beee8955e4ee0a4c405ccd65884
parent54f2ddbdc1039c65ca8f3920fcd76ed0c3b674ae (diff)
downloadaur-435c0baf3ed703a035f8b139f80da7767502482d.tar.gz
new release: weechat-notify-send 0.8-1
upstream release
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD43
2 files changed, 33 insertions, 22 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9d1fa584e47d..92375b08cb95 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,15 @@
pkgbase = weechat-notify-send
pkgdesc = A WeeChat script that sends highlight and message notifications through notify-send
- pkgver = r180.962218a
- pkgrel = 2
+ pkgver = 0.8
+ pkgrel = 1
url = https://github.com/s3rvac/weechat-notify-send
arch = any
license = MIT
- makedepends = git
- depends = weechat
depends = libnotify
- source = git+https://github.com/s3rvac/weechat-notify-send.git
- sha512sums = SKIP
+ depends = python
+ depends = weechat
+ source = weechat-notify-send_0.8.tar.gz::https://github.com/s3rvac/weechat-notify-send/archive/v0.8.tar.gz
+ sha512sums = 250814152ea6d123aa4c48fb40648fe490134121a62253c692fcddb1eba05e28bda7523182fbb1db13a41f7a38d63e2e56ea97584d0c06321c4d56f6d701a985
pkgname = weechat-notify-send
diff --git a/PKGBUILD b/PKGBUILD
index 3ba77cbd9195..fd46a22cbda7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,22 +1,33 @@
-arch=('any')
-depends=('weechat' 'libnotify')
-license=('MIT')
-sha512sums=('SKIP')
-pkgdesc='A WeeChat script that sends highlight and message notifications through notify-send'
pkgname=weechat-notify-send
-pkgrel=2
-pkgver=r180.962218a
-source=('git+https://github.com/s3rvac/weechat-notify-send.git')
-makedepends=('git')
+pkgver=0.8
+pkgrel=1
+pkgdesc="A WeeChat script that sends highlight and message notifications through notify-send"
url='https://github.com/s3rvac/weechat-notify-send'
-
-pkgver() {
- cd "${pkgname}"
- printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
-}
+arch=('any')
+license=('MIT')
+depends=(
+ 'libnotify'
+ 'python'
+ 'weechat'
+)
+source=("${pkgname}_${pkgver}.tar.gz::${url}/archive/v${pkgver}.tar.gz")
+sha512sums=(
+ '250814152ea6d123aa4c48fb40648fe490134121a62253c692fcddb1eba05e28bda7523182fbb1db13a41f7a38d63e2e56ea97584d0c06321c4d56f6d701a985'
+)
package() {
- cd "${pkgname}"
+ cd "$srcdir/$pkgname-$pkgver"
+
+ msg2 "Installing the notify_send.py plugin"
+ install -Dm644 notify_send.py ${pkgdir}/usr/lib/weechat/python/notify_send.py
- install -Dm644 "notify_send.py" "${pkgdir}/usr/lib/weechat/python/notify_send.py"
+ msg2 "Installing license"
+ install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+
+ msg2 "Since WeeChat does not yet load plugins in the system path, you need"
+ msg2 "to load the script from your user path. Use symlnks so that you can"
+ msg2 "benefit from package upgrades via pacman."
+ msg2 " $ ln -s /usr/lib/weechat/python/notify_send.py $HOME/.weechat/python/notify_send.py"
}
+
+# vim:set ts=2 sw=2 et: