summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBenjamin Denhartog2020-03-15 14:30:42 -0700
committerBenjamin Denhartog2020-03-15 14:35:46 -0700
commite8193f47e72d91410a7a30ac974c1f6c5b5e92ef (patch)
tree03b2ca883b41f877c002a76ac61bed2213bd8cf3
parent262972b9c5d18def32bbe76b8f8763f282716955 (diff)
downloadaur-e8193f47e72d91410a7a30ac974c1f6c5b5e92ef.tar.gz
chore(weechat-notify-send): remove msg2 invocations
This patch removes the calls to the internal function `msg2`, moving the post-installation instructions and informational messages (e.g. "Installing the plugin...") to comments within the PKGBUILD. This results in less output when building the package. The post-installation instructions are helpful to display, but are out of place in various scenarios, such as when the user builds the package in a chroot environment, or as a different user than their own on the host machine.
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD25
2 files changed, 16 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0c58df961862..fef5ff201cd2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = weechat-notify-send
pkgdesc = A WeeChat script that sends highlight and message notifications through notify-send
pkgver = 0.9
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/s3rvac/weechat-notify-send
arch = any
license = MIT
diff --git a/PKGBUILD b/PKGBUILD
index 2666b3871f41..bc80dd320564 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,20 @@
# Maintainer: Benjamin Denhartog <ben@sudoforge.com>
+# POST-INSTALLATION INSTRUCTIONS
+#
+# WeeChat is unable to source files from outside of a user's home directory.
+# Because of this limitation, this package *DOES NOT* make this plugin available
+# to WeeChat without end user interaction.
+#
+# Each user who wants to enable this plugin needs to create symlinks in the
+# WeeChat configuration directory for their user (by default, ~/.weechat). The
+# following command(s) will accomplish this:
+#
+# $ ln -s /usr/lib/weechat/python/notify_send.py ~/.weechat/python/autoload/notify_send.py
+
pkgname=weechat-notify-send
pkgver=0.9
-pkgrel=1
+pkgrel=2
pkgdesc="A WeeChat script that sends highlight and message notifications through notify-send"
url='https://github.com/s3rvac/weechat-notify-send'
arch=('any')
@@ -18,16 +30,9 @@ sha512sums=('108c094ab9080581284255bd7c9aa8f4d9dcb836b91a082c21370810b60eabbc882
package() {
cd "$srcdir/$pkgname-$pkgver"
- msg2 "Installing the notify_send.py plugin"
+ # Install the plugin script
install -Dm644 notify_send.py ${pkgdir}/usr/lib/weechat/python/notify_send.py
- msg2 "Installing license"
+ # Install the plugin license
install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
-
- msg2 "Since WeeChat does not yet load plugins in the system path, you need"
- msg2 "to load the script from your user path. Use symlnks so that you can"
- msg2 "benefit from package upgrades via pacman."
- msg2 " $ ln -s /usr/lib/weechat/python/notify_send.py $HOME/.weechat/python/notify_send.py"
}
-
-# vim:set ts=2 sw=2 et: