summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSlashbunny2019-05-18 00:48:53 -0400
committerSlashbunny2019-05-18 00:48:53 -0400
commit097afa01a59379e9a0f72c5471fc010b5933e665 (patch)
treeba736b69a6130edb130546f0c8fd0a7caab80f0d
downloadaur-097afa01a59379e9a0f72c5471fc010b5933e665.tar.gz
Initial commit
-rw-r--r--.SRCINFO33
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD36
3 files changed, 73 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3ff8b96719ef
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,33 @@
+# Generated by mksrcinfo v8
+# Sat May 18 04:48:41 UTC 2019
+pkgbase = weechat-poljar-matrix-git
+ pkgdesc = Python plugin for Weechat to communicate over the Matrix protocol
+ pkgver = r614.b136153
+ pkgrel = 1
+ url = https://github.com/poljar/weechat-matrix
+ arch = any
+ license = custom
+ makedepends = git
+ depends = cython2
+ depends = python2-atomicwrites
+ depends = python2-attrs
+ depends = python2-future
+ depends = python2-h11
+ depends = python2-h2
+ depends = python2-jsonschema
+ depends = python2-logbook
+ depends = python2-matrix-nio
+ depends = python2-olm
+ depends = python2-peewee
+ depends = python2-pygments
+ depends = python2-pyopenssl
+ depends = python2-typing
+ depends = python2-unpaddedbase64
+ depends = python2-webcolors
+ provides = weechat-poljar-matrix
+ conflicts = weechat-poljar-matrix
+ source = weechat-matrix::git+https://github.com/poljar/weechat-matrix.git
+ md5sums = SKIP
+
+pkgname = weechat-poljar-matrix-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..e984beab6197
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+pkg/
+src/
+weechat-matrix/
+*.pkg.tar.xz
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f6a84371fe2c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: Slash <youremail@domain.com>
+
+pkgname=weechat-poljar-matrix-git
+pkgver=r614.b136153
+pkgrel=1
+pkgdesc="Python plugin for Weechat to communicate over the Matrix protocol"
+arch=('any')
+url="https://github.com/poljar/weechat-matrix"
+license=('custom')
+groups=()
+depends=('cython2' 'python2-atomicwrites' 'python2-attrs' 'python2-future'
+ 'python2-h11' 'python2-h2' 'python2-jsonschema' 'python2-logbook'
+ 'python2-matrix-nio' 'python2-olm' 'python2-peewee' 'python2-pygments'
+ 'python2-pyopenssl' 'python2-typing' 'python2-unpaddedbase64'
+ 'python2-webcolors')
+makedepends=('git')
+provides=('weechat-poljar-matrix')
+conflicts=('weechat-poljar-matrix')
+source=('weechat-matrix::git+https://github.com/poljar/weechat-matrix.git')
+md5sums=('SKIP')
+
+pkgver() {
+ cd "${srcdir}/weechat-matrix"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd "${srcdir}/weechat-matrix"
+
+ # Install plugin scripts
+ make WEECHAT_HOME="${pkgdir}/usr/lib/weechat" install
+
+ # Install License
+ install -D -m 644 'LICENSE' \
+ "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}