summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSlashbunny2019-12-04 11:48:30 -0500
committerSlashbunny2019-12-04 11:48:30 -0500
commitdd7a6f8871a5011e894b77a2d3df80834c8e753e (patch)
treef9ce06b929a6ccaae8f2187d35f6c6525c0970ba
parentc11171e83dcd5782cacd66923e31449fbd086c41 (diff)
downloadaur-dd7a6f8871a5011e894b77a2d3df80834c8e753e.tar.gz
Install contrib scripts, update .install script
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD8
-rw-r--r--weechat-poljar-matrix-git.install23
3 files changed, 20 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a64986a7705e..bd7e883ab85f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = weechat-poljar-matrix-git
pkgdesc = Python plugin for Weechat to communicate over the Matrix protocol
- pkgver = r690.b26dc83
+ pkgver = r701.6d58ff0
pkgrel = 1
url = https://github.com/poljar/weechat-matrix
install = weechat-poljar-matrix-git.install
diff --git a/PKGBUILD b/PKGBUILD
index cb9af2a0fd15..501e01b2f0a0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Slash <youremail@domain.com>
pkgname=weechat-poljar-matrix-git
-pkgver=r690.b26dc83
+pkgver=r701.6d58ff0
pkgrel=1
pkgdesc="Python plugin for Weechat to communicate over the Matrix protocol"
arch=('any')
@@ -28,6 +28,12 @@ package() {
# Install plugin scripts
make WEECHAT_HOME="${pkgdir}/usr/lib/weechat" install
+ # Install contrib scripts
+ for script in contrib/*; do
+ install -D -m 644 "${script}" \
+ "${pkgdir}/usr/lib/weechat/python/matrix/${script}"
+ done;
+
# Install License
install -D -m 644 'LICENSE' \
"${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
diff --git a/weechat-poljar-matrix-git.install b/weechat-poljar-matrix-git.install
index 23937c39fb5c..4222419bd125 100644
--- a/weechat-poljar-matrix-git.install
+++ b/weechat-poljar-matrix-git.install
@@ -1,5 +1,4 @@
-
-post_install() {
+_install_update_msg() {
echo "In order to use this plugin after installation, you'll need to run the following commands as the user that is running weechat:"
echo ""
echo " $ ln -s /usr/lib/weechat/python/matrix/ ~/.weechat/python/"
@@ -9,16 +8,18 @@ post_install() {
echo ""
echo " $ ln -s /usr/lib/weechat/python/matrix.py ~/.weechat/python/autoload/"
echo ""
-}
-
-post_upgrade() {
- echo "In order to use this plugin after installation, you'll need to run the following commands as the user that is running weechat:"
+ echo "Optional scripts, like matrix_decrypt, matrix_sso_helper, and matrix_upload are available in the following directory:"
echo ""
- echo " $ ln -s /usr/lib/weechat/python/matrix/ ~/.weechat/python/"
- echo " $ ln -s /usr/lib/weechat/python/matrix.py ~/.weechat/python/"
+ echo " /usr/lib/weechat/python/matrix/contrib/"
echo ""
- echo "If you want the script to be loaded on start-up, you'll also need to symlink it into the autoload folder:"
- echo ""
- echo " $ ln -s /usr/lib/weechat/python/matrix.py ~/.weechat/python/autoload/"
+ echo " Symlink these files or add this directory to your \$PATH to use these scripts."
echo ""
}
+
+post_install() {
+ _install_update_msg
+}
+
+post_upgrade() {
+ _install_update_msg
+}