summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorOskar Grunning2018-10-18 22:20:56 +0200
committerOskar Grunning2018-10-18 22:20:56 +0200
commit1bbeb4a48bf6c4b3fab162b003d2de1f07803265 (patch)
treefacd1b496c2dccb14047ba1dd2050279562c2788
downloadaur-1bbeb4a48bf6c4b3fab162b003d2de1f07803265.tar.gz
Initial commit
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD24
2 files changed, 38 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9b6519a4e0ce
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = weechat-vimode-git
+ pkgdesc = A WeeChat script that adds vi-like modes, commands and keybindings
+ pkgver = r173.1da5a2e
+ pkgrel = 1
+ url = https://github.com/GermainZ/weechat-vimode
+ arch = any
+ license = GPL3
+ makedepends = git
+ depends = weechat
+ source = git+https://github.com/GermainZ/weechat-vimode.git
+ sha512sums = SKIP
+
+pkgname = weechat-vimode-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c256fd9477fe
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+arch=('any')
+depends=('weechat')
+license=('GPL3')
+sha512sums=('SKIP')
+pkgdesc='A WeeChat script that adds vi-like modes, commands and keybindings'
+pkgname=weechat-vimode-git
+pkgrel=1
+pkgver=r173.1da5a2e
+source=('git+https://github.com/GermainZ/weechat-vimode.git')
+makedepends=('git')
+url='https://github.com/GermainZ/weechat-vimode'
+
+_gitname='weechat-vimode'
+
+pkgver() {
+ cd "${_gitname}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd "${_gitname}"
+
+ install -Dm644 "vimode.py" "${pkgdir}/usr/lib/weechat/python/vimode.py"
+}