summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorOlivier Brunel2015-06-08 19:19:45 +0200
committerOlivier Brunel2015-06-08 19:20:28 +0200
commit841ea60ee251e9d388894384e6619f40089eebf3 (patch)
treeee4513814e2b8af3ffbd98a335383aeb611d7624
downloadaur-841ea60ee251e9d388894384e6619f40089eebf3.tar.gz
weeplugins-git: Fixup folder name
Signed-off-by: Olivier Brunel <jjk@jjacky.com>
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD25
2 files changed, 40 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..582730b1c3bc
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = weeplugins-git
+ pkgdesc = WeeChat plugins: NickServ handling, trigger commands on messages, command to send text/command to specific buffer
+ pkgver = 0.1.1
+ pkgrel = 1
+ url = https://github.com/jjk-jacky/weeplugins
+ arch = i686
+ arch = x86_64
+ license = GPL3+
+ makedepends = git
+ depends = weechat
+ source = git+https://github.com/jjk-jacky/weeplugins.git
+ md5sums = SKIP
+
+pkgname = weeplugins-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7d8841547763
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: jjacky
+_pkgname=weeplugins
+pkgname=$_pkgname-git
+pkgver=0.1.1
+pkgrel=1
+pkgdesc="WeeChat plugins: NickServ handling, trigger commands on messages, command to send text/command to specific buffer"
+arch=('i686' 'x86_64')
+url="https://github.com/jjk-jacky/weeplugins"
+license=('GPL3+')
+depends=('weechat')
+makedepends=('git')
+source=("git+https://github.com/jjk-jacky/${_pkgname}.git")
+md5sums=('SKIP')
+
+build() {
+ cd "$srcdir/$_pkgname"
+ make
+}
+
+package() {
+ cd "$srcdir/$_pkgname"
+ make DESTDIR="$pkgdir/" install
+}
+
+# vim:set ts=2 sw=2 et: