summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAaron Mueller2014-03-06 19:31:29 +0100
committerAaron Mueller2014-03-06 19:31:29 +0100
commit05ff3836d413bc0ca8d5bb36e25639066ab607be (patch)
treed45aaed22636531910e7b0004ebfba20b2ff117c
downloadaur-05ff3836d413bc0ca8d5bb36e25639066ab607be.tar.gz
Move all packages to version control
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD26
-rw-r--r--weex-2.6.1.5-formatstring.patch13
-rw-r--r--weex-2.6.1.5-va_list.patch23
4 files changed, 79 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e4d666faefd3
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = weex
+ pkgdesc = A non-interactive FTP client for updating web pages
+ pkgver = 2.6.1.5
+ pkgrel = 4
+ url = http://weex.sourceforge.net/
+ arch = i686
+ arch = x86_64
+ license = GPL
+ source = http://downloads.sourceforge.net/sourceforge/weex/weex-2.6.1.5.tar.gz
+ source = weex-2.6.1.5-formatstring.patch
+ source = weex-2.6.1.5-va_list.patch
+ md5sums = c10192608ab9f715c4c1ea63cf6ad2da
+ md5sums = a12d955c5a4d6b059395a0da22942114
+ md5sums = 522552e03b82ab5669fd21c558290691
+
+pkgname = weex
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6cbaa69a910a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Contributor: Tom Newsom <Jeepster@gmx.co.uk>
+# Contributor: Giorgio Lando <patroclo7@gmail.com>
+# Maintainer: Aaron Mueller <mail@aaron-mueller.de>
+
+pkgname=weex
+pkgver=2.6.1.5
+pkgrel=4
+pkgdesc="A non-interactive FTP client for updating web pages"
+arch=(i686 x86_64)
+license=("GPL")
+source=("http://downloads.sourceforge.net/sourceforge/$pkgname/$pkgname-$pkgver.tar.gz"
+ "weex-2.6.1.5-formatstring.patch"
+ "weex-2.6.1.5-va_list.patch")
+md5sums=("c10192608ab9f715c4c1ea63cf6ad2da"
+ "a12d955c5a4d6b059395a0da22942114"
+ "522552e03b82ab5669fd21c558290691")
+url="http://weex.sourceforge.net/"
+
+build() {
+ cd $startdir/src/$pkgname-$pkgver
+ patch -Np0 -i ../weex-$pkgver-formatstring.patch
+ [ "$CARCH" == "x86_64" ] && patch -Np0 -i ../weex-$pkgver-va_list.patch
+ ./configure --prefix=/usr
+ make || return 1
+ make prefix=$startdir/pkg/usr install
+}
diff --git a/weex-2.6.1.5-formatstring.patch b/weex-2.6.1.5-formatstring.patch
new file mode 100644
index 000000000000..73564e9b4e01
--- /dev/null
+++ b/weex-2.6.1.5-formatstring.patch
@@ -0,0 +1,13 @@
+Patch for CAN-2005-3150 provided by Ulf Harnhammar.
+
+--- src/log.c.old 2005-10-02 03:49:34.495603240 +0200
++++ src/log.c 2005-10-02 03:50:18.064979688 +0200
+@@ -183,7 +183,7 @@ void log_flush(void)
+
+ fp=log_open();
+ for(i=0;i<max_log;i++){
+- fprintf(fp,log_str[i]);
++ fprintf(fp,"%s",log_str[i]);
+ free(log_str[i]);
+ }
+ free(log_str);
diff --git a/weex-2.6.1.5-va_list.patch b/weex-2.6.1.5-va_list.patch
new file mode 100644
index 000000000000..70b3ebcdd832
--- /dev/null
+++ b/weex-2.6.1.5-va_list.patch
@@ -0,0 +1,23 @@
+--- src/strlib.c.orig 2003-08-18 11:52:38.000000000 +0200
++++ src/strlib.c 2004-07-05 20:32:48.853638760 +0200
+@@ -167,14 +167,16 @@
+ -------------------------------------------------- */
+ char *str_dup_printf(const char *format, ...)
+ {
+- va_list ap1,ap2;
++ va_list ap1;
+ char *ptr;
+
+ va_start(ap1,format);
+- G_VA_COPY(ap2,ap1);
++ //G_VA_COPY(ap2,ap1);
+ ptr=str_malloc(printf_string_upper_bound(format,ap1));
+- vsprintf(ptr,format,ap2);
+- va_end(ap2);
++ va_end(ap1);
++ va_start(ap1,format);
++ vsprintf(ptr,format,ap1);
++ va_end(ap1);
+
+ return(ptr);
+ }