summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel M. Capella2017-08-06 08:32:47 -0400
committerDaniel M. Capella2017-08-06 08:32:47 -0400
commit7e3548fff7edbd36f47d7b66f8da7de1f7082db4 (patch)
treea65872ac8983c5cb53444555ed5c3ec15d6aa84d
parenta958d8fc260b0a7593d02a5ed3a4f46cd0aebfb8 (diff)
downloadaur-7e3548fff7edbd36f47d7b66f8da7de1f7082db4.tar.gz
Minor simplification
-rw-r--r--PKGBUILD14
1 files changed, 6 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 3bda0a0f5562..762dae4e9d51 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,5 +1,6 @@
# Maintainer: Daniel M. Capella <polyzen@archlinux.info>
+_commit=6f7b2f4b18f85766b6199b574f42c72ef4539c45
pkgname=wego
pkgver=2.0.r33.g6f7b2f4
pkgrel=1
@@ -8,18 +9,16 @@ url=https://github.com/schachmat/wego
arch=('any')
license=('ISC')
makedepends=('git' 'go')
-source=("wego-$pkgver.tar.gz::$url/archive/6f7b2f4b18f85766b6199b574f42c72ef4539c45.zip")
+source=("wego-$pkgver.tar.gz::$url/archive/$_commit.tar.gz")
sha512sums=('f7c0d2da770ff311c62c4ab9e539edbd785ac21dbf7578d281876e621bb933c5ed168597d209c5140e686e3f27df5a3d89a87a49cc42298dd5af2c29fe03d09a')
prepare() {
- local tmp=${source##*/}
mkdir -p src/github.com/schachmat
- ln -rsnf wego-${tmp%\.*} src/${url#*//}
+ ln -rsnf wego-$_commit src/${url#*//}
}
build() {
- local tmp=${source##*/}
- cd wego-${tmp%\.*}
+ cd wego-$_commit
export GOPATH="$srcdir"
go get -u -v github.com/schachmat/ingo
go get -u -v github.com/mattn/go-colorable
@@ -28,9 +27,8 @@ build() {
}
package() {
- local tmp=${source##*/}
- cd wego-${tmp%\.*}
- install -Dm755 wego-${tmp%\.*} "$pkgdir"/usr/bin/$pkgname
+ cd wego-$_commit
+ install -Dm755 wego-$_commit "$pkgdir"/usr/bin/$pkgname
install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
}