summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJohn ShaggyTwoDope Jenkins2015-06-23 01:38:11 -0700
committerJohn ShaggyTwoDope Jenkins2015-06-23 01:38:11 -0700
commitaf6e3c21ab5169b10035eec5e45d6c9671c7814e (patch)
tree20c7c6899ab26736805e2ee9beab5aae6f1998f7
downloadaur-af6e3c21ab5169b10035eec5e45d6c9671c7814e.tar.gz
Initial import
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD39
-rw-r--r--wego.install4
3 files changed, 60 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..446d90e06ae0
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = wego-git
+ pkgdesc = Weather app for your terminal.
+ pkgver = r32.0a3ce5b
+ pkgrel = 1
+ url = https://github.com/schachmat/wego
+ install = wego.install
+ arch = any
+ license = ISC
+ makedepends = go
+ makedepends = git
+ options = !strip
+ options = !emptydirs
+ source = wego-git::git+https://github.com/schachmat/wego.git
+ md5sums = SKIP
+
+pkgname = wego-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b11b1da8163e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# Maintainer: John Jenkins <twodopeshaggy@gmail.com>
+
+pkgname=wego-git
+pkgver=r32.0a3ce5b
+pkgrel=1
+pkgdesc="Weather app for your terminal."
+arch=('any')
+url="https://github.com/schachmat/wego"
+license=('ISC')
+makedepends=('go' 'git')
+options=('!strip' '!emptydirs')
+install=wego.install
+source=($pkgname::git+https://github.com/schachmat/wego.git)
+md5sums=('SKIP')
+pkgver() {
+ cd $srcdir/$pkgname
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+prepare() {
+ export GOPATH="$srcdir/$pkgname"
+ go get github.com/mattn/go-colorable
+}
+
+build() {
+ cd "$srcdir/$pkgname"
+ msg2 'Building wego'
+ go build -o wego we.go
+}
+
+package() {
+ mkdir -p "$pkgdir/usr/bin"
+ install -p -m755 $srcdir/$pkgname/wego "$pkgdir/usr/bin"
+
+ cd "$srcdir/$pkgname"
+ mkdir -p $pkgdir/usr/share/licenses/$pkgname
+ install -m 0644 LICENSE $pkgdir/usr/share/licenses/$pkgname/
+
+}
diff --git a/wego.install b/wego.install
new file mode 100644
index 000000000000..4989c5c0e634
--- /dev/null
+++ b/wego.install
@@ -0,0 +1,4 @@
+post_install() {
+echo "You need an API key in your config file before you can run wego."
+echo "Vist https://github.com/schachmat/wego and read setup section."
+}