summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAitor Alonso2018-05-23 16:41:29 +0200
committerAitor Alonso2018-05-23 16:41:29 +0200
commit294bdfe1d260818771e579f9c0166876b46224fb (patch)
tree6b2181e625a3e07021d4cf4047f94f3f7cb158b2
parenta3506fbec7c478327ad1a3672486842a8afde46a (diff)
downloadaur-294bdfe1d260818771e579f9c0166876b46224fb.tar.gz
New maintainer and update to v3.8.2
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD7
-rwxr-xr-xweka.sh6
3 files changed, 9 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9126d66dd925..5cc71d3f2c86 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -2,7 +2,7 @@
# Sat May 6 10:20:03 UTC 2017
pkgbase = weka
pkgdesc = A collection of machine learning algorithms for data mining tasks
- pkgver = 3.8.1
+ pkgver = 3.8.2
pkgrel = 1
url = http://www.cs.waikato.ac.nz/ml/weka/
arch = any
@@ -13,7 +13,7 @@ pkgbase = weka
source = http://downloads.sourceforge.net/sourceforge/weka/weka-3-8-1.zip
source = weka.sh
source = weka.desktop
- md5sums = e9542ebadb41594ba23729b741fffa7f
+ md5sums = 491f1efa03a6406f524f934d481059d6
md5sums = 60dc5666b93d98db0900deb7d8b5eae4
md5sums = 83a4d47ba64df90a92a38b23a14c6480
diff --git a/PKGBUILD b/PKGBUILD
index e5c811945931..d3fac506c567 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,9 +1,10 @@
-# Maintainer: Andrew Chen <andrew.chuanye.chen@gmail.com>
+# Maintainer: Aitor Alonso <mail@aalonso.pw>
+# Contributor: Andrew Chen <andrew.chuanye.chen@gmail.com>
# Contributor: mmm
# Contributor: Dan McGee <dan@archlinux.org>
pkgname=weka
-pkgver=3.8.1
+pkgver=3.8.2
_dlver=${pkgver//./-}
pkgrel=1
pkgdesc="A collection of machine learning algorithms for data mining tasks"
@@ -15,7 +16,7 @@ makedepends=('java-environment' 'gif2png')
source=(http://downloads.sourceforge.net/sourceforge/weka/$pkgname-$_dlver.zip
weka.sh
weka.desktop)
-md5sums=('e9542ebadb41594ba23729b741fffa7f'
+md5sums=('491f1efa03a6406f524f934d481059d6'
'60dc5666b93d98db0900deb7d8b5eae4'
'83a4d47ba64df90a92a38b23a14c6480')
diff --git a/weka.sh b/weka.sh
index 7b70a33d9966..d18250d9406b 100755
--- a/weka.sh
+++ b/weka.sh
@@ -1,11 +1,11 @@
#! /bin/sh
-# Note: the '-Xmx1g' flag is used to set the maximum memory that the java
+# Note: the '-Xmx2g' flag is used to set the maximum memory that the java
# program is allowed. When working with large data sets, this number may need
# to be increased based on how much memory you wish to allow weka to have.
# Specifying command line arguments will override the defaults shown here.
-# Example: '-Xmx2g'
-DEFAULT_ARGS='-Xms32m -Xmx1g'
+# Example: '-Xmx4g'
+DEFAULT_ARGS='-Xms32m -Xmx2g'
if [ $# -gt 0 ]; then
ARGS="$@"