summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFredy García2018-12-30 15:55:16 -0500
committerFredy García2018-12-30 15:55:16 -0500
commitd9bbfffd9751cc865506021775ac469477f32015 (patch)
tree0d5649acf782fe281558e3a39dd920a0ddf4b931
parentb0e14b0478f4078b9d1a15e4e1f00c344ac93985 (diff)
downloadaur-d9bbfffd9751cc865506021775ac469477f32015.tar.gz
Adding dependencies, using full path in cmake.
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD18
2 files changed, 14 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6b52f3fe5003..09441a0be0fb 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,24 +1,27 @@
pkgbase = welle.io-git
pkgdesc = An open source DAB and DAB+ software defined radio (SDR) with support for rtl-sdr (RTL2832U) and airspy
- pkgver = 1.0.r21.0141eb1
+ pkgver = 2.0.beta1.r0.f00230c
pkgrel = 1
url = https://www.welle.io
arch = x86_64
license = GPL2
- makedepends = gcc
makedepends = cmake
+ makedepends = gcc
makedepends = git
depends = faad2
depends = fftw
+ depends = hicolor-icon-theme
+ depends = lame
+ depends = mpg123
depends = qt5-charts
- depends = qt5-multimedia
depends = qt5-quickcontrols
depends = qt5-quickcontrols2
+ depends = qt5-multimedia
depends = rtl-sdr
optdepends = airspy
provides = welle.io
conflicts = welle.io
- source = welle.io::git://github.com/AlbrechtL/welle.io
+ source = welle.io::git+https://github.com/AlbrechtL/welle.io
sha256sums = SKIP
pkgname = welle.io-git
diff --git a/PKGBUILD b/PKGBUILD
index 42a4afa6a483..9d95013c609f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,19 +1,19 @@
# Maintainer: Fredy García <frealgagu at gmail dot com>
-# Maintainer: Daniel Strobl <danielstrobl:gmail>
+# Contributor: Daniel Strobl <danielstrobl:gmail>
pkgname=welle.io-git
-pkgver=1.0.r21.0141eb1
+pkgver=2.0.beta1.r0.f00230c
pkgrel=1
pkgdesc="An open source DAB and DAB+ software defined radio (SDR) with support for rtl-sdr (RTL2832U) and airspy"
arch=("x86_64")
url="https://www.${pkgname%-git}"
license=("GPL2")
-depends=("faad2" "fftw" "qt5-charts" "qt5-multimedia" "qt5-quickcontrols" "qt5-quickcontrols2" "rtl-sdr")
+depends=("faad2" "fftw" "hicolor-icon-theme" "lame" "mpg123" "qt5-charts" "qt5-quickcontrols" "qt5-quickcontrols2" "qt5-multimedia" "rtl-sdr")
optdepends=("airspy")
-makedepends=("gcc" "cmake" "git")
+makedepends=("cmake" "gcc" "git")
provides=("${pkgname%-git}")
conflicts=("${pkgname%-git}")
-source=("${pkgname%-git}::git://github.com/AlbrechtL/${pkgname%-git}")
+source=("${pkgname%-git}::git+https://github.com/AlbrechtL/${pkgname%-git}")
sha256sums=("SKIP")
pkgver() {
@@ -27,16 +27,12 @@ pkgver() {
build() {
mkdir -p "${srcdir}/${pkgname%-git}/build"
- cd "${pkgname%-git}/build"
- cmake .. -DRTLSDR=1
+ cd "${srcdir}/${pkgname%-git}/build"
+ cmake "${srcdir}/${pkgname%-git}" -DRTLSDR=1
make
}
package() {
- install -D -m 0644 "${srcdir}/${pkgname%-git}/${pkgname/%.io-git/-io}.desktop" "${pkgdir}/usr/share/applications/${pkgname/%.io-soapysdr-git/-io}.desktop"
-
- install -D -m 0644 "${srcdir}/${pkgname%-git}/icon.png" "${pkgdir}/usr/share/pixmaps/${pkgname/%.io-soapysdr-git/-io}.png"
-
cd "${srcdir}/${pkgname%-git}/build"
make DESTDIR=${pkgdir} install