summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorfrealgagu2018-04-02 13:51:58 -0500
committerfrealgagu2018-04-02 13:51:58 -0500
commit26db1b854e6aa939450f916b4c1ed45926457c84 (patch)
tree56964bbad70c0b05a215ee1fd2cdda59602b9dcb
parent488089131cca126c42ca7855e1cf33f51628c1e6 (diff)
downloadaur-26db1b854e6aa939450f916b4c1ed45926457c84.tar.gz
Installing in /usr/bin instead of /usr/local/bin according to Arch packaging standards
-rw-r--r--.SRCINFO10
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD19
3 files changed, 22 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ae1d65ea6241..e59124714b9b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,23 +1,21 @@
pkgbase = welle.io-soapysdr
- pkgdesc = Open source DAB and DAB+ software defined radio (SDR) with support for rtl-sdr (RTL2832U) and airspy (including SoapySDR)
+ pkgdesc = An open source DAB and DAB+ software defined radio (SDR) with support for rtl-sdr (RTL2832U) and airspy (including SoapySDR)
pkgver = 1.0
- pkgrel = 2
+ pkgrel = 3
url = https://www.welle.io
- arch = any
+ arch = x86_64
license = GPL2
makedepends = gcc
makedepends = cmake
depends = faad2
depends = fftw
- depends = libusb
- depends = qt5-base
depends = qt5-charts
depends = qt5-declarative
depends = qt5-multimedia
- depends = qt5-quickcontrols2
depends = rtl-sdr
depends = soapysdr-git
optdepends = airspy
+ optdepends = qt5-quickcontrols2
optdepends = soapyairspy-git
optdepends = soapybladerf-git
optdepends = soapyhackrf-git
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..2a45b6bdb393
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+welle.io-soapysdr-*.pkg.tar.xz
+welle.io-*.tar.gz
+pkg/
+src/
diff --git a/PKGBUILD b/PKGBUILD
index c1caaf7a265a..79cd5aec6e56 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,14 +2,14 @@
pkgname=welle.io-soapysdr
pkgver=1.0
-pkgrel=2
-pkgdesc="Open source DAB and DAB+ software defined radio (SDR) with support for rtl-sdr (RTL2832U) and airspy (including SoapySDR)"
-arch=("any")
+pkgrel=3
+pkgdesc="An open source DAB and DAB+ software defined radio (SDR) with support for rtl-sdr (RTL2832U) and airspy (including SoapySDR)"
+arch=("x86_64")
url="https://www.${pkgname%-soapysdr}"
license=("GPL2")
-depends=("faad2" "fftw" "libusb" "qt5-base" "qt5-charts" "qt5-declarative" "qt5-multimedia" "qt5-quickcontrols2" "rtl-sdr" "soapysdr-git")
+depends=("faad2" "fftw" "qt5-charts" "qt5-declarative" "qt5-multimedia" "rtl-sdr" "soapysdr-git")
+optdepends=("airspy" "qt5-quickcontrols2" "soapyairspy-git" "soapybladerf-git" "soapyhackrf-git" "soapylms7-git" "soapyosmo-git" "soapyplutosdr-git" "soapyrtlsdr-git" "soapysdrplay-git")
makedepends=("gcc" "cmake")
-optdepends=("airspy" "soapyairspy-git" "soapybladerf-git" "soapyhackrf-git" "soapylms7-git" "soapyosmo-git" "soapyplutosdr-git" "soapyrtlsdr-git" "soapysdrplay-git")
provides=("${pkgname%-soapysdr}")
conflicts=("${pkgname%-soapysdr}")
source=("${pkgname%-soapysdr}-${pkgver}.tar.gz::https://github.com/AlbrechtL/${pkgname%-soapysdr}/archive/V${pkgver}.tar.gz")
@@ -23,8 +23,17 @@ build() {
}
package() {
+ msg2 "Installing desktop file into /usr/share/applications/"
install -D -m 0644 "${srcdir}/${pkgname%-soapysdr}-${pkgver}/${pkgname/%.io-soapysdr/-io}.desktop" "${pkgdir}/usr/share/applications/${pkgname/%.io-soapysdr/-io}.desktop"
+
+ msg2 "Installing icon into /usr/share/pixmaps/"
install -D -m 0644 "${srcdir}/${pkgname%-soapysdr}-${pkgver}/icon.png" "${pkgdir}/usr/share/pixmaps/${pkgname/%.io-soapysdr/-io}.png"
+
+ msg2 "Installing application"
cd "${pkgname%-soapysdr}-${pkgver}/build"
make DESTDIR=${pkgdir} install
+
+ msg2 "Moving from /usr/local/bin to /usr/bin to match Arch packaging standards"
+ mv "${pkgdir}/usr/local/"* "${pkgdir}/usr/"
+ rm -r "${pkgdir}/usr/local"
}