summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorfrealgagu2018-03-10 02:05:48 -0500
committerfrealgagu2018-03-10 02:05:48 -0500
commit915056b861abf1dc0ddc209851fe9380faf83a47 (patch)
treefdbd335b8febd264a89de9ab36f498779445d17d
downloadaur-915056b861abf1dc0ddc209851fe9380faf83a47.tar.gz
Initial commit version 1.0
-rw-r--r--.SRCINFO32
-rw-r--r--PKGBUILD39
2 files changed, 71 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8aad5a9cd605
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,32 @@
+pkgbase = welle.io-soapysdr
+ pkgdesc = Open source DAB and DAB+ software defined radio (SDR) with support for rtl-sdr (RTL2832U) and airspy (including SoapySDR)
+ pkgver = 1.0
+ pkgrel = 1
+ url = https://www.welle.io/
+ arch = any
+ license = GPL2
+ makedepends = gcc
+ makedepends = cmake
+ depends = qt5-base
+ depends = qt5-charts
+ depends = fftw
+ depends = faad2
+ depends = rtl-sdr
+ depends = libusb
+ depends = soapysdr-git
+ optdepends = airspy
+ optdepends = soapyairspy-git
+ optdepends = soapybladerf-git
+ optdepends = soapyhackrf-git
+ optdepends = soapylms7-git
+ optdepends = soapyosmo-git
+ optdepends = soapyplutosdr-git
+ optdepends = soapyrtlsdr-git
+ optdepends = soapysdrplay-git
+ provides = welle.io
+ conflicts = welle.io
+ source = https://github.com/AlbrechtL/welle.io/archive/V1.0.tar.gz
+ sha256sums = 669ae5d471f723c32622cbf6ee37b66c3aefd8e02d6334b55d1fb60b3c22a883
+
+pkgname = welle.io-soapysdr
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c9d8ae18229f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# Maintainer: Fredy GarcĂ­a <frealgagu at gmail dot com>
+pkgname=welle.io-soapysdr
+pkgver=1.0
+pkgrel=1
+pkgdesc="Open source DAB and DAB+ software defined radio (SDR) with support for rtl-sdr (RTL2832U) and airspy (including SoapySDR)"
+_pkgnameorig=welle.io
+_pkgname=welle-io
+arch=('any')
+url="https://www.welle.io/"
+license=('GPL2')
+depends=('qt5-base' 'qt5-charts' 'fftw' 'faad2' 'rtl-sdr' 'libusb' 'soapysdr-git')
+makedepends=('gcc' 'cmake')
+optdepends=('airspy'
+ 'soapyairspy-git'
+ 'soapybladerf-git'
+ 'soapyhackrf-git'
+ 'soapylms7-git'
+ 'soapyosmo-git'
+ 'soapyplutosdr-git'
+ 'soapyrtlsdr-git'
+ 'soapysdrplay-git')
+provides=('welle.io')
+conflicts=('welle.io')
+source=("https://github.com/AlbrechtL/welle.io/archive/V${pkgver}.tar.gz")
+sha256sums=('669ae5d471f723c32622cbf6ee37b66c3aefd8e02d6334b55d1fb60b3c22a883')
+
+build() {
+ mkdir -p ${_pkgnameorig}-${pkgver}/build
+ cd ${_pkgnameorig}-${pkgver}/build
+ cmake .. -DRTLSDR=1 -DSOAPYSDR=1
+ make
+}
+
+package() {
+ install -D -m 0644 ${srcdir}/${_pkgnameorig}-${pkgver}/${_pkgname}.desktop ${pkgdir}/usr/share/applications/${_pkgname}.desktop
+ install -D -m 0644 ${srcdir}/${_pkgnameorig}-${pkgver}/icon.png ${pkgdir}/usr/share/pixmaps/${_pkgname}.png
+ cd ${_pkgnameorig}-${pkgver}/build
+ make DESTDIR=${pkgdir} install
+}