summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJeff Wright2021-03-24 14:23:30 -0700
committerJeff Wright2021-03-24 14:23:30 -0700
commit2c8154dc03386990e3bd062aac2aa9cc45bccdad (patch)
tree95d23ccd14ae520155a3ddb627884a78519841eb
downloadaur-2c8154dc03386990e3bd062aac2aa9cc45bccdad.tar.gz
0.2.6 initial PKGBUILD
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD37
2 files changed, 51 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..69042336d24a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = wesher
+ pkgdesc = Create and manage an encrypted mesh overlay network using wireguard
+ pkgver = 0.2.6
+ pkgrel = 1
+ url = https://github.com/costela/wesher
+ arch = x86_64
+ license = GPL
+ makedepends = go
+ depends = gcc-libs
+ source = wesher-0.2.6.tar.gz::https://github.com/costela/wesher/archive/refs/tags/v0.2.6.tar.gz
+ md5sums = 209febe054a716466ac9987081e01eac
+
+pkgname = wesher
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..09abeefd018c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: Jeff Wright <jeff@teamjk.page>
+pkgname=wesher
+pkgver=0.2.6
+pkgrel=1
+pkgdesc='Create and manage an encrypted mesh overlay network using wireguard'
+arch=('x86_64')
+url="https://github.com/costela/$pkgname"
+license=('GPL')
+makedepends=('go')
+depends=('glibc')
+source=("$pkgname-$pkgver.tar.gz::$url/archive/refs/tags/v$pkgver.tar.gz")
+
+prepare(){
+ cd "$pkgname-$pkgver"
+ mkdir -p build/
+}
+
+build() {
+ cd "$pkgname-$pkgver"
+ export CGO_CPPFLAGS="${CPPFLAGS}"
+ export CGO_CFLAGS="${CFLAGS}"
+ export CGO_CXXFLAGS="${CXXFLAGS}"
+ export CGO_LDFLAGS="${LDFLAGS}"
+ export GOFLAGS="-buildmode=pie -trimpath -ldflags=-linkmode=external -mod=readonly -modcacherw"
+ go build -o build ./...
+}
+
+check() {
+ cd "$pkgname-$pkgver"
+ go test ./...
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+ install -Dm755 build/$pkgname "$pkgdir"/usr/bin/$pkgname
+}
+md5sums=('209febe054a716466ac9987081e01eac')