summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSeverin Glöckner2018-12-24 21:08:47 +0100
committerSeverin Glöckner2018-12-26 13:55:39 +0100
commitbdd46bc2e49854997b1454c2404468721e97d5a8 (patch)
tree7795c716d0317bea2d2cb1817bedec4d60adb62f
downloadaur-bdd46bc2e49854997b1454c2404468721e97d5a8.tar.gz
inital AUR release
requires an old compiler
-rw-r--r--.SRCINFO26
-rw-r--r--PKGBUILD106
-rw-r--r--wesnoth-1.2.appdata.xml61
-rw-r--r--wesnoth-1.2.desktop94
-rw-r--r--wesnothd-1.2.service37
-rw-r--r--wesnothd-1.2.tmpfiles.conf5
6 files changed, 329 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..fa5806486c65
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,26 @@
+pkgbase = wesnoth-1.2
+ pkgdesc = Turn-based strategy game on a fantasy world (for old replays)
+ pkgver = 1.2.8+dev
+ pkgrel = 1
+ url = https://www.wesnoth.org
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = gcc43
+ depends = sdl
+ depends = sdl_image
+ depends = sdl_mixer
+ depends = sdl_net
+ depends = freetype2
+ options = !emptydirs
+ source = wesnoth-1.2.desktop
+ source = wesnothd-1.2.tmpfiles.conf
+ source = wesnothd-1.2.service
+ source = wesnoth-1.2.appdata.xml
+ md5sums = c3ba9b84c818bba105b0ea236b1d3744
+ md5sums = d23cafae5c732d6bf10a836bdabd15b9
+ md5sums = a1831302d36c5d5ddffcf76c42483e1d
+ md5sums = b6dfb0e146e6ac3a265487b6e32e9766
+
+pkgname = wesnoth-1.2
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c3e4d0795d70
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,106 @@
+# Maintainer Severin Glöckner <severin.gloeckner@stud.htwk-leipzig.de>
+
+# This doesn't compile with gcc 4.5, 4.9 or the current versions of gcc or clang.
+# It does compile with gcc 4.3.
+
+pkgname=wesnoth-1.2
+pkgver=1.2.8+dev
+pkgrel=1
+pkgdesc="Turn-based strategy game on a fantasy world (for old replays)"
+arch=('i686' 'x86_64')
+url="https://www.wesnoth.org"
+license=('GPL')
+depends=('sdl' 'sdl_image' 'sdl_mixer' 'sdl_net' 'freetype2')
+makedepends=('gcc43')
+options=('!emptydirs')
+source=("wesnoth-1.2.desktop"
+ "wesnothd-1.2.tmpfiles.conf"
+ "wesnothd-1.2.service"
+ "wesnoth-1.2.appdata.xml")
+
+md5sums=('c3ba9b84c818bba105b0ea236b1d3744'
+ 'd23cafae5c732d6bf10a836bdabd15b9'
+ 'a1831302d36c5d5ddffcf76c42483e1d'
+ 'b6dfb0e146e6ac3a265487b6e32e9766')
+
+PKGEXT='.pkg.tar'
+
+prepare() {
+ cd "$startdir"
+
+ # get a shallow clone of the git repo and store it outside the srcdir
+ if [ ! -d "wesnoth-1.2-git" ] ; then
+ git clone https://github.com/wesnoth/wesnoth -b 1.2 --shallow-exclude=1.2.8 wesnoth-1.2-git
+ msg "Git checkout done (or server timeout)"
+ fi
+
+ # Archlinux specific (hide the usage of the deprecated $startdir variable)
+ if [ ! -e "$srcdir/wesnoth-1.2-git" ] ; then
+ ln -s "$startdir/wesnoth-1.2-git" "$srcdir/wesnoth-1.2-git"
+ fi
+
+ # clean up previous builds, in case different flags or library versions were
+ # used before. (|| true avoids failure if the makefile is not yet generated.)
+ cd "$srcdir/wesnoth-1.2-git"
+ make distclean || true
+}
+
+build() {
+ cd "$srcdir/wesnoth-1.2-git"
+ # As this is an older version and not worked on anymore, it will someday break
+ # If you happen to find a fix, please fill a Pull Request for the 1.2 branch
+ # at bugs.wesnoth.org
+
+ # Archs default flags are too new for the old compiler
+ unset CFLAGS CXXFLAGS
+ export CXXFLAGS="-w -pipe"
+
+ export CC=gcc-4.3
+ export CXX=g++-4.3
+
+ ./autogen.sh
+ ./configure --with-freetype-prefix=/usr/lib --prefix=/usr --with-preferences-dir=.local/share/wesnoth/1.2 --program-suffix=-1.2 --with-datadir-name=wesnoth-1.2 --enable-editor --enable-server --with-fifodir=/run/wesnothd-1.2
+ make -j4
+}
+
+# These commands have to be run with root privileges.
+# E.g. by prefixing them with "sudo ".
+package() {
+ cd "$srcdir/wesnoth-1.2-git"
+
+ # On Debian / Ubuntu / Mint / Fedora / Suse, just "make install"
+ make DESTDIR="$pkgdir" install
+
+ # The manpages have no suffix by default, so they have the same name like
+ # the manpages of other wesnoth installations. To avoid conflicts, rename
+ # (or delete) them.
+ # Note that you can do this only the installation step shown above, as the
+ # command will fail if it doesn't find these files.
+ for filename in "$pkgdir"/usr/share/man/{,*/}man6/wesnoth{,d,_editor}.6
+ do
+ mv "$filename" $(dirname $filename)/$(basename $filename .6)-1.2.6
+ done
+
+ # use the tools from a recent version of wesnoth, where they received patches
+ rm -r "$pkgdir/usr/share/wesnoth-1.2/data/tools"
+
+ # remove unneeded files
+ find "$pkgdir/usr/share" -name .gitignore -delete
+
+ # placing launcher, icons and (not required) appdata and systemd files
+ install -D -m644 "$srcdir/wesnoth-1.2.desktop" "$pkgdir/usr/share/applications/wesnoth-1.2.desktop"
+ install -D -m644 "$srcdir/wesnoth-1.2-git/icons/wesnoth-icon.png" "$pkgdir/usr/share/icons/hicolor/64x64/apps/wesnoth-1.2-icon.png"
+ install -D -m644 "$srcdir/wesnoth-1.2-git/icons/wesnoth-icon-Mac.png" "$pkgdir/usr/share/icons/hicolor/128x128/apps/wesnoth-1.2-icon.png"
+
+ # On Debian / Ubuntu / Mint, the two files go into /etc instead of /usr/lib
+ install -D -m644 "$srcdir/wesnothd-1.2.tmpfiles.conf" "$pkgdir/usr/lib/tmpfiles.d/wesnothd-1.2.conf"
+ # On Debian / Ubuntu / Mint, edit the file and change:
+ # Group=nobody to Group=nogroup
+ # /usr/bin/rm to /bin/rm
+ install -D -m644 "$srcdir/wesnothd-1.2.service" "$pkgdir/usr/lib/systemd/system/wesnothd-1.2.service"
+
+ install -D -m644 "$srcdir/wesnoth-1.2.appdata.xml" "$pkgdir/usr/share/metainfo/wesnoth-1.2.appdata.xml"
+
+ # All done, but it doesn't show up? Try that:
+ # update-desktop-database
+}
diff --git a/wesnoth-1.2.appdata.xml b/wesnoth-1.2.appdata.xml
new file mode 100644
index 000000000000..538534464483
--- /dev/null
+++ b/wesnoth-1.2.appdata.xml
@@ -0,0 +1,61 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<component type="desktop">
+ <id>wesnoth-1.2.desktop</id>
+ <metadata_license>GFDL-1.3</metadata_license>
+ <project_license>GPL-2.0-or-later</project_license>
+ <name>Battle for Wesnoth (1.2)</name>
+ <name xml:lang="de">Battle for Wesnoth (1.2)</name>
+ <name xml:lang="es">La batalla por Wesnoth (1.2)</name>
+ <name xml:lang="fr">La Bataille pour Wesnoth (1.2)</name>
+ <name xml:lang="hu">Harc Wesnothért (1.2)</name>
+ <name xml:lang="pl">Bitwa o Wesnoth (1.2)</name>
+ <name xml:lang="ru">Битва за Веснот (1.2)</name>
+ <summary>A turn-based strategy game with a high fantasy theme</summary>
+ <summary xml:lang="de">Ein rundenbasierendes Strategiespiel mit Fantasy-Thematik</summary>
+ <summary xml:lang="es">Un juego de estrategia basado en turnos con un tema de fantasía</summary>
+ <summary xml:lang="fr">Un jeu de stratégie au tour par tour dans un univers fantastique</summary>
+ <summary xml:lang="hu">Fantasy stílusú, körökre osztott, stratégiai játék</summary>
+ <summary xml:lang="pl">Bitwa o Wesnoth to turowa strategia w klimatach fantasy</summary>
+ <summary xml:lang="ru">Фантастическая пошаговая стратегия</summary>
+ <description>
+ Wesnoth at the time of series 1.2…
+ </description>
+ <screenshots>
+ <screenshot type="default">
+ <image type="source" width="1024" height="768">https://www.wesnoth.org/images/sshots/wesnoth-1.3.13-1.jpg</image>
+ </screenshot>
+ <screenshot>
+ <image type="source" width="1024" height="768">https://www.wesnoth.org/images/sshots/wesnoth-1.3.13-2.jpg</image>
+ </screenshot>
+ <screenshot>
+ <image type="source" width="1024" height="768">https://www.wesnoth.org/images/sshots/wesnoth-1.3.13-3.jpg</image>
+ </screenshot>
+ <screenshot>
+ <image type="source" width="1024" height="768">https://www.wesnoth.org/images/sshots/wesnoth-1.3.13-4.jpg</image>
+ </screenshot>
+ <screenshot>
+ <image type="source" width="1024" height="768">https://www.wesnoth.org/images/sshots/wesnoth-1.3.13-5.jpg</image>
+ </screenshot>
+ </screenshots>
+ <categories>
+ <category>Game</category>
+ <category>StrategyGame</category>
+ </categories>
+ <launchable type="desktop-id">wesnoth-1.2.desktop</launchable>
+ <url type="homepage">https://www.wesnoth.org</url>
+ <url type="faq">https://wiki.wesnoth.org/Play</url>
+ <url type="help">https://wiki.wesnoth.org/WesnothManual</url>
+ <url type="translate">https://wiki.wesnoth.org/WesnothTranslations</url>
+ <url type="bugtracker">https://bugs.wesnoth.org</url>
+ <project_group>Wesnoth</project_group>
+ <developer_name>The Battle for Wesnoth Project</developer_name>
+ <translation>wesnoth</translation>
+ <kudos>
+ <kudo>HiDpiIcon</kudo>
+ </kudos>
+ <provides>
+ <binary>wesnoth-1.2</binary>
+ <binary>wesnothd-1.2</binary>
+ <binary>wesnoth_editor-1.2</binary>
+ </provides>
+</component>
diff --git a/wesnoth-1.2.desktop b/wesnoth-1.2.desktop
new file mode 100644
index 000000000000..8577dcfd2899
--- /dev/null
+++ b/wesnoth-1.2.desktop
@@ -0,0 +1,94 @@
+[Desktop Entry]
+Version=1.0
+Type=Application
+Name=Battle for Wesnoth
+Name[af]=Die Stryd vir Wesnoth (1.2)
+Name[ca]=Batalla per Wesnoth (1.2)
+Name[cs]=Bitva o Wesnoth (1.2)
+Name[de]=Battle for Wesnoth (1.2)
+Name[dk]=Kampen om Wesnoth (1.2)
+Name[es]=La batalla por Wesnoth (1.2)
+Name[eu]=Wesnotheko Guda (1.2)
+Name[fi]=Taistelu Wesnothista (1.2)
+Name[fr]=La Bataille pour Wesnoth (1.2)
+Name[gl]=A batalla polo Noroeste (1.2)
+Name[he]=הקרב על ווסנות' (1.2)
+Name[hu]=Harc Wesnothért (1.2)
+Name[it]=Battle for Wesnoth (1.2)
+Name[lt]=Mūšis dėl Vesnoto (1.2)
+Name[pt]=A Batalha por Wesnoth (1.2)
+Name[ru]=Битва за Веснот (1.2)
+Name[sk]=Bitka o Wesnoth (1.2)
+Name[sr]=Бој за Веснот (1.2)
+Name[sr@ijekavian]=Бој за Веснот (1.2)
+Name[sr@ijekavianlatin]=Boj za Vesnot (1.2)
+Name[sr@latin]=Boj za Vesnot (1.2)
+Name[tr]=Wesnoth Savaşı (1.2)
+Name[vi]=Trận chiến vì Wesnoth (1.2)
+GenericName=Strategy Game
+GenericName[af]=Strategie-spel
+GenericName[ca]=Joc d'estrategia
+GenericName[cs]=Strategická hra
+GenericName[de]=Strategiespiel
+GenericName[dk]=Strategi-spil
+GenericName[es]=Juego de estrategia
+GenericName[eu]=Estrategiako jokoa
+GenericName[fi]=Strategiapeli
+GenericName[fr]=Jeu de stratégie
+GenericName[gl]=Xogo de estratexia
+GenericName[he]=משחק אסטרטגיה
+GenericName[hu]=Stratégia
+GenericName[it]=Gioco strategico
+GenericName[lt]=Strateginis žaidimas
+GenericName[pt]=Jogo de Estratégia
+GenericName[ru]=Стратегическая игра
+GenericName[sk]=Strategická hra
+GenericName[sr]=Стратешка игра
+GenericName[sr@latin]=Strateška igra
+GenericName[tr]=Strateji Oyunu
+GenericName[vi]=Trò chơi chiến lược
+Comment=A fantasy turn-based strategy game
+Comment[af]='n Fantasie beurt-basis strategie-spel
+Comment[ca]=Un joc fantàstic d'estrategia per torns
+Comment[cs]=Tahová strategická hra ve fantastickém prostředí
+Comment[de]=Rundenbasiertes Strategiespiel im Fantasyszenario
+Comment[dk]=Et fantasy træk-baseret strategi-spil
+Comment[es]=Un juego de estrategia basado en turnos con un tema de fantasía
+Comment[eu]=Giro fantastikoan eta txandetan oinarritutako estrategia jokoa
+Comment[fi]=Vuoropohjainen fantasiastrategiapeli
+Comment[fr]=Un jeu de stratégie au tour par tour dans un univers fantastique
+Comment[gl]=Xogo de estratexia por quendas ambientado nun mundo fantástico.
+Comment[he]=משחק אסטרטגיה ופנטסיה מבוסס מהלכים
+Comment[hu]=Fantasy stílusú, körökre osztott, stratégiai játék
+Comment[it]=Un gioco strategico a turni con ambientazione fantasy
+Comment[lt]=Fantastinis ėjimais pagrįstas strateginis žaidimas
+Comment[pt]=Um jogo de fantasia estratégico em turnos
+Comment[ru]=Фантастическая пошаговая стратегия
+Comment[sk]=Ťahová strategická hra z prostredia fantasy
+Comment[sr]=Фантазијска стратешка игра на потезе
+Comment[sr@latin]=Fantazijska strateška igra na poteze
+Comment[tr]=Fantastik, sırayla oynanan bir strateji oyunu
+Comment[vi]=Một trò chơi chiến lược dựa trên lượt đi theo phong cách thần thoại
+Icon=wesnoth-1.2-icon
+Exec=sh -c "wesnoth-1.2 >/dev/null 2>&1"
+Categories=Game;StrategyGame;
+Actions=Editor;
+
+[Desktop Action Editor]
+Name=Map Editor
+Name[cs]=Editor map
+Name[de]=Karteneditor
+Name[es]=Editor de mapas
+Name[fi]=Kenttäeditori
+Name[fr]=Éditeur de cartes
+Name[gl]=Editor de mapas
+Name[hu]=pályaszerkesztő
+Name[it]=Editor delle mappe
+Name[lt]=žemėlapių redaktorius
+Name[pt]=Editor de mapas
+Name[sr]=Уређивач мапа
+Name[sr@ijekavian]=Уређивач мапа
+Name[sr@ijekavianlatin]=Uređivač mapa
+Name[sr@latin]=Uređivač mapa
+Name[tr]=Harita Düzenleyici
+Exec=sh -c "wesnoth_editor-1.2 >/dev/null 2>&1"
diff --git a/wesnothd-1.2.service b/wesnothd-1.2.service
new file mode 100644
index 000000000000..c0b057d7897a
--- /dev/null
+++ b/wesnothd-1.2.service
@@ -0,0 +1,37 @@
+[Unit]
+Description=Wesnoth-1.2 Server Daemon
+Documentation=https://www.wesnoth.org/wiki/ServerAdministration
+Documentation=man:wesnoth-1.2(6)
+After=network.target
+# They use by default the same port
+Conflicts=wesnothd.service wesnothd-1.0.service wesnothd-1.4.service wesnothd-1.6.service wesnothd-1.8.service wesnothd-1.10.service wesnothd-1.12.service wesnothd-1.14.service wesnothd-devel.service wesnothd-git.service
+
+[Service]
+ExecStart=/usr/bin/wesnothd-1.2 -t 2 -T 5
+# you can use -c to specify the same configuration file
+# which is used when starting wensothd from the wesnoth UI
+# (and make sure wesnothd has the required access permissions)
+
+SyslogIdentifier=Wesnothd-1.2
+User=nobody
+Group=users
+ExecStopPost=/usr/bin/rm -f /run/wesnothd-1.2/socket
+
+# Additional security-related features
+ProtectSystem=yes
+ProtectHome=yes # disable this if using the -c option
+PrivateTmp=yes
+PrivateDevices=yes
+NoNewPrivileges=yes
+RestrictAddressFamilies=AF_INET AF_UNIX
+RestrictRealtime=yes
+MemoryDenyWriteExecute=yes
+SystemCallArchitectures=native
+ProtectControlGroups=yes
+ProtectKernelTunables=yes
+ProtectKernelModules=yes
+RestrictNamespaces=yes
+LockPersonality=yes
+
+[Install]
+WantedBy=multi-user.target
diff --git a/wesnothd-1.2.tmpfiles.conf b/wesnothd-1.2.tmpfiles.conf
new file mode 100644
index 000000000000..3e6b2b5b88e5
--- /dev/null
+++ b/wesnothd-1.2.tmpfiles.conf
@@ -0,0 +1,5 @@
+# This directory is used to store a named pipe, which accepts administration commands
+# See https://wiki.wesnoth.org/ServerAdministration (without /query)
+#
+# wesnothd can either be started by the systemd service file or the wesnoth UI
+d /run/wesnothd-1.2 0770 nobody users -