summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSeverin Glöckner2018-12-31 14:11:40 +0100
committerSeverin Glöckner2018-12-31 14:11:40 +0100
commitf7c5b775f47e8bbfc15640aa24ca71160e52917d (patch)
tree0b76186395246bb6565c32ce8f537121b0c84274
parent1cc738059ad48ec007977f622b2a062fa914ff76 (diff)
downloadaur-f7c5b775f47e8bbfc15640aa24ca71160e52917d.tar.gz
service: fix pipe management
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD4
-rw-r--r--wesnothd-1.2.service13
3 files changed, 12 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6883d35f70a6..27c9ab5dbc9a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -19,7 +19,7 @@ pkgbase = wesnoth-1.2
source = wesnoth-1.2.appdata.xml
md5sums = c3ba9b84c818bba105b0ea236b1d3744
md5sums = d23cafae5c732d6bf10a836bdabd15b9
- md5sums = 64a072ffd085f2b5af5110fc5b41ab37
+ md5sums = f75bef73c448e101b09beb8ad92c791e
md5sums = b6dfb0e146e6ac3a265487b6e32e9766
pkgname = wesnoth-1.2
diff --git a/PKGBUILD b/PKGBUILD
index a2a5b7382706..f8b847ead908 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -17,10 +17,12 @@ source=("wesnoth-1.2.desktop"
"wesnothd-1.2.tmpfiles.conf"
"wesnothd-1.2.service"
"wesnoth-1.2.appdata.xml")
+# Not finding the files? https://aur.archlinux.org/packages/wesnoth-1.2
+# Rest assured, they are optional. Things like a launcher for your convenience…
md5sums=('c3ba9b84c818bba105b0ea236b1d3744'
'd23cafae5c732d6bf10a836bdabd15b9'
- '64a072ffd085f2b5af5110fc5b41ab37'
+ 'f75bef73c448e101b09beb8ad92c791e'
'b6dfb0e146e6ac3a265487b6e32e9766')
PKGEXT='.pkg.tar'
diff --git a/wesnothd-1.2.service b/wesnothd-1.2.service
index c948a2b0b067..9a6ae60f9f40 100644
--- a/wesnothd-1.2.service
+++ b/wesnothd-1.2.service
@@ -9,19 +9,22 @@ Conflicts=wesnothd.service wesnothd-1.0.service wesnothd-1.4.service wesnothd-1.
[Service]
# If wesnothd is started from within the game it runs under a different user
# Deleting the pipe resets owner, group and mode
-ExecStopPre=/bin/rm -f /run/wesnothd-1.2/socket
+ExecStartPre=/bin/rm -f /run/wesnothd-1.2/socket
-ExecStart=/usr/bin/wesnothd-1.2 -t 2 -T 5
+ExecStart=/usr/bin/wesnothd-1.2
# you can use -c to specify a configuration file
# (and make sure wesnothd has the required access permissions)
+# Remove remaining administration pipe
+ExecStopPost=/bin/rm -f /run/wesnothd-1.2/socket
+
SyslogIdentifier=Wesnothd-1.2
+# Apply security settings only to ExecStart, so the Pre & Post steps run as root
+PermissionsStartOnly=yes
+WorkingDirectory=/run/wesnothd-1.2
User=nobody
Group=users
-# Remove remaining administration pipe
-ExecStopPost=/bin/rm -f /run/wesnothd-1.2/socket
-
# Additional security-related features
ProtectSystem=strict
ProtectHome=yes