summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSeverin Glöckner2018-10-06 01:01:11 +0200
committerSeverin Glöckner2018-10-06 01:01:11 +0200
commit567ee5e0ffe85fedc25fdf7dc5d52b042692c5a5 (patch)
tree43997753a32a82475ce3089d3d76c1430d6930fd
downloadaur-567ee5e0ffe85fedc25fdf7dc5d52b042692c5a5.tar.gz
wesnoth 1.8 for archlinux
mainly for the purpose of viewing replay files
-rw-r--r--.SRCINFO40
-rw-r--r--PKGBUILD126
-rw-r--r--wesnoth-1.8.appdata.xml102
-rw-r--r--wesnoth-1.8.desktop94
-rw-r--r--wesnothd-1.8.service35
-rw-r--r--wesnothd-1.8.tmpfiles.conf5
6 files changed, 402 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..cb23c193ca31
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,40 @@
+pkgbase = wesnoth-1.8
+ pkgdesc = Turn-based strategy game on a fantasy world (legacy version for old replays)
+ pkgver = 1.8.6+dev
+ pkgrel = 5
+ url = https://www.wesnoth.org
+ arch = i686
+ arch = x86_64
+ license = GPL
+ checkdepends = desktop-file-utils
+ checkdepends = appstream-glib
+ makedepends = boost
+ makedepends = gettext
+ makedepends = cmake
+ makedepends = make
+ makedepends = git
+ depends = sdl
+ depends = sdl_image
+ depends = sdl_mixer
+ depends = sdl_ttf
+ depends = sdl_net
+ depends = boost-libs
+ depends = zlib
+ depends = pango
+ depends = cairo
+ depends = fontconfig
+ depends = dbus
+ depends = fribidi
+ depends = lua51
+ options = !emptydirs
+ source = wesnoth-1.8.desktop
+ source = wesnothd-1.8.tmpfiles.conf
+ source = wesnothd-1.8.service
+ source = wesnoth-1.8.appdata.xml
+ md5sums = 7fa59aab4ec96e6466dd276a76462e78
+ md5sums = a3afc892c43bbff72a9b150de513beaf
+ md5sums = 8f88ebc8879ba6aabf87baeefade4b41
+ md5sums = f11a61e8d08b11a954707a527f113af2
+
+pkgname = wesnoth-1.8
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..75eff92f1776
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,126 @@
+# Maintainer Severin Glöckner <severin dot gloeckner at stud dot htwk minus leipzig dot de>
+
+# BUILDING THIS PACKAGE REQUIRES THAT »lua« is not installed!
+
+# »lua52« does not cause problems, and »lua« being installed together with this package (after building) is fine
+
+# if Lua has been detected correctly, you will see a line such as:
+# -- Found Lua51: /usr/lib/liblua5.1.so;/usr/lib/libm.so (found version "5.1.5")
+
+# if the »lua« package is installed, the following will be shown instead:
+# -- Found Lua51: /usr/lib/liblua5.1.so;/usr/lib/libm.so (found version "")
+
+_suffix=-1.8
+pkgname=wesnoth-1.8
+pkgver=1.8.6+dev
+pkgrel=5
+pkgdesc="Turn-based strategy game on a fantasy world (legacy version for old replays)"
+arch=('i686' 'x86_64')
+url="https://www.wesnoth.org"
+license=('GPL')
+depends=('sdl' 'sdl_image' 'sdl_mixer' 'sdl_ttf' 'sdl_net' 'boost-libs' 'zlib' 'pango' 'cairo' 'fontconfig' 'dbus' 'fribidi' 'lua51')
+makedepends=('boost' 'gettext' 'cmake' 'make' 'git')
+checkdepends=('desktop-file-utils' 'appstream-glib')
+options=('!emptydirs')
+#options=('!emptydirs' '!strip') #use this when building with debugging symbols
+source=("wesnoth$_suffix.desktop"
+ "wesnothd$_suffix.tmpfiles.conf"
+ "wesnothd$_suffix.service"
+ "wesnoth$_suffix.appdata.xml")
+
+md5sums=('7fa59aab4ec96e6466dd276a76462e78'
+ 'a3afc892c43bbff72a9b150de513beaf'
+ '8f88ebc8879ba6aabf87baeefade4b41'
+ 'f11a61e8d08b11a954707a527f113af2')
+
+PKGEXT='.pkg.tar'
+
+prepare() {
+ msg ""
+ msg ""
+ msg ""
+ msg ""
+ msg "LUA DETECTEION DOES NOT WORK CORRECTLY IF YOU HAVE MULTIPLE VERSIONS OF LUA INSTALLED"
+ msg "YOU MUST REMOVE THE PACKAGE »lua« PRIOR TO BUILDING THIS PACKAGE"
+ msg ""
+ msg "you can use the following command for building"
+ msg "sudo pacman -Rdd lua && makepkg -sri --nocheck ; sudo pacman -S --asdeps lua"
+ msg ""
+ msg "THIS BUILD WILL FAIL LATER OTHERWISE"
+ msg ""
+ msg ""
+ msg ""
+ msg ""
+
+ cd "$startdir"
+ # get a shallow clone of the git repo and store it outside the srcdir
+ msg "Connecting to GIT server...."
+
+ if [ -d "$pkgname-git" ] ; then
+ cd "$pkgname-git" && git pull origin
+ msg "The local files are up to date"
+ else
+ git clone https://github.com/wesnoth/wesnoth -b 1.8 --shallow-exclude=1.8.6 --single-branch $pkgname-git
+ fi
+
+ msg "GIT checkout done or server timeout"
+}
+
+build() {
+ # As this is an older version and not worked on anymore, it will someday break
+ # If you happen to find a fix, please fill a Pull Request for the 1.8 branch
+ # at bugs.wesnoth.org
+
+ # silence compiler warnings - they are not going to be fixed
+ export CFLAGS="$CFLAGS -w"
+ export CXXFLAGS="$CXXFLAGS -w"
+
+ rm -rf "$srcdir/build" && mkdir -p "$srcdir/build" && cd "$srcdir/build"
+ cmake "$startdir/$pkgname-git" \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DBINARY_SUFFIX=-1.8 \
+ -DDATADIRNAME=wesnoth-1.8 \
+ -DMANDIR=share/man \
+ -DDOCDIR=share/doc/wesnoth-1.8 \
+ -DFIFO_DIR=/run/wesnothd-1.8 \
+ -DPREFERENCES_DIR=.local/share/wesnoth/1.8 \
+ -DENABLE_DESKTOP_ENTRY=OFF \
+ -DENABLE_STRICT_COMPILATION=OFF \
+ -Wno-dev # silence cmake warnings
+ make
+}
+
+check() {
+ desktop-file-validate --no-hints --no-warn-deprecated *.desktop
+ appstream-util validate-relax *.appdata.xml
+}
+
+package() {
+ cd "$srcdir/build"
+
+ make DESTDIR="$pkgdir" install
+
+ # better use the tools from a recent version of wesnoth
+ rm -r "$pkgdir/usr/share/wesnoth$_suffix/data/tools"
+
+ # these translation files are not needed
+ find "$pkgdir/usr/share/wesnoth$_suffix/translations" -name wesnoth-manpages.mo -delete
+ find "$pkgdir/usr/share/wesnoth$_suffix/translations" -name wesnoth-manual.mo -delete
+
+ # add suffix to manpages
+ cd "$pkgdir/usr/share/man"
+ for filename in man6/*.6 */man6/*.6
+ do
+ mv "$filename" $(dirname $filename)/$(basename $filename .6)-1.8.6
+ done
+
+ # INSTALLING of menu entry and icons as well as systemd files and appstream information:
+ install -D -m644 "$srcdir/wesnoth$_suffix.desktop" "$pkgdir/usr/share/applications/wesnoth$_suffix.desktop"
+ install -D -m644 "$startdir/$pkgname-git/images/wesnoth-icon-small.png" "$pkgdir/usr/share/icons/hicolor/64x64/apps/$pkgname-icon.png"
+ install -D -m644 "$startdir/$pkgname-git/data/core/images/wesnoth-icon.png" "$pkgdir/usr/share/icons/hicolor/128x128/apps/$pkgname-icon.png"
+
+ install -D -m644 "$srcdir/wesnothd$_suffix.tmpfiles.conf" "$pkgdir/usr/lib/tmpfiles.d/wesnothd$_suffix.conf"
+ install -D -m644 "$srcdir/wesnothd$_suffix.service" "$pkgdir/usr/lib/systemd/system/wesnothd$_suffix.service"
+
+ install -D -m644 "$srcdir/wesnoth$_suffix.appdata.xml" "$pkgdir/usr/share/metainfo/wesnoth$_suffix.appdata.xml"
+}
diff --git a/wesnoth-1.8.appdata.xml b/wesnoth-1.8.appdata.xml
new file mode 100644
index 000000000000..65a8e5ce8852
--- /dev/null
+++ b/wesnoth-1.8.appdata.xml
@@ -0,0 +1,102 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<component type="desktop">
+ <id>wesnoth-1.8.desktop</id>
+ <metadata_license>GFDL-1.3</metadata_license>
+ <project_license>GPL-2.0-or-later</project_license>
+ <name>Battle for Wesnoth (1.8)</name>
+ <name xml:lang="de">Battle for Wesnoth (1.8)</name>
+ <name xml:lang="es">La batalla por Wesnoth (1.8)</name>
+ <name xml:lang="fr">La Bataille pour Wesnoth (1.8)</name>
+ <name xml:lang="hu">Harc Wesnothért (1.8)</name>
+ <name xml:lang="pl">Bitwa o Wesnoth (1.8)</name>
+ <name xml:lang="ru">Битва за Веснот (1.8)</name>
+ <summary>A turn-based strategy game with a high fantasy theme</summary>
+ <summary xml:lang="de">Ein rundenbasierendes Strategiespiel mit Fantasy-Thematik</summary>
+ <summary xml:lang="es">Un juego de estrategia basado en turnos con un tema de fantasía</summary>
+ <summary xml:lang="fr">Un jeu de stratégie au tour par tour dans un univers fantastique</summary>
+ <summary xml:lang="hu">Fantasy stílusú, körökre osztott, stratégiai játék</summary>
+ <summary xml:lang="pl">Bitwa o Wesnoth to turowa strategia w klimatach fantasy</summary>
+ <summary xml:lang="ru">Фантастическая пошаговая стратегия</summary>
+ <description>
+ <p>
+ Build up a great army, gradually turning raw recruits into hardened
+ veterans.
+ In later games, recall your toughest warriors and form a deadly host that
+ no one can stand against! Choose units from a large pool of specialists,
+ and hand-pick a force with the right strengths to fight well on different
+ terrains against all manner of opposition.
+ </p>
+ <p xml:lang="de">Stelle eine mächtige Armee zusammen, indem du aus einfachen Rekruten gestählte Veteranen machst. Später kannst du deine härtesten Krieger wieder einberufen, und niemand wird sich dir mehr in den Weg stellen können! Wähle deine Mitstreiter aus einer Anzahl von spezialisierten Einheitentypen und erstelle eine handverlesene Kriegsmacht, mit deren Stärken du dich auf verschiedenem Gelände gegen jede Art von Widerstand behaupten kannst.</p>
+ <p xml:lang="es">Reúne un gran ejercito y convierte progresivamente los reclutas en duros veteranos. ¡Posteriormente reincorpora a tus guerreros más poderosos formando un batallón mortal al que nadie se pueda oponer!. Selecciona unidades entre un gran número de perfiles construyendo un ejercito equilibrado para luchar en diferentes terrenos contra todo tipo de rivales.</p>
+ <p xml:lang="fr">Construisez une grande armée, transformant progressivement de simples recrues en vétérans aguerris. Dans les parties ultérieures, rappelez vos combattants les plus forts et formez une faction meurtrière contre laquelle il est impossible de lutter ! Choisissez des unités parmi un large éventail de spécialistes, et sélectionnez méticuleusement des troupes avec les atouts adéquats pour combattre efficacement sur différents terrains et contre toute sorte d'opposition.</p>
+ <p xml:lang="hu">Építs óriási seregeket, zöldfülű újoncaidat harcedzett veteránokká változtatva! Legkeményebb harcosaidat későbbi pályákon is visszahívhatod, így szinte legyőzhetetlen csapatot alkothatsz. Egységeidet rengeteg típus közül választhatod ki, hogy bármilyen terepen bármilyen ellenfél ellen sikerrel küzdhess meg.</p>
+ <p xml:lang="pl">Stwórz wspaniałą armię, stopniowo rozwijając rekrutów w doświadczonych żołnierzy. W późniejszych grach przywołuj najlepszych wojowników, aby stworzyć niszczycielską drużynę, której nikt nie będzie mógł się przeciwstawić. Wybieraj podwładnych z szerokiej puli wyspecjalizowanych jednostek i stwórz armię, która będzie w stanie skutecznie walczyć na zróżnicowanym terenie z dowolnym wrogiem.</p>
+ <p xml:lang="ru">Создайте великую армию, постепенно превращая неотесанных новобранцев в закаленных ветеранов. В последующих играх призывайте ваших сильнейших воинов и сформируйте из них смертоносный тандем, против которого никто не сможет выстоять! Выбирайте юниты с различными специализациями, подбирайте бойцов с правильными особенностями, чтобы хорошо сражаться на различных территориях и дать отпор против любых маневров врага. </p>
+ <p>
+ Wesnoth has many different sagas waiting to be played.
+ Fight to regain the throne of Wesnoth, of which you are the legitimate
+ heir... lead a brutal quest to unite the orcish tribes... vanquish a horde
+ of undead warriors... Guide a band of elvish survivors in an epic quest to
+ find a new home...
+ </p>
+ <p xml:lang="de">Viele Sagen warten darauf, von dir gespielt zu werden. Kämpfe um den Thron von Wesnoth, dessen legitimer Erbe du bist... schlüpfe in die Rolle eines jungen Offiziers, der ausgesandt wurde, um einen nicht allzu ruhigen Außenposten zu verteidigen... führe einen brutalen Feldzug, um die orkischen Stämme zu vereinigen... besiege eine Gruppe untoter Krieger, die von einem Totenbeschwörer beschworen wurden, der auch deinen Bruder in seiner Gewalt hat... führe eine Gruppe elfischer Überlebender auf ihrer Suche nach einer neuen Heimat...</p>
+ <p xml:lang="es">Wesnoth cuenta con un gran número de campañas esperando a ser jugadas. Lucha por recuperar el trono de Wesnoth del cual eres legítimo heredero... ponte en la piel de un joven oficial enviado a protejer un puesto fronterizo no tan tranquilo como esperaba... lidera la brutal aventura de unir las tribus orcas... derrota una horda de guerreros no muertos invocados por un infecto nigromante que ha raptado a tu hermano... guía a un grupo de supervivientes elfos en su épica búsqueda de un nuevo hogar...</p>
+ <p xml:lang="fr">Wesnoth comporte de nombreuses sagas qui n'attendent que d'être jouées. Luttez pour regagner le trône de Wesnoth, dont vous êtes l'héritier légitime… incarnez un jeune officier envoyé en mission pour garder un avant-poste frontalier pas si paisible… dirigez une quête brutale pour unifier les tribus orcs… surmontez une horde de guerriers morts-vivants contrôlés par un vil nécromancien, qui a par ailleurs pris votre frère en otage… guidez une troupe de survivants elfes dans une quête épique pour trouver une nouvelle terre d'accueil...</p>
+ <p xml:lang="hu">Wesnoth világa számos történetet tartogat. Harcolj Wesnoth trónjáért, amelynek te vagy a jogos örököse... bújj egy fiatal tiszt bőrébe, és vedd át egy nem is annyira nyugodt helyőrség parancsnokságát... egyesítsd az ork törzseket egy kegyetlen hadjáratban... irtsd ki a gonosz holtidéző élőholt seregét, akik mellesleg a bátyádat is túszul ejtették... vezesd tünde túlélők egy kicsiny csoportját egy új haza felé...</p>
+ <p xml:lang="pl">Wesnoth posiada wiele historii gotowych do rozegrania. Walcz aby odzyskać tron Wesnoth, którego jesteś prawowitym spadkobiercą... zasmakuj życia młodego oficera, wysłanego by bronić nie-tak-spokojnej granicy... zniszcz hordę nieumarłych przywołanych przez zuchwałego nekromantę, który porwał też twego brata... poprowadź grupę ocalałych elfów w epickiej wyprawie poszukiwania nowego domu.</p>
+ <p xml:lang="ru">Веснот содержит множество различных саг, которые только и ждут, чтобы быть сыгранными. Сражайтесь за возвращение трона Веснота как его истинный наследник... почувствуйте себя молодым офицером, отправленным на охрану неспокойного передового аванпоста... возглавьте брутальный квест по объединению орочьих племен... сокрушите орду мертвецов, поднятую отвратительным некромантом, который также берет вашего брата в заложники... ведите отряд выживших эльфов в эпическом квесте по поиску нового дома...</p>
+ <p>
+ There are at least two hundred unit types, sixteen races, six major
+ factions, and hundreds of years of history.
+ The world of Wesnoth is absolutely huge and only limited by your
+ creativity.
+ You can also challenge up to eight friends — or strangers — and fight in
+ epic multiplayer fantasy battles.
+ </p>
+ <p xml:lang="de">Mehr als 200 Einheitentypen. 16 Rassen. 6 Hauptfraktionen. Hunderte von Geschichtsjahren. Die Welt Wesnoths ist gigantisch und nur von den Grenzen deiner Vorstellungskraft begrenzt — erstelle deine eigenen Einheiten, Karten, Szenarien oder gleich ganze Kampagnen. Du kannst auch bis zu 8 Personen in epischen Mehrspielerschlachten herausfordern.</p>
+ <p xml:lang="es">Existen más de doscientos tipos de unidades, dieciseis razas, seis facciones principales y cientos de años de historia. El mundo de Wesnoth es absolutamente gigante y sólo está limitado por tu creatividad — construye tus propias unidades personalizadas, elabora tus propios mapas, crea tus propios escenarios o incluso campañas completas. Puedes también retar hasta ocho amigos — o estraños — y luchar en épicas batallas multijugador.</p>
+ <p xml:lang="fr">Plus de 200 types d'unités. 16 races. 6 factions majeures. Des siècles d'histoire. Le monde de Wesnoth est gigantesque et ses seules limites sont votre créativité : créez vos propres unités personnalisées, réalisez vos propres cartes, et écrivez vos propres scénarios voire des campagnes complètes ! Vous pouvez également défier jusqu'à 8 amis — ou inconnus — et les combattre dans d'épiques batailles en mode multijoueur.</p>
+ <p xml:lang="hu">Több, mint kétszáz fajta egység, hatvan faj, hat nagy szövetség és több száz évnyi történelem vár felfedezésre. Wesnoth világa hatalmas és csak a saját képzeleted jelenti a határt. Egyedi egységeket és térképeket készíthetsz, saját küldetéseket vagy akkár hadjáratokat írhatsz. Többjátékos küzdelemre hívhatod ki legfeljebb nyolc barátodat vagy idegeneket.</p>
+ <p xml:lang="pl">Ponad 200 jednostek. 16 ras. 6 głównych frakcji. Setki lat historii. Świat Wesnoth jest niezwykle wielki, ograniczony tylko Twoją wyobraźnią - stwórz własne jednostki, zbuduj własne mapy i napisz własne scenariusze, a nawet całe kampanie. Możesz wyzwać nawet do 8 przyjaciół — lub nieznajomych — aby toczyć epickie bitwy w trybie gry wieloosobowej.</p>
+ <p xml:lang="ru">В игре есть по крайней мере две сотни типов юнитов, шестнадцать рас, шесть крупных фракций и сотни лет истории. Мир Веснота огромен и ограничен только вашей креативностью — создавайте собственные юниты, карты, пишите собственные сценарии или даже полноценные кампании. Вы также можете соревноваться с друзьями или незнакомцами (до 8 человек), сражаясь с ними в эпических многопользовательских фэнтезийных баталиях.</p>
+ </description>
+ <screenshots>
+ <screenshot type="default">
+ <image type="source" width="1024" height="768">https://www.wesnoth.org/images/sshots/wesnoth1.8-6.jpg</image>
+ </screenshot>
+ <screenshot>
+ <image type="source" width="1024" height="768"> https://www.wesnoth.org/images/sshots/wesnoth1.8-2.jpg</image>
+ </screenshot>
+ <screenshot>
+ <image type="source" width="1024" height="768"> https://www.wesnoth.org/images/sshots/wesnoth1.8-3.jpg</image>
+ </screenshot>
+ <screenshot>
+ <image type="source" width="1024" height="768"> https://www.wesnoth.org/images/sshots/wesnoth1.8-1.jpg</image>
+ </screenshot>
+ <screenshot>
+ <image type="source" width="1024" height="768">https://www.wesnoth.org/images/sshots/wesnoth1.8-4.jpg</image>
+ </screenshot>
+ </screenshots>
+ <categories>
+ <category>Game</category>
+ <category>StrategyGame</category>
+ </categories>
+ <launchable type="desktop-id">wesnoth-1.8.desktop</launchable>
+ <url type="homepage">https://www.wesnoth.org</url>
+ <url type="faq">https://wiki.wesnoth.org/Play</url>
+ <url type="help">https://wiki.wesnoth.org/WesnothManual</url>
+ <url type="translate">https://wiki.wesnoth.org/WesnothTranslations</url>
+ <url type="bugtracker">https://bugs.wesnoth.org</url>
+ <project_group>Wesnoth</project_group>
+ <developer_name>The Battle for Wesnoth Project</developer_name>
+ <translation>wesnoth</translation>
+ <kudos>
+ <kudo>HiDpiIcon</kudo>
+ <kudo>Notifications</kudo>
+ <kudo>UserDocs</kudo>
+ </kudos>
+ <provides>
+ <binary>wesnoth-1.8</binary>
+ <binary>wesnothd-1.8</binary>
+ </provides>
+</component>
diff --git a/wesnoth-1.8.desktop b/wesnoth-1.8.desktop
new file mode 100644
index 000000000000..52591da8e936
--- /dev/null
+++ b/wesnoth-1.8.desktop
@@ -0,0 +1,94 @@
+[Desktop Entry]
+Version=1.0
+Type=Application
+Name=Battle for Wesnoth
+Name[af]=Die Stryd vir Wesnoth (1.8)
+Name[ca]=Batalla per Wesnoth (1.8)
+Name[cs]=Bitva o Wesnoth (1.8)
+Name[de]=Battle for Wesnoth (1.8)
+Name[dk]=Kampen om Wesnoth (1.8)
+Name[es]=La batalla por Wesnoth (1.8)
+Name[eu]=Wesnotheko Guda (1.8)
+Name[fi]=Taistelu Wesnothista (1.8)
+Name[fr]=La Bataille pour Wesnoth (1.8)
+Name[gl]=A batalla polo Noroeste (1.8)
+Name[he]=הקרב על ווסנות' (1.8)
+Name[hu]=Harc Wesnothért (1.8)
+Name[it]=Battle for Wesnoth (1.8)
+Name[lt]=Mūšis dėl Vesnoto (1.8)
+Name[pt]=A Batalha por Wesnoth (1.8)
+Name[ru]=Битва за Веснот (1.8)
+Name[sk]=Bitka o Wesnoth (1.8)
+Name[sr]=Бој за Веснот (1.8)
+Name[sr@ijekavian]=Бој за Веснот (1.8)
+Name[sr@ijekavianlatin]=Boj za Vesnot (1.8)
+Name[sr@latin]=Boj za Vesnot (1.8)
+Name[tr]=Wesnoth Savaşı (1.8)
+Name[vi]=Trận chiến vì Wesnoth (1.8)
+GenericName=Strategy Game
+GenericName[af]=Strategie-spel
+GenericName[ca]=Joc d'estrategia
+GenericName[cs]=Strategická hra
+GenericName[de]=Strategiespiel
+GenericName[dk]=Strategi-spil
+GenericName[es]=Juego de estrategia
+GenericName[eu]=Estrategiako jokoa
+GenericName[fi]=Strategiapeli
+GenericName[fr]=Jeu de stratégie
+GenericName[gl]=Xogo de estratexia
+GenericName[he]=משחק אסטרטגיה
+GenericName[hu]=Stratégia
+GenericName[it]=Gioco strategico
+GenericName[lt]=Strateginis žaidimas
+GenericName[pt]=Jogo de Estratégia
+GenericName[ru]=Стратегическая игра
+GenericName[sk]=Strategická hra
+GenericName[sr]=Стратешка игра
+GenericName[sr@latin]=Strateška igra
+GenericName[tr]=Strateji Oyunu
+GenericName[vi]=Trò chơi chiến lược
+Comment=A fantasy turn-based strategy game
+Comment[af]='n Fantasie beurt-basis strategie-spel
+Comment[ca]=Un joc fantàstic d'estrategia per torns
+Comment[cs]=Tahová strategická hra ve fantastickém prostředí
+Comment[de]=Rundenbasiertes Strategiespiel im Fantasyszenario
+Comment[dk]=Et fantasy træk-baseret strategi-spil
+Comment[es]=Un juego de estrategia basado en turnos con un tema de fantasía
+Comment[eu]=Giro fantastikoan eta txandetan oinarritutako estrategia jokoa
+Comment[fi]=Vuoropohjainen fantasiastrategiapeli
+Comment[fr]=Un jeu de stratégie au tour par tour dans un univers fantastique
+Comment[gl]=Xogo de estratexia por quendas ambientado nun mundo fantástico.
+Comment[he]=משחק אסטרטגיה ופנטסיה מבוסס מהלכים
+Comment[hu]=Fantasy stílusú, körökre osztott, stratégiai játék
+Comment[it]=Un gioco strategico a turni con ambientazione fantasy
+Comment[lt]=Fantastinis ėjimais pagrįstas strateginis žaidimas
+Comment[pt]=Um jogo de fantasia estratégico em turnos
+Comment[ru]=Фантастическая пошаговая стратегия
+Comment[sk]=Ťahová strategická hra z prostredia fantasy
+Comment[sr]=Фантазијска стратешка игра на потезе
+Comment[sr@latin]=Fantazijska strateška igra na poteze
+Comment[tr]=Fantastik, sırayla oynanan bir strateji oyunu
+Comment[vi]=Một trò chơi chiến lược dựa trên lượt đi theo phong cách thần thoại
+Icon=wesnoth-1.8-icon
+Exec=sh -c "wesnoth-1.8 >/dev/null 2>&1"
+Categories=Game;StrategyGame;
+Actions=Editor;
+
+[Desktop Action Editor]
+Name=Map Editor
+Name[cs]=Editor map
+Name[de]=Karteneditor
+Name[es]=Editor de mapas
+Name[fi]=Kenttäeditori
+Name[fr]=Éditeur de cartes
+Name[gl]=Editor de mapas
+Name[hu]=pályaszerkesztő
+Name[it]=Editor delle mappe
+Name[lt]=žemėlapių redaktorius
+Name[pt]=Editor de mapas
+Name[sr]=Уређивач мапа
+Name[sr@ijekavian]=Уређивач мапа
+Name[sr@ijekavianlatin]=Uređivač mapa
+Name[sr@latin]=Uređivač mapa
+Name[tr]=Harita Düzenleyici
+Exec=sh -c "wesnoth-1.8 -e >/dev/null 2>&1"
diff --git a/wesnothd-1.8.service b/wesnothd-1.8.service
new file mode 100644
index 000000000000..d037278eaa31
--- /dev/null
+++ b/wesnothd-1.8.service
@@ -0,0 +1,35 @@
+[Unit]
+Description=Wesnoth-1.8 Server Daemon
+Documentation=https://www.wesnoth.org/wiki/ServerAdministration
+Documentation=man:/usr/share/man/wesnoth-1.8/man6/wesnothd.6.gz
+After=network.target
+# They use by default the same port
+Conflicts=wesnothd.service wesnothd-1.10.service wesnothd-1.12.service wesnothd-1.14.service wesnothd-devel.service wesnothd-git.service
+
+[Service]
+ExecStart=/usr/bin/wesnothd-1.8 -t 2 -T 5
+# you can use -c to specify the same configuration file
+# which is used when starting wensothd from the wesnoth UI
+# (and make sure wesnothd has the required access permissions)
+
+SyslogIdentifier=Wesnothd-1.8
+User=nobody
+Group=nobody
+ExecStopPost=/usr/bin/rm -f /run/wesnothd-1.8/socket
+
+# Additional security-related features
+ProtectSystem=yes
+PrivateTmp=yes
+PrivateDevices=yes
+NoNewPrivileges=yes
+RestrictAddressFamilies=AF_INET
+RestrictRealtime=yes
+MemoryDenyWriteExecute=yes
+SystemCallArchitectures=native
+ProtectControlGroups=yes
+ProtectKernelTunables=yes
+ProtectKernelModules=yes
+RestrictNamespaces=yes
+
+[Install]
+WantedBy=multi-user.target
diff --git a/wesnothd-1.8.tmpfiles.conf b/wesnothd-1.8.tmpfiles.conf
new file mode 100644
index 000000000000..bdec872aa95c
--- /dev/null
+++ b/wesnothd-1.8.tmpfiles.conf
@@ -0,0 +1,5 @@
+# This directory is used to store a named pipe, which accepts administration commands
+# See https://wiki.wesnoth.org/ServerAdministration (without /query)
+#
+# wesnothd can either be started by the systemd service file or the wesnoth UI
+d /run/wesnothd-1.8 0770 nobody users -