summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorvaldar2016-05-31 07:50:41 +0100
committervaldar2016-05-31 07:50:41 +0100
commit62796e0e628ca7e31d4d709634da51accc2aee9b (patch)
tree8f7c07b6ff35ed488b00b16feb538938f392de87
parentaf3af3ffeaa4806b8831b669f9955a739fa943bd (diff)
downloadaur-62796e0e628ca7e31d4d709634da51accc2aee9b.tar.gz
Patch added to make it compile with ggc 6.x
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD16
-rw-r--r--patch_gcc6.patch28
3 files changed, 40 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 30d8d6650fe0..be27b42a2440 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Fri Mar 11 23:09:15 UTC 2016
+# Tue May 31 06:37:07 UTC 2016
pkgbase = wesnoth-devel
pkgdesc = development version of a turn-based strategy game on a fantasy world
pkgver = 1.13.4
- pkgrel = 1
+ pkgrel = 2
url = http://www.wesnoth.org/
install = wesnoth-devel.install
arch = i686
@@ -29,8 +29,7 @@ pkgbase = wesnoth-devel
source = wesnoth-devel_editor-icon.xpm
source = wesnothd-devel.tmpfiles.conf
source = wesnothd-devel.service
- source = boost1_60.patch
- source = boost1_600tests.patch
+ source = patch_gcc6.patch
md5sums = 70e949917df1b6e3d222469a58d09849
md5sums = a906eae5d541a51de77038469b1f794b
md5sums = b9de9e7ee16f757aa406466657c274a9
@@ -38,8 +37,7 @@ pkgbase = wesnoth-devel
md5sums = 931e7443fe37b2862ca59f65ded74a0b
md5sums = ffc4b6c06dcd187855710ed96a55fc8f
md5sums = 959aea3af36e7b2a1be6bf4537ec54b7
- md5sums = 1049f1455e829f723e65069c3260277c
- md5sums = b22e2b85f90a4c85226f6e92db1fce78
+ md5sums = 5182ce65c28a8bd62043c3a7fc09e642
pkgname = wesnoth-devel
diff --git a/PKGBUILD b/PKGBUILD
index 6af251aeead8..e2747575a8d3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,11 +1,9 @@
-
-
#Contributor:Andrea Tarocchi <valdar@email.it>
#Maintainer: Andrea Tarocchi <valdar@email.it>
pkgname=wesnoth-devel
pkgver=1.13.4
-pkgrel=1
+pkgrel=2
pkgdesc="development version of a turn-based strategy game on a fantasy world"
arch=('i686' 'x86_64')
url="http://www.wesnoth.org/"
@@ -20,8 +18,7 @@ source=("http://downloads.sourceforge.net/sourceforge/wesnoth/wesnoth-$pkgver.ta
"wesnoth-devel_editor-icon.xpm"
"wesnothd-devel.tmpfiles.conf"
"wesnothd-devel.service"
- "boost1_60.patch"
- "boost1_600tests.patch")
+ "patch_gcc6.patch")
md5sums=('70e949917df1b6e3d222469a58d09849'
'a906eae5d541a51de77038469b1f794b'
@@ -30,8 +27,7 @@ md5sums=('70e949917df1b6e3d222469a58d09849'
'931e7443fe37b2862ca59f65ded74a0b'
'ffc4b6c06dcd187855710ed96a55fc8f'
'959aea3af36e7b2a1be6bf4537ec54b7'
-'1049f1455e829f723e65069c3260277c'
-'b22e2b85f90a4c85226f6e92db1fce78')
+'5182ce65c28a8bd62043c3a7fc09e642')
prepare() {
cd "${srcdir}/wesnoth-$pkgver"
@@ -48,13 +44,17 @@ prepare() {
build() {
cd "${srcdir}/wesnoth-$pkgver"
+ #gcc 6 patching
+ patch -p1 < ../../patch_gcc6.patch
+
scons prefix=/usr program_suffix=-devel datadirname=wesnoth-devel prefsdir=.wesnoth-devel fifodir=/run/wesnothd-devel \
+ boostdir=/usr/include boostlibdir=/usr/include \
localedir=/usr/share/locale docdir=/usr/share/doc/wesnoth-devel mandir=/usr/share/man/wesnoth-devel python_site_packages_dir=/lib/python/site-packages/wesnoth all
}
package(){
cd "${srcdir}/wesnoth-$pkgver"
- scons destdir=${pkgdir} install
+ scons destdir=${pkgdir} boostdir=/usr/include boostlibdir=/usr/include install
#INSTALLING of menu entry and icons:
install -D -m644 ../../wesnoth-devel.desktop ${pkgdir}/usr/share/applications/wesnoth-devel.desktop
diff --git a/patch_gcc6.patch b/patch_gcc6.patch
new file mode 100644
index 000000000000..865c91c97f98
--- /dev/null
+++ b/patch_gcc6.patch
@@ -0,0 +1,28 @@
+diff --git a/scons/boost.py b/scons/boost.py
+index d48829d..e0dfbcc 100644
+--- a/scons/boost.py
++++ b/scons/boost.py
+@@ -1,6 +1,6 @@
+ # vi: syntax=python:et:ts=4
+ from config_check_utils import find_include
+-from os.path import join, dirname, basename
++from os.path import join, dirname, basename, samefile
+ from glob import glob
+ import re
+
+@@ -69,10 +69,11 @@ def CheckBoost(context, boost_lib, require_version = None, header_only = False):
+ header_name = boost_headers.get(boost_lib, boost_lib + ".hpp")
+ libname = "boost_" + boost_lib + env.get("boost_suffix", "")
+
+- if env["fast"]:
+- env.AppendUnique(CXXFLAGS = ["-isystem", boostdir], LIBPATH = [boostlibdir])
+- else:
+- env.AppendUnique(CPPPATH = [boostdir], LIBPATH = [boostlibdir])
++ if not samefile(boostdir, "/usr/include"):
++ if env["fast"]:
++ env.AppendUnique(CXXFLAGS = ["-isystem", boostdir], LIBPATH = [boostlibdir])
++ else:
++ env.AppendUnique(CPPPATH = [boostdir], LIBPATH = [boostlibdir])
+ if not header_only:
+ env.AppendUnique(LIBS = [libname])
+ if boost_lib == "thread" and env["PLATFORM"] == "posix": \ No newline at end of file