summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndrea Tarocchi2021-03-22 16:03:25 +0100
committerAndrea Tarocchi2021-03-22 16:03:25 +0100
commitf9a554661134fecd364d54c9d4f8338ccf9d2d4d (patch)
tree8697b93ffbb4309791d5372d5697e408317889bb
parent926a2ee9c4081d027462754c7b0f13fdd84c6af2 (diff)
downloadaur-f9a554661134fecd364d54c9d4f8338ccf9d2d4d.tar.gz
Update to 1.15.11 and cleanup
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD11
-rw-r--r--boost1_60.patch23
-rw-r--r--boost1_600tests.patch174
-rw-r--r--patch_gcc6.patch28
5 files changed, 7 insertions, 238 deletions
diff --git a/.SRCINFO b/.SRCINFO
index abd2ea5ff477..6f8f1f4148f8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = wesnoth-devel
pkgdesc = development version of a turn-based strategy game on a fantasy world
- pkgver = 1.15.10
+ pkgver = 1.15.11
pkgrel = 1
url = https://www.wesnoth.org/
install = wesnoth-devel.install
@@ -20,13 +20,10 @@ pkgbase = wesnoth-devel
depends = sdl2
depends = sdl2_image
depends = sdl2_mixer
- depends = sdl2_ttf
depends = pango
- depends = fribidi
depends = dbus
depends = openssl
depends = boost-libs
- depends = libpng
optdepends = python: some tools for UMC developers
optdepends = tk: for GUI.pyw, a gui for some of these tools
optdepends = gettext: for creating translation files with wmlxgettext
@@ -35,7 +32,7 @@ pkgbase = wesnoth-devel
optdepends = advancecomp: png optimization with wesnoth-optipng / woptipng
optdepends = imagemagick: png optimization with wesnoth-optipng / woptipng
options = !emptydirs
- source = https://downloads.sourceforge.net/sourceforge/wesnoth/wesnoth-1.15.10.tar.bz2
+ source = https://downloads.sourceforge.net/sourceforge/wesnoth/wesnoth-1.15.11.tar.bz2
source = wesnoth-devel.desktop
source = wesnoth_editor-devel.desktop
source = wesnoth-devel-icon.png
@@ -43,7 +40,7 @@ pkgbase = wesnoth-devel
source = wesnothd-devel.tmpfiles.conf
source = wesnothd-devel.service
source = wesnoth-devel.appdata.xml
- sha256sums = e04692d7a48b82a72a25ce895617f248372b01a5675e8356c16d675748a8bc61
+ sha256sums = 08e90fbbd6d5989caad4f0c3e805158ad5298445aa68017bee60b7ce243cc77f
sha256sums = 3631b4c1eda6c2099e43272f2a26a8a3e897b9541a395ebeb9a1b8b3753a647d
sha256sums = 196cd09c73c6503b9caef7c47bb61d0243c10e9b15daa6b3aff437f7ad03448a
sha256sums = 98fbd8bafff165c45d0a1eb23a500108e4ce7c8ed32b9abc9bf1c3179e1d3491
diff --git a/PKGBUILD b/PKGBUILD
index 35f0699b957c..dc68027ec1d4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=wesnoth-devel
#XXX: when changing major version (i.e. 1.15 to 1.1X) remeber to updated the occurences in build() and package()
-pkgver=1.15.10
+pkgver=1.15.11
pkgrel=1
pkgdesc="development version of a turn-based strategy game on a fantasy world"
arch=('i486' 'i686' 'pentium4' 'x86_64' 'armv6h' 'armv7h' 'aarch64')
@@ -12,13 +12,10 @@ license=('GPL')
depends=('sdl2'
'sdl2_image'
'sdl2_mixer'
- 'sdl2_ttf'
'pango'
- 'fribidi'
'dbus'
'openssl'
- 'boost-libs'
- 'libpng')
+ 'boost-libs')
optdepends=('python: some tools for UMC developers'
'tk: for GUI.pyw, a gui for some of these tools'
'gettext: for creating translation files with wmlxgettext'
@@ -41,7 +38,7 @@ source=("https://downloads.sourceforge.net/sourceforge/wesnoth/wesnoth-$pkgver.t
"wesnothd-devel.service"
"wesnoth-devel.appdata.xml")
-sha256sums=('e04692d7a48b82a72a25ce895617f248372b01a5675e8356c16d675748a8bc61'
+sha256sums=('08e90fbbd6d5989caad4f0c3e805158ad5298445aa68017bee60b7ce243cc77f'
'3631b4c1eda6c2099e43272f2a26a8a3e897b9541a395ebeb9a1b8b3753a647d'
'196cd09c73c6503b9caef7c47bb61d0243c10e9b15daa6b3aff437f7ad03448a'
'98fbd8bafff165c45d0a1eb23a500108e4ce7c8ed32b9abc9bf1c3179e1d3491'
@@ -57,7 +54,7 @@ prepare() {
#diff -rupN src/ src_new/ > patch_name.patch
#How to apply a patch
- #patch -p1 < ../../sdlmixer_2.0.2.patch
+ #patch -p1 < ../../patch_name.patch
}
check() {
diff --git a/boost1_60.patch b/boost1_60.patch
deleted file mode 100644
index e2ff326bce4a..000000000000
--- a/boost1_60.patch
+++ /dev/null
@@ -1,23 +0,0 @@
-From aa1ea043bbf52d509197eab91ab85c70e633d69e Mon Sep 17 00:00:00 2001
-From: Celtic Minstrel <celtic.minstrel.ca@some.place>
-Date: Fri, 25 Dec 2015 08:17:33 -0500
-Subject: [PATCH] Use boost::none instead of boost::none_t()
-
-Fixes bug 24227
----
- src/play_controller.hpp | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/src/play_controller.hpp b/src/play_controller.hpp
-index d5596b6..e289861 100644
---- a/src/play_controller.hpp
-+++ b/src/play_controller.hpp
-@@ -137,7 +137,7 @@ class play_controller : public controller_base, public events::observer, public
- gamestate().end_level_data_ = data;
- }
- void reset_end_level_data() {
-- gamestate().end_level_data_ = boost::none_t();
-+ gamestate().end_level_data_ = boost::none;
- }
- bool is_regular_game_end() const {
- return gamestate().end_level_data_.get_ptr() != NULL;
diff --git a/boost1_600tests.patch b/boost1_600tests.patch
deleted file mode 100644
index be744cbd1fc7..000000000000
--- a/boost1_600tests.patch
+++ /dev/null
@@ -1,174 +0,0 @@
-From ff29581baa74dbc6ce1923e1352f4fd6d423a67d Mon Sep 17 00:00:00 2001
-From: =?UTF-8?q?Andreas=20L=C3=B6f?= <andreas@alternating.net>
-Date: Mon, 28 Dec 2015 22:58:50 +1300
-Subject: [PATCH] Fix bug #24234: Add Boost 1.60.0 support to unit tests
-
-The unit test part in boost has changed a few header files and
-function signatures between previous versions and 1.60.0. These
-changes adds a version check and two different versions of the
-affected code, as well as introducing semicolons after the global text
-fixtures (which doesn't appear to do harm) but otherwise requires more
-version checks.
----
- src/tests/main.cpp | 20 +++++++++++++++++-
- src/tests/test_map_location.cpp | 4 ++--
- src/tests/test_mp_connect.cpp | 4 ++--
- src/tests/utils/auto_parameterized.hpp | 38 +++++++++++++++++++++++++++++++---
- 4 files changed, 58 insertions(+), 8 deletions(-)
-
-diff --git a/src/tests/main.cpp b/src/tests/main.cpp
-index fe5ed3f..10551c9 100644
---- a/src/tests/main.cpp
-+++ b/src/tests/main.cpp
-@@ -16,11 +16,19 @@
-
-
- #define BOOST_TEST_MODULE wesnoth unit tests master suite
-+
-+#include <boost/version.hpp>
-+
- #include <boost/test/unit_test.hpp>
- #include <boost/test/unit_test_monitor.hpp>
-+#if BOOST_VERSION >= 106000
-+#include <boost/test/unit_test_parameters.hpp>
-+#else
- #include <boost/test/detail/unit_test_parameters.hpp>
-+#endif
- #include <boost/test/results_reporter.hpp>
-
-+
- #include <fstream>
-
- #include "SDL.h"
-@@ -80,6 +88,15 @@ struct wesnoth_global_fixture {
-
-
- // Set more report as default
-+#if BOOST_VERSION >= 106000
-+ if (boost::unit_test::runtime_config::get<boost::unit_test::log_level>(boost::unit_test::runtime_config::LOG_LEVEL) == boost::unit_test::invalid_log_level)
-+ boost::unit_test::unit_test_log.set_threshold_level( boost::unit_test::log_messages );
-+ if (boost::unit_test::runtime_config::get<boost::unit_test::report_level>(boost::unit_test::runtime_config::REPORT_LEVEL) == boost::unit_test::INV_REPORT_LEVEL)
-+ boost::unit_test::results_reporter::set_level(boost::unit_test::SHORT_REPORT);
-+ boost::unit_test::unit_test_monitor.register_exception_translator<game::error>(&exception_translator_game);
-+ boost::unit_test::unit_test_monitor.register_exception_translator<network::error>(&exception_translator_network);
-+ boost::unit_test::unit_test_monitor.register_exception_translator<config::error>(&exception_translator_config);
-+#else
- if (boost::unit_test::runtime_config::log_level() == boost::unit_test::invalid_log_level)
- boost::unit_test::unit_test_log.set_threshold_level( boost::unit_test::log_messages );
- if (boost::unit_test::runtime_config::report_level() == boost::unit_test::INV_REPORT_LEVEL)
-@@ -87,6 +104,7 @@ struct wesnoth_global_fixture {
- boost::unit_test::unit_test_monitor.register_exception_translator<game::error>(&exception_translator_game);
- boost::unit_test::unit_test_monitor.register_exception_translator<network::error>(&exception_translator_network);
- boost::unit_test::unit_test_monitor.register_exception_translator<config::error>(&exception_translator_config);
-+#endif
- }
- ~wesnoth_global_fixture()
- {
-@@ -94,7 +112,7 @@ struct wesnoth_global_fixture {
- }
- };
-
--BOOST_GLOBAL_FIXTURE(wesnoth_global_fixture)
-+BOOST_GLOBAL_FIXTURE(wesnoth_global_fixture);
-
- /*
- * This is a main compilation unit for the test program.
-diff --git a/src/tests/test_map_location.cpp b/src/tests/test_map_location.cpp
-index ca644c1..1077b62 100644
---- a/src/tests/test_map_location.cpp
-+++ b/src/tests/test_map_location.cpp
-@@ -64,9 +64,9 @@ struct MLFixture
- ~MLFixture() {}
- };
-
--BOOST_GLOBAL_FIXTURE ( MLFixture )
-+BOOST_GLOBAL_FIXTURE ( MLFixture );
-
--BOOST_AUTO_TEST_SUITE ( test_map_location )
-+BOOST_AUTO_TEST_SUITE ( test_map_location );
-
- //#define MAP_LOCATION_GET_OUTPUT
-
-diff --git a/src/tests/test_mp_connect.cpp b/src/tests/test_mp_connect.cpp
-index 051f868..2b69aee 100644
---- a/src/tests/test_mp_connect.cpp
-+++ b/src/tests/test_mp_connect.cpp
-@@ -125,8 +125,8 @@ static ng::side_engine* create_side_engine(const config& defaults,
-
- /* Tests */
-
--BOOST_GLOBAL_FIXTURE( mp_connect_fixture )
--BOOST_AUTO_TEST_SUITE( mp_connect )
-+BOOST_GLOBAL_FIXTURE( mp_connect_fixture );
-+BOOST_AUTO_TEST_SUITE( mp_connect );
-
-
- BOOST_AUTO_TEST_CASE( flg_map_settings )
-diff --git a/src/tests/utils/auto_parameterized.hpp b/src/tests/utils/auto_parameterized.hpp
-index dd903cf..2a6705f 100644
---- a/src/tests/utils/auto_parameterized.hpp
-+++ b/src/tests/utils/auto_parameterized.hpp
-@@ -15,15 +15,46 @@
- #ifndef TESTS_UTILS_AUTO_PARAMETERIZED_HPP_INCLUDED
- #define TESTS_UTILS_AUTO_PARAMETERIZED_HPP_INCLUDED
-
-+#include <boost/version.hpp>
-+
- #include <boost/test/unit_test_suite.hpp>
- #include <boost/test/parameterized_test.hpp>
-
-+#if BOOST_VERSION >= 106000
-+#include <boost/test/tree/auto_registration.hpp>
-+#endif
-+
- namespace test_utils {
-
- #ifndef BOOST_AUTO_TU_REGISTRAR
- #define BOOST_AUTO_TU_REGISTRAR BOOST_AUTO_TC_REGISTRAR
- #endif
-
-+#if BOOST_VERSION >= 106000
-+#define WESNOTH_PARAMETERIZED_TEST_CASE( test_name, type_name, values, param_name ) \
-+struct test_name : public BOOST_AUTO_TEST_CASE_FIXTURE \
-+{ void test_method(const type_name&); }; \
-+\
-+type_name* BOOST_JOIN(test_name, _begin) = &values[0]; \
-+type_name* BOOST_JOIN(test_name, _end) = BOOST_JOIN(test_name, _begin) + (sizeof(values)/sizeof(values[0])); \
-+static void BOOST_AUTO_TC_INVOKER( test_name )(const type_name& param_name ) \
-+{ \
-+ test_name t; \
-+ t.test_method(param_name); \
-+} \
-+ \
-+struct BOOST_AUTO_TC_UNIQUE_ID( test_name ) {}; \
-+ \
-+BOOST_AUTO_TU_REGISTRAR( test_name )( \
-+ boost::unit_test::make_test_case(&BOOST_AUTO_TC_INVOKER( test_name ), \
-+ BOOST_TEST_STRINGIZE( test_name ), \
-+ BOOST_TEST_STRINGIZE(__FILE__), __LINE__, \
-+ BOOST_JOIN(test_name, _begin), BOOST_JOIN(test_name, _end)), \
-+ boost::unit_test::decorator::collector::instance()); \
-+ \
-+void test_name::test_method(const type_name& param_name) \
-+/**/
-+#else
- #define WESNOTH_PARAMETERIZED_TEST_CASE( test_name, type_name, values, param_name ) \
- struct test_name : public BOOST_AUTO_TEST_CASE_FIXTURE \
- { void test_method(const type_name&); }; \
-@@ -39,12 +70,13 @@ static void BOOST_AUTO_TC_INVOKER( test_name )(const type_name& param_name ) \
- struct BOOST_AUTO_TC_UNIQUE_ID( test_name ) {}; \
- \
- BOOST_AUTO_TU_REGISTRAR( test_name )( \
-- boost::unit_test::make_test_case(&BOOST_AUTO_TC_INVOKER( test_name ), \
-- BOOST_TEST_STRINGIZE( test_name ),\
-- BOOST_JOIN(test_name, _begin), BOOST_JOIN(test_name, _end))); \
-+ boost::unit_test::make_test_case(&BOOST_AUTO_TC_INVOKER( test_name ), \
-+ BOOST_TEST_STRINGIZE( test_name ), \
-+ BOOST_JOIN(test_name, _begin), BOOST_JOIN(test_name, _end))); \
- \
- void test_name::test_method(const type_name& param_name) \
- /**/
-+#endif
-
- }
- #endif
diff --git a/patch_gcc6.patch b/patch_gcc6.patch
deleted file mode 100644
index 865c91c97f98..000000000000
--- a/patch_gcc6.patch
+++ /dev/null
@@ -1,28 +0,0 @@
-diff --git a/scons/boost.py b/scons/boost.py
-index d48829d..e0dfbcc 100644
---- a/scons/boost.py
-+++ b/scons/boost.py
-@@ -1,6 +1,6 @@
- # vi: syntax=python:et:ts=4
- from config_check_utils import find_include
--from os.path import join, dirname, basename
-+from os.path import join, dirname, basename, samefile
- from glob import glob
- import re
-
-@@ -69,10 +69,11 @@ def CheckBoost(context, boost_lib, require_version = None, header_only = False):
- header_name = boost_headers.get(boost_lib, boost_lib + ".hpp")
- libname = "boost_" + boost_lib + env.get("boost_suffix", "")
-
-- if env["fast"]:
-- env.AppendUnique(CXXFLAGS = ["-isystem", boostdir], LIBPATH = [boostlibdir])
-- else:
-- env.AppendUnique(CPPPATH = [boostdir], LIBPATH = [boostlibdir])
-+ if not samefile(boostdir, "/usr/include"):
-+ if env["fast"]:
-+ env.AppendUnique(CXXFLAGS = ["-isystem", boostdir], LIBPATH = [boostlibdir])
-+ else:
-+ env.AppendUnique(CPPPATH = [boostdir], LIBPATH = [boostlibdir])
- if not header_only:
- env.AppendUnique(LIBS = [libname])
- if boost_lib == "thread" and env["PLATFORM"] == "posix": \ No newline at end of file