summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndrea Tarocchi2021-01-17 21:44:57 +0100
committerAndrea Tarocchi2021-01-17 21:44:57 +0100
commitfa20f911a3715d4f581e38956f822887154f0037 (patch)
tree2557799e5c93344808f50dd1c43f999ab9192ce5
parentec11444d9f2f2ecbf479f906457da37c7c914382 (diff)
downloadaur-fa20f911a3715d4f581e38956f822887154f0037.tar.gz
Updated to 1.15.9
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD38
2 files changed, 31 insertions, 23 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 54c96d618cff..714eb472db65 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,11 +1,16 @@
pkgbase = wesnoth-devel
pkgdesc = development version of a turn-based strategy game on a fantasy world
- pkgver = 1.15.8
+ pkgver = 1.15.9
pkgrel = 1
url = https://www.wesnoth.org/
install = wesnoth-devel.install
+ arch = i486
arch = i686
+ arch = pentium4
arch = x86_64
+ arch = armv6h
+ arch = armv7h
+ arch = aarch64
license = GPL
checkdepends = desktop-file-utils
checkdepends = appstream-glib
@@ -18,22 +23,19 @@ pkgbase = wesnoth-devel
depends = sdl2_ttf
depends = pango
depends = fribidi
- depends = lua
depends = dbus
depends = openssl
depends = boost-libs
- depends = desktop-file-utils
+ depends = libpng
optdepends = python: some tools for UMC developers
- optdepends = python2: some tools for UMC developers
optdepends = tk: for GUI.pyw, a gui for some of these tools
optdepends = gettext: for creating translation files with wmlxgettext
optdepends = python-pyenchant: spellchecking with wmllint
optdepends = optipng: png optimization with wesnoth-optipng / woptipng
optdepends = advancecomp: png optimization with wesnoth-optipng / woptipng
optdepends = imagemagick: png optimization with wesnoth-optipng / woptipng
- optdepends = libpng: png screenshots
options = !emptydirs
- source = https://downloads.sourceforge.net/sourceforge/wesnoth/wesnoth-1.15.8.tar.bz2
+ source = https://downloads.sourceforge.net/sourceforge/wesnoth/wesnoth-1.15.9.tar.bz2
source = wesnoth-devel.desktop
source = wesnoth_editor-devel.desktop
source = wesnoth-devel-icon.png
@@ -41,7 +43,7 @@ pkgbase = wesnoth-devel
source = wesnothd-devel.tmpfiles.conf
source = wesnothd-devel.service
source = wesnoth-devel.appdata.xml
- md5sums = 845d08ac4f8d439ccf206f0dd6922ada
+ md5sums = 2709228549bac1d11ccb0814c2079daa
md5sums = 719df848ebda176f995051ef9da302c6
md5sums = 049a22a72074277e53484e3a530d1d69
md5sums = 251f487241afda73c048b4fb654ceda7
diff --git a/PKGBUILD b/PKGBUILD
index 6759b2369c3b..a90cb4551374 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,29 +1,37 @@
-#Contributor:Andrea Tarocchi <valdar@email.it>
-#Maintainer: Andrea Tarocchi <valdar@email.it>
+#Contributor:Andrea Tarocchi <valdar9@protonmail.com>
+#Maintainer: Andrea Tarocchi <valdar9@protonmail.com>
pkgname=wesnoth-devel
-# when changing major version (i.e. 1.15 to 1.1X) remeber to updated the occurences in build() and package()
-pkgver=1.15.8
+#XXX: when changing major version (i.e. 1.15 to 1.1X) remeber to updated the occurences in build() and package()
+pkgver=1.15.9
pkgrel=1
pkgdesc="development version of a turn-based strategy game on a fantasy world"
-arch=('i686' 'x86_64')
+arch=('i486' 'i686' 'pentium4' 'x86_64' 'armv6h' 'armv7h' 'aarch64')
url="https://www.wesnoth.org/"
license=('GPL')
-depends=('sdl2' 'sdl2_image' 'sdl2_mixer' 'sdl2_ttf' 'pango' 'fribidi' 'lua' 'dbus' 'openssl' 'boost-libs' 'desktop-file-utils')
+depends=('sdl2'
+ 'sdl2_image'
+ 'sdl2_mixer'
+ 'sdl2_ttf'
+ 'pango'
+ 'fribidi'
+ 'dbus'
+ 'openssl'
+ 'boost-libs'
+ 'libpng')
optdepends=('python: some tools for UMC developers'
- 'python2: some tools for UMC developers'
'tk: for GUI.pyw, a gui for some of these tools'
'gettext: for creating translation files with wmlxgettext'
'python-pyenchant: spellchecking with wmllint'
'optipng: png optimization with wesnoth-optipng / woptipng'
'advancecomp: png optimization with wesnoth-optipng / woptipng'
- 'imagemagick: png optimization with wesnoth-optipng / woptipng'
- 'libpng: png screenshots')
+ 'imagemagick: png optimization with wesnoth-optipng / woptipng')
makedepends=('boost' 'scons' 'pkg-config')
checkdepends=('desktop-file-utils' 'appstream-glib')
install=${pkgname}.install
options=('!emptydirs')
#options=('!emptydirs' '!strip') #use this when building with debugging symbols
+
source=("https://downloads.sourceforge.net/sourceforge/wesnoth/wesnoth-$pkgver.tar.bz2"
"${pkgname}.desktop"
"wesnoth_editor-devel.desktop"
@@ -33,7 +41,7 @@ source=("https://downloads.sourceforge.net/sourceforge/wesnoth/wesnoth-$pkgver.t
"wesnothd-devel.service"
"wesnoth-devel.appdata.xml")
-md5sums=('845d08ac4f8d439ccf206f0dd6922ada'
+md5sums=('2709228549bac1d11ccb0814c2079daa'
'719df848ebda176f995051ef9da302c6'
'049a22a72074277e53484e3a530d1d69'
'251f487241afda73c048b4fb654ceda7'
@@ -42,8 +50,6 @@ md5sums=('845d08ac4f8d439ccf206f0dd6922ada'
'93f1afc41c66eb324a45ca26055f1507'
'eb0e7466413cd0cdf5ed535146e87f87')
-PKGEXT='.pkg.tar'
-
prepare() {
cd "$srcdir/wesnoth-$pkgver"
@@ -64,7 +70,7 @@ build() {
cd "$srcdir/wesnoth-$pkgver"
#the option build=debug can be useful if the game crashes and you would like to report a bug
- scons jobs=4 desktop_entry=False prefix=/usr version_suffix=-devel prefsdir=.wesnoth-devel \
+ scons jobs=4 desktop_entry=False prefix=/usr version_suffix=-devel \
docdir=/usr/share/doc/wesnoth-devel fifodir=/run/wesnothd-devel \
prefsdir=.local/share/wesnoth/1.15 \
appdata_file=False enable_lto=True wesnoth wesnothd
@@ -78,17 +84,17 @@ package(){
#INSTALLING of menu entry and icons and appstream information:
install -D -m644 "$srcdir/wesnoth-devel.desktop" "$pkgdir/usr/share/applications/wesnoth-devel.desktop"
- install -D -m644 "$srcdir/wesnoth-devel-icon.png" "$pkgdir/usr/share/pixmaps/$pkgname-icon.png"
+ install -D -m644 "$srcdir/wesnoth-devel-icon.png" "$pkgdir/usr/share/icons/hicolor/64x64/apps/$pkgname-icon.png"
install -D -m644 "$srcdir/wesnoth_editor-devel.desktop" "$pkgdir/usr/share/applications/wesnoth_editor-devel.desktop"
- install -D -m644 "$srcdir/wesnoth-devel_editor-icon.png" "$pkgdir/usr/share/pixmaps/${pkgname}_editor-icon.png"
+ install -D -m644 "$srcdir/wesnoth-devel_editor-icon.png" "$pkgdir/usr/share/icons/hicolor/64x64/apps/${pkgname}_editor-icon.png"
install -D -m644 "$srcdir/wesnothd-devel.tmpfiles.conf" "$pkgdir/usr/lib/tmpfiles.d/wesnothd-devel.conf"
install -D -m644 "$srcdir/wesnothd-devel.service" "$pkgdir/usr/lib/systemd/system/wesnothd-devel.service"
install -D -m644 "$srcdir/wesnoth-devel.appdata.xml" "$pkgdir/usr/share/metainfo/wesnoth-devel.appdata.xml"
- # add suffix to manpages (.6 is the file extension) and copy them in the right directory
+ # add suffix to manpages (IMPORTANT: .6 is the file extension!!!) and copy them in the right directory
for filename in "$pkgdir"/usr/share/man/{,*/}man6/wesnoth{,d}.6
do
mv "$filename" $(dirname $filename)/$(basename $filename .6)-1.15.6