summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMiguel A. Vico2019-01-04 15:21:11 -0800
committerMiguel A. Vico2019-01-04 15:21:11 -0800
commita59387e4ff4176886ed14711d793228c1db7cce8 (patch)
treebe1d92c757d98aa5284d1a75698126b924079838
parentf09053e7823022c93ae05e9416ebebd76f815646 (diff)
downloadaur-a59387e4ff4176886ed14711d793228c1db7cce8.tar.gz
Use wayland-eglstream-protocols from egl-wayland
-rw-r--r--.SRCINFO6
-rw-r--r--0006-compositor-Process-stream-attach-requests-with-wl_eg.patch91
-rw-r--r--0008-Add-nvidia-release-notes-file.patch48
-rw-r--r--PKGBUILD11
4 files changed, 45 insertions, 111 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 83a9ea618510..9f99ced86773 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = weston-eglstream
pkgdesc = Reference implementation of a Wayland compositor with EGLStream support
pkgver = 5.0.0
- pkgrel = 2
+ pkgrel = 3
url = https://wayland.freedesktop.org/
arch = i686
arch = x86_64
@@ -44,16 +44,14 @@ pkgbase = weston-eglstream
source = 0005-compositor-drm-Add-support-for-EGLDevice-EGLOutput.patch
source = 0006-compositor-Process-stream-attach-requests-with-wl_eg.patch
source = 0007-simple-egl-Do-not-set-EGL-up-until-XDG-setup-is-comp.patch
- source = 0008-Add-nvidia-release-notes-file.patch
sha256sums = 15a23423bcfa45e31e1dedc0cd524ba71e2930df174fde9c99b71a537c4e4caf
sha256sums = 467c25f7158e54736ed7e9d071c8524e0f83509defcea49a7b053b11be1e9f93
sha256sums = b60522d00263f1e67e4d4ca823550c1c90f30be450facd9a95fca7a91376b160
sha256sums = 7ae690d0f75c8e341efea4a2b1f3557a0aec481fa38fe732b61805f9ee530b03
sha256sums = 4845734de15fa99dbfc7e58b364996a72f63cf3632793d57eca7f696d3d6186e
sha256sums = 037632c607638d98cf04cb5f1d5754842b77670671358ef34629c8c9dc2d9d19
- sha256sums = c83406c44c75e68f2efe0419d9500d1e4a3b5b6c212bec9df15bb40b6b2287dc
+ sha256sums = d1197824dda263bdde19312095125295a87d773e46fae62d68297d38a810e7f6
sha256sums = 7d756c6e091eb6933aa49d7bb822e3a10abfdab5466f7c3763e7bff3ce60090f
- sha256sums = aad2f5c1941abae1cf42db3c59377aa688a9c9fbb0f60b15defc67bd63f9c149
pkgname = weston-eglstream
diff --git a/0006-compositor-Process-stream-attach-requests-with-wl_eg.patch b/0006-compositor-Process-stream-attach-requests-with-wl_eg.patch
index 8ae69ac5e61e..6cb2161a7ccc 100644
--- a/0006-compositor-Process-stream-attach-requests-with-wl_eg.patch
+++ b/0006-compositor-Process-stream-attach-requests-with-wl_eg.patch
@@ -1,4 +1,4 @@
-From 8d52cfe1ae51e6a69ec2c41c65faeb02a5cc1314 Mon Sep 17 00:00:00 2001
+From 9036a214efffea4c2eb13e1d275c59621ee17a52 Mon Sep 17 00:00:00 2001
From: "Miguel A. Vico" <mvicomoya@nvidia.com>
Date: Thu, 18 May 2017 14:35:36 -0700
Subject: [PATCH 6/8] compositor: Process stream attach requests with
@@ -31,16 +31,15 @@ requests.
Signed-off-by: Ashutosh Agarwal <asagarwal@nvidia.com>
Signed-off-by: Miguel A Vico Moya <mvicomoya@nvidia.com>
---
- Makefile.am | 5 +
- libweston/compositor.c | 78 ++++++++++++
- libweston/compositor.h | 4 +
- libweston/gl-renderer.c | 147 ++++++++++++++--------
- protocol/wayland-eglstream-controller.xml | 37 ++++++
- 5 files changed, 217 insertions(+), 54 deletions(-)
- create mode 100644 protocol/wayland-eglstream-controller.xml
+ Makefile.am | 14 ++++
+ configure.ac | 4 ++
+ libweston/compositor.c | 78 +++++++++++++++++++++
+ libweston/compositor.h | 4 ++
+ libweston/gl-renderer.c | 147 +++++++++++++++++++++++++---------------
+ 5 files changed, 193 insertions(+), 54 deletions(-)
diff --git a/Makefile.am b/Makefile.am
-index 83bb2533..3b8fe631 100644
+index 83bb2533..ac24e1dd 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -173,6 +173,11 @@ nodist_libweston_@LIBWESTON_MAJOR@_la_SOURCES = \
@@ -55,6 +54,37 @@ index 83bb2533..3b8fe631 100644
bin_PROGRAMS += weston
weston_LDFLAGS = -export-dynamic
+@@ -1658,6 +1663,15 @@ protocol/%-server-protocol.h : $(WAYLAND_PROTOCOLS_DATADIR)/$$(call protostabili
+ protocol/%-client-protocol.h : $(WAYLAND_PROTOCOLS_DATADIR)/$$(call protostability,$$*)/$$(call protoname,$$*)/$$*.xml
+ $(AM_V_GEN)$(MKDIR_P) $(dir $@) && $(wayland_scanner) client-header < $< > $@
+
++protocol/%-protocol.c : $(WAYLAND_EGLSTREAM_PROTOCOLS_DATADIR)/%.xml
++ $(AM_V_GEN)$(MKDIR_P) $(dir $@) && $(wayland_scanner) code < $< > $@
++
++protocol/%-server-protocol.h : $(WAYLAND_EGLSTREAM_PROTOCOLS_DATADIR)/%.xml
++ $(AM_V_GEN)$(MKDIR_P) $(dir $@) && $(wayland_scanner) server-header < $< > $@
++
++protocol/%-client-protocol.h : $(WAYLAND_EGLSTREAM_PROTOCOLS_DATADIR)/%.xml
++ $(AM_V_GEN)$(MKDIR_P) $(dir $@) && $(wayland_scanner) client-header < $< > $@
++
+ protocol/%-protocol.c : $(top_srcdir)/protocol/%.xml
+ $(AM_V_GEN)$(MKDIR_P) $(dir $@) && $(wayland_scanner) code < $< > $@
+
+diff --git a/configure.ac b/configure.ac
+index 50f8e013..b219d2e2 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -231,6 +231,10 @@ PKG_CHECK_MODULES(WAYLAND_PROTOCOLS, [wayland-protocols >= 1.13],
+ [ac_wayland_protocols_pkgdatadir=`$PKG_CONFIG --variable=pkgdatadir wayland-protocols`])
+ AC_SUBST(WAYLAND_PROTOCOLS_DATADIR, $ac_wayland_protocols_pkgdatadir)
+
++PKG_CHECK_MODULES(WAYLAND_EGLSTREAM_PROTOCOLS, [wayland-eglstream-protocols],
++ [ac_wayland_eglstream_protocols_pkgdatadir=`$PKG_CONFIG --variable=pkgdatadir wayland-eglstream-protocols`])
++AC_SUBST(WAYLAND_EGLSTREAM_PROTOCOLS_DATADIR, $ac_wayland_eglstream_protocols_pkgdatadir)
++
+ AC_ARG_ENABLE(wayland-compositor, [ --enable-wayland-compositor],,
+ enable_wayland_compositor=yes)
+ AM_CONDITIONAL(ENABLE_WAYLAND_COMPOSITOR,
diff --git a/libweston/compositor.c b/libweston/compositor.c
index 9deb7817..a2941788 100644
--- a/libweston/compositor.c
@@ -377,49 +407,6 @@ index 39e33350..c89c7965 100644
gr->egl_display = NULL;
/* extension_suffix is supported */
-diff --git a/protocol/wayland-eglstream-controller.xml b/protocol/wayland-eglstream-controller.xml
-new file mode 100644
-index 00000000..dea072e6
---- /dev/null
-+++ b/protocol/wayland-eglstream-controller.xml
-@@ -0,0 +1,37 @@
-+<?xml version="1.0" encoding="UTF-8"?>
-+<protocol name="wl_eglstream_controller">
-+ <copyright>
-+ Copyright (c) 2017, NVIDIA CORPORATION. All rights reserved.
-+
-+ Permission is hereby granted, free of charge, to any person obtaining a
-+ copy of this software and associated documentation files (the "Software"),
-+ to deal in the Software without restriction, including without limitation
-+ the rights to use, copy, modify, merge, publish, distribute, sublicense,
-+ and/or sell copies of the Software, and to permit persons to whom the
-+ Software is furnished to do so, subject to the following conditions:
-+
-+ The above copyright notice and this permission notice shall be included in
-+ all copies or substantial portions of the Software.
-+
-+ THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
-+ IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
-+ FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL
-+ THE AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
-+ LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING
-+ FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER
-+ DEALINGS IN THE SOFTWARE.
-+ </copyright>
-+ <interface name="wl_eglstream_controller" version="1">
-+ <request name="attach_eglstream_consumer">
-+ <description summary="Create server stream and attach consumer">
-+ Creates the corresponding server side EGLStream from the given wl_buffer
-+ and attaches a consumer to it.
-+ </description>
-+ <arg name="wl_surface" type="object" interface="wl_surface"
-+ summary="wl_surface corresponds to the client surface associated with
-+ newly created eglstream"/>
-+ <arg name="wl_resource" type="object" interface="wl_buffer"
-+ summary="wl_resource corresponding to an EGLStream"/>
-+ </request>
-+ </interface>
-+</protocol>
--
2.18.0
diff --git a/0008-Add-nvidia-release-notes-file.patch b/0008-Add-nvidia-release-notes-file.patch
deleted file mode 100644
index e9a6a54958c4..000000000000
--- a/0008-Add-nvidia-release-notes-file.patch
+++ /dev/null
@@ -1,48 +0,0 @@
-From 58926a862d2fe59c918ab2cd4d15ac60f51039f3 Mon Sep 17 00:00:00 2001
-From: "Miguel A. Vico" <mvicomoya@nvidia.com>
-Date: Wed, 9 Aug 2017 16:01:34 -0700
-Subject: [PATCH 8/8] Add nvidia-release-notes file
-X-NVConfidentiality: public
-
-Signed-off-by: Miguel A Vico Moya <mvicomoya@nvidia.com>
----
- nvidia-release-notes | 27 +++++++++++++++++++++++++++
- 1 file changed, 27 insertions(+)
- create mode 100644 nvidia-release-notes
-
-diff --git a/nvidia-release-notes b/nvidia-release-notes
-new file mode 100644
-index 00000000..1ef437ea
---- /dev/null
-+++ b/nvidia-release-notes
-@@ -0,0 +1,27 @@
-+NVIDIA EGLStream-based Weston version 5.0.0
-+-------------------------------------------
-+
-+This branch includes NVIDIA EGLStream patches on top of
-+Weston 5.0.0.
-+
-+* Known issues:
-+
-+ - Bad interactions with XDG Shell v6 preventing
-+ clients that implement the new interface from
-+ starting
-+
-+ Fixed if using wl_eglstream_controller from commit:
-+
-+ 8d52cfe1ae51e6a69ec2c41c65faeb02a5cc1314 compositor: Process stream attach requests with wl_eglstream_controller
-+
-+ (Needs libnvidia-egl-wayland.so >= 1.0.2 - https://github.com/NVIDIA/egl-wayland)
-+
-+ Fixed in 'weston-simple-egl' with commit:
-+
-+ 27266e389b238f023f8789fec40ae661541372e4 simple-egl: Do not set EGL up until XDG setup is complete
-+
-+
-+* Contact:
-+
-+ Miguel A. Vico (mvicomoya AT nvidia.com)
-+
---
-2.18.0
-
diff --git a/PKGBUILD b/PKGBUILD
index f1540436d749..1005742a48cd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
pkgname=weston-eglstream
pkgver=5.0.0
-pkgrel=2
+pkgrel=3
pkgdesc='Reference implementation of a Wayland compositor with EGLStream support'
arch=('i686' 'x86_64')
url='https://wayland.freedesktop.org/'
@@ -24,17 +24,15 @@ source=("https://wayland.freedesktop.org/releases/weston-$pkgver.tar.xz"
'0004-compositor-drm-Gracefully-handle-vblank-and-flip-inv.patch'
'0005-compositor-drm-Add-support-for-EGLDevice-EGLOutput.patch'
'0006-compositor-Process-stream-attach-requests-with-wl_eg.patch'
- '0007-simple-egl-Do-not-set-EGL-up-until-XDG-setup-is-comp.patch'
- '0008-Add-nvidia-release-notes-file.patch')
+ '0007-simple-egl-Do-not-set-EGL-up-until-XDG-setup-is-comp.patch')
sha256sums=('15a23423bcfa45e31e1dedc0cd524ba71e2930df174fde9c99b71a537c4e4caf'
'467c25f7158e54736ed7e9d071c8524e0f83509defcea49a7b053b11be1e9f93'
'b60522d00263f1e67e4d4ca823550c1c90f30be450facd9a95fca7a91376b160'
'7ae690d0f75c8e341efea4a2b1f3557a0aec481fa38fe732b61805f9ee530b03'
'4845734de15fa99dbfc7e58b364996a72f63cf3632793d57eca7f696d3d6186e'
'037632c607638d98cf04cb5f1d5754842b77670671358ef34629c8c9dc2d9d19'
- 'c83406c44c75e68f2efe0419d9500d1e4a3b5b6c212bec9df15bb40b6b2287dc'
- '7d756c6e091eb6933aa49d7bb822e3a10abfdab5466f7c3763e7bff3ce60090f'
- 'aad2f5c1941abae1cf42db3c59377aa688a9c9fbb0f60b15defc67bd63f9c149')
+ 'd1197824dda263bdde19312095125295a87d773e46fae62d68297d38a810e7f6'
+ '7d756c6e091eb6933aa49d7bb822e3a10abfdab5466f7c3763e7bff3ce60090f')
prepare() {
cd weston-$pkgver
@@ -45,7 +43,6 @@ prepare() {
patch -Np1 -i "${srcdir}/0005-compositor-drm-Add-support-for-EGLDevice-EGLOutput.patch"
patch -Np1 -i "${srcdir}/0006-compositor-Process-stream-attach-requests-with-wl_eg.patch"
patch -Np1 -i "${srcdir}/0007-simple-egl-Do-not-set-EGL-up-until-XDG-setup-is-comp.patch"
- patch -Np1 -i "${srcdir}/0008-Add-nvidia-release-notes-file.patch"
}
build() {