summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGrey Christoforo2015-10-25 01:42:16 +0100
committerGrey Christoforo2015-10-25 01:42:16 +0100
commitc4e3d6179ff6e0ae0d25af3b7003fe5f90147a58 (patch)
tree7d8f35fcca3e870a92dc68729c253d31d980bb01
parent57e13828d26a991963027e1aad706fe7f78ad912 (diff)
downloadaur-c4e3d6179ff6e0ae0d25af3b7003fe5f90147a58.tar.gz
fix some refs to weston
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD7
2 files changed, 5 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5e9ab02701c1..bfb0a585b471 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -17,7 +17,7 @@ pkgbase = weston-rbp
depends = colord
provides = weston
replaces = weston
- source = http://wayland.freedesktop.org/releases/weston-rbp-1.9.0.tar.xz
+ source = http://wayland.freedesktop.org/releases/weston-1.9.0.tar.xz
sha1sums = 94b70baca9a6ba007c696b740a711586f9dc274f
pkgname = weston-rbp
diff --git a/PKGBUILD b/PKGBUILD
index 414f14f91f86..72f1b6c668b4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -14,10 +14,11 @@ replaces=('weston')
url='http://wayland.freedesktop.org'
license=('MIT')
depends=('libxkbcommon' 'libinput' 'libunwind' 'poppler-glib' 'mtdev' 'libxcursor' 'glu' 'pango' 'colord')
-source=("http://wayland.freedesktop.org/releases/$pkgname-$pkgver.tar.xz")
+source=("http://wayland.freedesktop.org/releases/weston-$pkgver.tar.xz")
sha1sums=('94b70baca9a6ba007c696b740a711586f9dc274f')
build() {
+ cd weston-$pkgver
export RPI_BCM_HOST_LIBS="-L/opt/vc/lib"
export RPI_BCM_HOST_CFLAGS="-I/opt/vc/include -I/opt/vc/include/interface/vcos/pthreads -I/opt/vc/include/interface/vmcs_host/linux"
export WESTON_NATIVE_BACKEND="rpi-backend.so"
@@ -33,8 +34,8 @@ build() {
}
package() {
- cd $pkgname-$pkgver
+ cd weston-$pkgver
make DESTDIR="$pkgdir" install
# license
- install -Dm644 COPYING "$pkgdir/usr/share/licenses/$pkgname/COPYING"
+ install -Dm644 COPYING "$pkgdir/usr/share/licenses/weston/COPYING"
}