summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBen Alex2015-06-10 13:47:41 +1000
committerBen Alex2015-06-10 13:47:41 +1000
commit708ab9b2f648bd25a1a913ecb7b792bc4f48e045 (patch)
tree800a94111b283a60ff285e5fc548fc84e6437b9b
downloadaur-708ab9b2f648bd25a1a913ecb7b792bc4f48e045.tar.gz
Initial import
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD28
2 files changed, 43 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7d4211e48bd7
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = westpac-git
+ pkgdesc = Westpac balance and transaction history scraper
+ pkgver = r22.624089b
+ pkgrel = 1
+ url = https://github.com/benalexau/westpac-balance-scraper
+ arch = any
+ license = unknown
+ makedepends = git
+ depends = python2-pycurl
+ depends = python2-beautifulsoup3
+ source = westpac-git::git+https://github.com/benalexau/westpac-balance-scraper.git
+ md5sums = SKIP
+
+pkgname = westpac-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7cb8096869e9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Contributor: Ben Alex <ben.alex@acegi.com.au>
+
+pkgname=westpac-git
+pkgver=r22.624089b
+pkgrel=1
+pkgdesc="Westpac balance and transaction history scraper"
+arch=('any')
+url="https://github.com/benalexau/westpac-balance-scraper"
+license=unknown
+depends=('python2-pycurl' 'python2-beautifulsoup3')
+makedepends=('git')
+source=("$pkgname"::'git+https://github.com/benalexau/westpac-balance-scraper.git')
+md5sums=('SKIP')
+build=()
+
+pkgver() {
+ cd "$srcdir/$pkgname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd "$srcdir/$pkgname"
+ mkdir -p $pkgdir/usr/bin
+ mkdir -p $pkgdir/usr/share/westpac
+ install -Dm755 "$srcdir/$pkgname/westpac" "$pkgdir/usr/share/westpac/westpac"
+ install -Dm644 "$srcdir/$pkgname/cacert.pem" "$pkgdir/usr/share/westpac/cacert.pem"
+ ln -s "/usr/share/westpac/westpac" "$pkgdir/usr/bin/westpac"
+} \ No newline at end of file