summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorThayne McCombs2020-03-29 23:17:05 -0600
committerThayne McCombs2020-03-29 23:18:11 -0600
commita7b4f674e18ddfd629efe58aa222e463fa653760 (patch)
tree33a49b474440f0fa766ea6ecdeb7b91e0204d02e
downloadaur-a7b4f674e18ddfd629efe58aa222e463fa653760.tar.gz
Initial upload: wev 1.0.0-1
-rw-r--r--.SRCINFO16
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD24
3 files changed, 44 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8f4101502b6d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = wev
+ pkgver = 1.0.0
+ pkgrel = 1
+ url = https://git.sr.ht/~sircmpwn/wev
+ arch = i686
+ arch = x86_64
+ license = MIT
+ makedepends = scdoc
+ depends = wayland
+ depends = wayland-protocols
+ depends = libxkbcommon
+ conflicts = wev-git
+ source = https://git.sr.ht/~sircmpwn/wev/archive/1.0.0.tar.gz
+ md5sums = 202208092a6560b1a78c568996a4cf27
+
+pkgname = wev
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..574a8578368c
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+/src
+/pkg
+*.tar.gz
+*.tar.xz
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4eddb6166806
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Thayne McCombs <astrothayne at gmail dot com>
+pkgname=wev
+pkgver=1.0.0
+pkgrel=1
+pkgdec="tool for debugging wayland events, similar to xev"
+url='https://git.sr.ht/~sircmpwn/wev'
+license=(MIT)
+arch=('i686' 'x86_64')
+depends=('wayland' 'wayland-protocols' 'libxkbcommon')
+makedepends=('scdoc')
+conflicts=('wev-git')
+source=("https://git.sr.ht/~sircmpwn/wev/archive/$pkgver.tar.gz")
+md5sums=('202208092a6560b1a78c568996a4cf27')
+
+build() {
+ cd "$pkgname-$pkgver"
+ make
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+ make DESTDIR="$pkgdir/" PREFIX=/usr MANDIR=/usr/share/man install
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}