summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorStephen Gregoratto2020-03-30 13:45:18 +1100
committerStephen Gregoratto2020-03-30 13:45:18 +1100
commit6a7c5fab20c7b040792a45d0d04fbcce069b1836 (patch)
treec02edca61c59c1b74f1d74be57a780a13fc2df77
parentb3808f8c429668833c8f4b931ff5cc9a87aa7bc4 (diff)
downloadaur-6a7c5fab20c7b040792a45d0d04fbcce069b1836.tar.gz
Patch makefile to use (C|CPP|LD)FLAGS
-rw-r--r--.SRCINFO6
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD21
-rw-r--r--wev-git.patch16
4 files changed, 39 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index daaa4afc1d1a..fcb33416fa09 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = wev-git
pkgdesc = Print wayland events, like xev(1)
- pkgver = r3.47d1739
- pkgrel = 2
+ pkgver = 1.0.0.r0.gcee3dfb
+ pkgrel = 1
url = https://git.sr.ht/~sircmpwn/wev
arch = i686
arch = x86_64
@@ -15,7 +15,9 @@ pkgbase = wev-git
depends = libxkbcommon
provides = wev
source = wev::git+https://git.sr.ht/~sircmpwn/wev
+ source = wev-git.patch
sha256sums = SKIP
+ sha256sums = d93b7cfbee98559178b1e650ae1bbdd7bb2fe07376c76a0312cb17c7529472f9
pkgname = wev-git
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..a41858f82da8
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+*
+!.SRCINFO
+!PKGBUILD
+!.gitignore
+!wev-git.patch
diff --git a/PKGBUILD b/PKGBUILD
index 8f310f2fb13e..9f3ab79f3f0b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
-# Maintainer: KingofToasters <dev@sgregoratto.me>
+# Maintainer: Stephen Gregoratto <dev@sgregoratto.me>
pkgname=wev-git
-pkgver=r3.47d1739
-pkgrel=2
+pkgver=1.0.0.r0.gcee3dfb
+pkgrel=1
pkgdesc='Print wayland events, like xev(1)'
url='https://git.sr.ht/~sircmpwn/wev'
license=('MIT')
@@ -9,8 +9,10 @@ provides=('wev')
arch=('i686' 'x86_64' 'armv6h' 'armv7h')
depends=('wayland' 'wayland-protocols' 'libxkbcommon')
makedepends=('git' 'scdoc')
-source=("${pkgname%-git}::git+$url")
-sha256sums=('SKIP')
+source=("${pkgname%-git}::git+$url"
+ "wev-git.patch")
+sha256sums=('SKIP'
+ 'd93b7cfbee98559178b1e650ae1bbdd7bb2fe07376c76a0312cb17c7529472f9')
pkgver() {
cd "${pkgname%-git}"
@@ -20,6 +22,11 @@ pkgver() {
)
}
+prepare() {
+ cd "${pkgname%-git}"
+ patch -Np1 -i "$srcdir/wev-git.patch"
+}
+
build() {
cd "${pkgname%-git}"
make
@@ -27,6 +34,6 @@ build() {
package() {
cd "${pkgname%-git}"
- make DESTDIR="$pkgdir/" PREFIX="/usr" MANDIR="/usr/share/man" install
- install -Dm644 "LICENSE" "$pkgdir/usr/share/licenses/${pkgname}/LICENCE"
+ make DESTDIR="$pkgdir" PREFIX="/usr" MANDIR="/usr/share/man" install
+ install -Dm644 "LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}
diff --git a/wev-git.patch b/wev-git.patch
new file mode 100644
index 000000000000..35d583eebabf
--- /dev/null
+++ b/wev-git.patch
@@ -0,0 +1,16 @@
+diff -ura wev.old/Makefile wev.new/Makefile
+--- wev.old/Makefile 2020-03-30 13:38:48.947716009 +1100
++++ wev.new/Makefile 2020-03-30 13:40:04.044187743 +1100
+@@ -14,10 +14,10 @@
+ $(WAYLAND_PROTOCOLS)/stable/xdg-shell/xdg-shell.xml $@
+
+ wev: wev.c shm.c xdg-shell-protocol.h xdg-shell-protocol.c
+- $(CC) $(CFLAGS) \
++ $(CC) $(CPPFLAGS) $(CFLAGS) \
+ -g -std=c11 -I. \
+ -o wev wev.c shm.c xdg-shell-protocol.c \
+- $(LIBS) -lrt
++ $(LIBS) -lrt $(LDFLAGS)
+
+ wev.1: wev.1.scd
+ $(SCDOC) < wev.1.scd > wev.1