aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorZadkiel2019-07-21 14:21:13 +0200
committerZadkiel2019-07-21 14:21:13 +0200
commit56d601893e4e18f97d800eb4a5cdb8bf77b0ca8c (patch)
treed874775c2f820ae5570db85a1008c0991383896a
downloadaur-56d601893e4e18f97d800eb4a5cdb8bf77b0ca8c.tar.gz
initial commit
-rw-r--r--.SRCINFO21
-rw-r--r--.gitignore6
-rw-r--r--.travis-ci.yml5
-rw-r--r--PKGBUILD52
-rw-r--r--README.md18
-rw-r--r--docker-compose.yml8
-rwxr-xr-xwexond5
7 files changed, 115 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..419acaa545c8
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = wexond
+ pkgdesc = A privacy-focused, extensible and beautiful web browser
+ pkgver = 2.2.3
+ pkgrel = 1
+ url = https://github.com/wexond/wexond
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = p7zip
+ provides = wexond
+ conflicts = wexond
+ options = !strip
+ source = wexond
+ sha256sums = SKIP
+ source_i686 = wexond-2.2.3.AppImage::https://github.com/wexond/wexond/releases/download/v2.2.3/wexond-2.2.3-i386.AppImage
+ sha256sums_i686 = 6810f89c1af92eab502c3be5e9d93d3c2be4f8fea2e699cd72c8693cace30c84
+ source_x86_64 = wexond-2.2.3.AppImage::https://github.com/wexond/wexond/releases/download/v2.2.3/wexond-2.2.3-x86_64.AppImage
+ sha256sums_x86_64 = ea1906f136c154520e7bc599e2ab6fd439ca74ef473e49f4e454930d8faf6619
+
+pkgname = wexond
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..86cdac9980f6
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,6 @@
+pkg
+src
+squashfs-root
+*.AppImage
+*.pkg.tar
+*.pkg.tar.xz \ No newline at end of file
diff --git a/.travis-ci.yml b/.travis-ci.yml
new file mode 100644
index 000000000000..e2be3aa43b9d
--- /dev/null
+++ b/.travis-ci.yml
@@ -0,0 +1,5 @@
+services:
+ - docker
+script:
+ - docker-compose run --user=2000:2000 --rm makepkg makepkg -f
+ - docker-compose run --user=root --rm makepkg pacman -U --noconfirm *.tar.xz
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..de128204f623
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,52 @@
+# Maintainer: Étienne Deparis <etienne@depar.is>
+
+pkgname=wexond
+pkgver=2.2.3
+pkgrel=1
+pkgdesc='A privacy-focused, extensible and beautiful web browser'
+arch=('i686' 'x86_64')
+url='https://github.com/wexond/wexond'
+license=('GPL')
+makedepends=('p7zip')
+options=('!strip')
+provides=(wexond)
+conflicts=(wexond)
+source=('wexond')
+source_i686=("wexond-${pkgver}.AppImage::https://github.com/wexond/wexond/releases/download/v${pkgver}/wexond-${pkgver}-i386.AppImage")
+source_x86_64=("wexond-${pkgver}.AppImage::https://github.com/wexond/wexond/releases/download/v${pkgver}/wexond-${pkgver}-x86_64.AppImage")
+sha256sums=(SKIP)
+sha256sums_i686=('6810f89c1af92eab502c3be5e9d93d3c2be4f8fea2e699cd72c8693cace30c84')
+sha256sums_x86_64=('ea1906f136c154520e7bc599e2ab6fd439ca74ef473e49f4e454930d8faf6619')
+
+prepare() {
+ cd $srcdir
+ chmod u+x wexond-${pkgver}.AppImage
+ ./wexond-${pkgver}.AppImage --appimage-extract 2> /dev/null
+}
+
+build() {
+ cd $srcdir
+ sed -i "s/^Exec=AppRun$/Exec=$pkgname/" squashfs-root/wexond.desktop
+ # sed -i "s/^Categories=AudioVideo/Categories=Video;Player;AudioVideo/" squashfs-root/molotov.desktop
+ sed -i "s/WEXOND_VERSION/${pkgver}/g" wexond
+}
+
+package() {
+ cd $srcdir
+
+ install -d -m755 $pkgdir/usr/share/{applications,icons/hicolor}
+ install -d -m755 $pkgdir/opt/appimages
+ # TODO find a decent license
+ #install -d -m755 $pkgdir/usr/share/licenses/$pkgname
+
+ hicolor="squashfs-root/usr/share/icons/hicolor"
+ for size in $(ls -1 $hicolor); do
+ install -d -m755 $pkgdir/usr/share/icons/hicolor/$size/apps
+ install -D -m644 $hicolor/$size/apps/wexond.png $pkgdir/usr/share/icons/hicolor/$size/apps/wexond.png
+ done
+
+ install -D -m644 squashfs-root/wexond.desktop $pkgdir/usr/share/applications/appimagekit-wexond.desktop
+ install -D -m755 wexond $pkgdir/usr/bin/wexond
+ install -D -m755 wexond-$pkgver.AppImage $pkgdir/opt/appimages/wexond-$pkgver.AppImage
+ rm -r squashfs-root
+} \ No newline at end of file
diff --git a/README.md b/README.md
new file mode 100644
index 000000000000..2e5e45ef5718
--- /dev/null
+++ b/README.md
@@ -0,0 +1,18 @@
+# Wexond AUR package (appimage)
+
+[![Build Status](https://travis-ci.org/aslafy-z/aur-wexond-appimage.svg?branch=master)](https://travis-ci.org/aslafy-z/aur-wexond-appimage)
+
+Official sources for the Wexond AUR package (https://github.com/aslafy-z/aur-wexond-appimage).
+
+AUR repository: https://aur.archlinux.org/wexond-appimage.git
+
+# Updating Version
+
+refer to https://wiki.archlinux.org/index.php/Creating_packages
+
+- update `pkgver` to Wexond version
+- increase `pkgrel` on any changes to PKGBUILD itself, reset to 1 on any updates to `pkgver`
+- update `sha256sums` (Appimage)
+- recreate `.SRCINFO` (`docker-compose run --rm makepkg --printsrcinfo > .SRCINFO`)
+- verify everything works and push changes to AUR (careful: latest commit on master is directly released)
+
diff --git a/docker-compose.yml b/docker-compose.yml
new file mode 100644
index 000000000000..87aaa92cb875
--- /dev/null
+++ b/docker-compose.yml
@@ -0,0 +1,8 @@
+version: '3'
+
+services:
+ makepkg:
+ image: imrehg/archlinux-makepkg
+ volumes:
+ - '.:/home/builder/'
+ command: sh -c "makepkg --printsrcinfo > .SRCINFO && makepkg -fi --noconfirm"
diff --git a/wexond b/wexond
new file mode 100755
index 000000000000..5176cb9a4ba7
--- /dev/null
+++ b/wexond
@@ -0,0 +1,5 @@
+#!/usr/bin/env bash
+
+[ -z "$XDG_DATA_DIRS" ] && export XDG_DATA_DIRS=$HOME/.local/share:/usr/share
+export APPIMAGE_SILENT_INSTALL=yes
+exec /opt/appimages/wexond-WEXOND_VERSION.AppImage --no-sandbox