summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorWez Furlong2020-06-07 09:50:26 -0700
committerWez Furlong2020-06-07 09:50:26 -0700
commitc75b09f8ed8796ffe696f079ff2bff3324d1457c (patch)
tree98c84e38167d3e847c8f19a8a73ff2f01b359724
parent88bed30c50313d06a998b60062f93f99d67dd4d3 (diff)
downloadaur-c75b09f8ed8796ffe696f079ff2bff3324d1457c.tar.gz
Now includes .desktop and color schemes
-rw-r--r--.SRCINFO13
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD44
-rwxr-xr-xbuild.sh7
4 files changed, 57 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d82ce68f224a..d3910696801a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,20 +1,27 @@
pkgbase = wezterm-nightly-bin
pkgdesc = Bleeding edge builds of a GPU-accelerated cross-platform terminal emulator and multiplexer implemented in Rust
pkgver = 20200517.122836.92c201c6.105.g5d508350
- pkgrel = 1
+ pkgrel = 2
url = https://wezfurlong.org/wezterm
arch = i686
arch = x86_64
license = MIT
- depends = fuse
+ makedepends = fuse
+ depends = dbus
+ depends = fontconfig
+ depends = hicolor-icon-theme
depends = libx11
+ depends = libxkbcommon-x11
+ depends = wayland
+ depends = xcb-util-keysyms
+ depends = xcb-util-wm
provides = wezterm
conflicts = wezterm-bin
options = !strip
source = wezterm::https://github.com/wez/wezterm/releases/download/nightly/WezTerm-nightly-Ubuntu16.04.AppImage
source = LICENSE::https://github.com/wez/wezterm/raw/master/LICENSE.md
sha256sums = SKIP
- sha256sums = SKIP
+ sha256sums = 191c46fcf52061382b1c51a70311eb9081381cc158e5899f3739473a9432185b
pkgname = wezterm-nightly-bin
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..39a4dc46e432
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+LICENSE
+src
+pkg
+wezterm*
+squashfs-root
diff --git a/PKGBUILD b/PKGBUILD
index 46c12c92bf16..34f2ce3f19a0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,29 +2,55 @@
pkgname=wezterm-nightly-bin
pkgver=20200517.122836.92c201c6.105.g5d508350
-pkgrel=1
+pkgrel=2
pkgdesc='Bleeding edge builds of a GPU-accelerated cross-platform terminal emulator and multiplexer implemented in Rust'
arch=('i686' 'x86_64')
url='https://wezfurlong.org/wezterm'
license=('MIT')
provides=('wezterm')
+conflicts=('wezterm-bin')
# Don't strip: it will break the AppImage!
options=('!strip')
-depends=('fuse' 'libx11')
-conflicts=('wezterm-bin')
-source=("wezterm::https://github.com/wez/wezterm/releases/download/nightly/WezTerm-nightly-Ubuntu16.04.AppImage"
- 'LICENSE::https://github.com/wez/wezterm/raw/master/LICENSE.md')
-sha256sums=('SKIP' 'SKIP')
+depends=('fuse')
+makedepends=('fuse')
+depends=(
+ 'dbus'
+ 'fontconfig'
+ 'hicolor-icon-theme'
+ 'libx11'
+ 'libxkbcommon-x11'
+ 'wayland'
+ 'xcb-util-keysyms'
+ 'xcb-util-wm'
+)
+source=(
+ "wezterm::https://github.com/wez/wezterm/releases/download/nightly/WezTerm-nightly-Ubuntu16.04.AppImage"
+ 'LICENSE::https://github.com/wez/wezterm/raw/master/LICENSE.md'
+)
+sha256sums=(
+ 'SKIP'
+ '191c46fcf52061382b1c51a70311eb9081381cc158e5899f3739473a9432185b'
+)
prepare() {
- chmod +x ${srcdir}/wezterm
+ chmod +x "${srcdir}/wezterm"
}
pkgver() {
- ${srcdir}/wezterm --version | cut -d' ' -f2 | tr - .
+ "${srcdir}/wezterm" --version | cut -d' ' -f2 | tr - .
+}
+
+build() {
+ "${srcdir}/wezterm" --appimage-extract >/dev/null
}
package() {
- install -Dm755 wezterm -t "${pkgdir}/usr/bin/"
+ install -Dm755 squashfs-root/usr/bin/wezterm -t "${pkgdir}/usr/bin/"
install -Dm644 LICENSE -t "${pkgdir}/usr/share/licenses/${pkgname}"
+ install -Dm644 squashfs-root/usr/share/icons/hicolor/128x128/apps/org.wezfurlong.wezterm.png \
+ "${pkgdir}/usr/share/icons/hicolor/128x128/apps/org.wezfurlong.wezterm.png"
+ install -Dm644 squashfs-root/usr/share/applications/org.wezfurlong.wezterm.desktop \
+ "${pkgdir}/usr/share/applications/org.wezfurlong.wezterm.desktop"
+ install -dm755 ${pkgdir}/usr/share/wezterm/colors
+ install -Dm644 -t ${pkgdir}/usr/share/wezterm/colors/* squashfs-root/usr/share/wezterm/colors/*
}
diff --git a/build.sh b/build.sh
new file mode 100755
index 000000000000..006f49b41295
--- /dev/null
+++ b/build.sh
@@ -0,0 +1,7 @@
+#!/bin/bash
+set -e
+set -x
+makepkg --force
+makepkg --printsrcinfo > .SRCINFO
+namcap PKGBUILD
+namcap wezterm*.pkg.tar.xz