summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAdrian Perez de Castro2020-01-02 17:55:30 +0200
committerAdrian Perez de Castro2020-01-02 17:55:30 +0200
commit7c50c40d6ca2007052994e6e43753c9c5e4d3637 (patch)
treed0cbe6fdac886030b6b80222d478cad8a0f32816
parent59e7663f41ae875bff83779baf89e4557ce0bd65 (diff)
downloadaur-7c50c40d6ca2007052994e6e43753c9c5e4d3637.tar.gz
Explicitly enable PulseAudio support
Always build support for the PulseAudio volume widget. This is more robust than relying on Meson automatically deciding whether to enable it or not because automatic selection can result in a built package which depends on PulseAudio at runtime, but it has no dependency on its package, which in turn allows the package manager to remove the PulseAudio package even if it's needed by wf-shell-git. This change prevents this issue.
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD6
2 files changed, 5 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index fff0ba7015e1..80917e164691 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = wf-shell-git
pkgdesc = GTK3-based panel for the Wayfire compositor
- pkgver = r127.5593eab
+ pkgver = r129.d319b01
pkgrel = 1
url = https://wayfire.org
arch = x86_64
@@ -14,6 +14,7 @@ pkgbase = wf-shell-git
depends = wf-config
depends = gtkmm3
depends = gtk-layer-shell
+ depends = pulseaudio
provides = wf-shell
conflicts = wf-shell
source = wf-shell-git::git+https://github.com/WayfireWM/wf-shell
diff --git a/PKGBUILD b/PKGBUILD
index 446b83e077a7..087976cde5f9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: Adrian Perez de Castro <aperez@igalia.com>
pkgname=wf-shell-git
-pkgver=r127.5593eab
+pkgver=r129.d319b01
pkgrel=1
pkgdesc='GTK3-based panel for the Wayfire compositor'
url=https://wayfire.org
@@ -8,7 +8,7 @@ arch=(x86_64)
license=(custom:MIT)
provides=("${pkgname%-git}")
conflicts=("${provides[@]}")
-depends=(wf-config gtkmm3 gtk-layer-shell)
+depends=(wf-config gtkmm3 gtk-layer-shell pulseaudio)
makedepends=(wayland wayland-protocols meson ninja git gobject-introspection)
source=("${pkgname}::git+https://github.com/WayfireWM/wf-shell")
sha512sums=('SKIP')
@@ -24,7 +24,7 @@ pkgver () {
build () {
rm -rf build
- arch-meson "${pkgname}" build
+ arch-meson "${pkgname}" build -Dpulse=enabled
ninja -C build
}