summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorgigamicro2024-04-15 21:46:40 -0400
committergigamicro2024-04-15 21:46:40 -0400
commit150b5e9ab7fdbe37acff0f47935672d9f94cba74 (patch)
treed9e0b6e177a4c3237f80963c93158f9e254cc515
parent92b7aeaaf2554686e3f63b6dca3a8d72b4db2e7c (diff)
downloadaur-150b5e9ab7fdbe37acff0f47935672d9f94cba74.tar.gz
add write to "$CACHEDIR/EElogloc"
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD2
-rw-r--r--wfinfo.sh2
3 files changed, 4 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a3991a2adcc7..edd084cfa429 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -20,6 +20,6 @@ pkgbase = wfinfo-ng-git
source = wfinfo-ng::git+https://github.com/knoellle/wfinfo-ng.git
source = wfinfo.sh
sha256sums = SKIP
- sha256sums = c3c00bc85a62d59742ff16bae95b41b88829439162db9b812c8f1a25dae768ac
+ sha256sums = 79a10b27dc87328fbb35bb7c10f3eb33ff6459c55e301ada4db2f352ae5f770f
pkgname = wfinfo-ng-git
diff --git a/PKGBUILD b/PKGBUILD
index ab3b692a9c7b..d7fd635ac56d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -14,7 +14,7 @@ optdepends=('mlocate: to autodetect EE.log location')
provides=('wfinfo')
#conflicts=('wfinfo')
source=("$_pkgname::git+https://github.com/knoellle/wfinfo-ng.git" 'wfinfo.sh')
-sha256sums=('SKIP' 'c3c00bc85a62d59742ff16bae95b41b88829439162db9b812c8f1a25dae768ac')
+sha256sums=('SKIP' '79a10b27dc87328fbb35bb7c10f3eb33ff6459c55e301ada4db2f352ae5f770f')
pkgver() {
cd "$srcdir/$_pkgname"
diff --git a/wfinfo.sh b/wfinfo.sh
index 47a7a8f7a7a1..cff5ac7d9099 100644
--- a/wfinfo.sh
+++ b/wfinfo.sh
@@ -20,6 +20,8 @@ if ! [ -r "$logloc" ]; then
echo Invalid or unreadable EE.log location \""$logloc"\", exiting...
exit 4
fi
+printf %s\\n "$logloc" > "$CACHEDIR/EElogloc" && echo Storing EE.log location...
+
wfinfo-update ||
if [ -f "$CACHEDIR/filtered_items.json" ] && [ -f "$CACHEDIR/prices.json" ]; then
echo Update failed, continuing...