summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorgigamicro2024-04-14 15:19:46 -0400
committergigamicro2024-04-14 15:19:46 -0400
commit915aab0f71fc77a8c432ec8ad107cfed0e56e44a (patch)
treed1fa3563d05492811992ac40603c718c1d74a6a8
parent2b3ad32348616ac7f5b73c1f99e268f43c9e80c1 (diff)
downloadaur-915aab0f71fc77a8c432ec8ad107cfed0e56e44a.tar.gz
remove jq dep
-rw-r--r--PKGBUILD4
1 files changed, 3 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index bbfa6241a69a..755bb6dd7407 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,7 +8,7 @@ epoch=1
arch=('any') #TODO: verify this
url="https://github.com/knoellle/wfinfo-ng"
license=('GPL-3.0')
-depends=('curl' 'jq') # database updates
+depends=(curl)
makedepends=(git rust\>=1.74 cargo libxrandr tesseract tesseract-data-eng cmake clang libxi libxtst fontconfig)
#checkdepends=('')
optdepends=('mlocate: to autodetect EE.log location')
@@ -25,6 +25,8 @@ pkgver() {
build(){
cd "$srcdir/$_pkgname"
env CARGO_INCREMENTAL=0 CFLAGS= cargo build --release --locked
+ # following line is to remove the 'jq' dependency (specifically, trimming the " | jq ." part)
+ cut update.sh -d\ -f-2,6- > update.sh~; chmod --reference=update.sh update.sh~; mv -f update.sh~ update.sh
}
check(){