summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGene C2025-02-27 12:46:41 -0500
committerGene C2025-02-27 12:46:41 -0500
commit0fe9bef39182e6854fac31edc7e8f799a3a6ce1d (patch)
tree4ec27ec0fbf31328faae644252d6f3a685ca484f
parent91c7cabee8c84938410d806a863c97c7b4777978 (diff)
downloadaur-0fe9bef39182e6854fac31edc7e8f799a3a6ce1d.tar.gz
update project version 6.6.0
-rw-r--r--.SRCINFO5
-rw-r--r--Changelog.rst8
-rw-r--r--PKGBUILD9
3 files changed, 16 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 84418737dc9e..8ee9ecabb74b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = wg-client
pkgdesc = Wireguard linux client (command line and gui)
- pkgver = 6.5.0
+ pkgver = 6.6.0
pkgrel = 1
url = https://github.com/gene-git/wg-client
install = wg-client.install
@@ -17,11 +17,12 @@ pkgbase = wg-client
depends = python-pyqt6
depends = hicolor-icon-theme
depends = python-psutil
+ depends = python-dateutil
depends = python-netifaces
depends = libcap
depends = python-pynotify
depends = openssl>=3.0
- source = git+https://github.com/gene-git/wg-client#tag=6.5.0
+ source = git+https://github.com/gene-git/wg-client#tag=6.6.0
validpgpkeys = 7CCA1BA66669F3273DB52678E5B81343AB9809E1
sha512sums = SKIP
diff --git a/Changelog.rst b/Changelog.rst
index e26d072afd50..6f72b21724bb 100644
--- a/Changelog.rst
+++ b/Changelog.rst
@@ -1,6 +1,14 @@
Changelog
=========
+**[6.6.0] ----- 2025-02-27** ::
+
+ Improve ssh retry loop after ssh session is dropped
+ Increase saved logs 2x10k to 5x100k
+ wg-dn stops any ssh listener as well
+ update Docs/Changelog.rst Docs/wg-client.pdf
+
+
**[6.5.0] ----- 2024-12-31** ::
Git tags are now signed.
diff --git a/PKGBUILD b/PKGBUILD
index 39e715066e62..c3b65ac48ed2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -10,7 +10,7 @@ pkgname='wg-client'
pkgdesc='Wireguard linux client (command line and gui)'
_gitname='wg-client'
-pkgver=6.5.0
+pkgver=6.6.0
pkgrel=1
url="https://github.com/gene-git/wg-client"
@@ -20,13 +20,14 @@ license=(MIT)
install='wg-client.install'
# To build docs uncommont sphinx/texlive
-depends=('python>=3.13' 'python-pyqt6' 'hicolor-icon-theme' 'python-psutil'
+depends=('python>=3.13' 'python-pyqt6' 'hicolor-icon-theme' 'python-psutil' 'python-dateutil'
'python-netifaces' 'libcap' 'python-pynotify' 'openssl>=3.0')
makedepends=('git' 'python-build' 'python-wheel' 'python-installer' 'python-hatch' 'rsync'
#'python-sphinx' 'python-myst-parser' 'texlive-latexextra'
)
-
+# Used by package : mkpkg
_mkpkg_depends=('python>minor')
+
#
# Verifying Signed Tag
# Add arch@sapience.com key to keyring then use the source line with "?signed"
@@ -68,7 +69,7 @@ build() {
package() {
cd "${_gitname}"
- cp Docs/Changelog.rst ${startdir}
+ #cp Docs/Changelog.rst ${startdir}
./scripts/do-install ${pkgdir}
}
# vim:set ts=4 sts=4 sw=4 et: