summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGene C2023-09-26 09:26:30 -0400
committerGene C2023-09-26 09:26:30 -0400
commita66dd661e0b2f7996e0f442e4f3223d0779e5888 (patch)
tree1007678d265a2ed32bc79f469a464dfb64db617d
parent17f6c43efe14feb0cc403439b336ce0f2270986f (diff)
downloadaur-a66dd661e0b2f7996e0f442e4f3223d0779e5888.tar.gz
update project version 5.3.1
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD18
2 files changed, 21 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d2b6c2b6601c..94ff38ee9bd9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = wg_tool
pkgdesc = Tool to manage wireguard server and user configs
- pkgver = 5.1.1
+ pkgver = 5.3.1
pkgrel = 1
url = https://github.com/gene-git/wg_tool
arch = any
@@ -18,7 +18,10 @@ pkgbase = wg_tool
depends = python-qrcode
depends = wireguard-tools
depends = python-tomli
- source = git+https://github.com/gene-git/wg_tool#tag=5.1.1
+ optdepends = python-sphinx: Docs
+ optdepends = python-myst-parser: Docs
+ optdepends = texlive-latexextra: PDF Docs
+ source = git+https://github.com/gene-git/wg_tool#tag=5.3.1
sha512sums = SKIP
pkgname = wg_tool
diff --git a/PKGBUILD b/PKGBUILD
index dcdcf6b560d9..4fdf4dd26a49 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -10,7 +10,7 @@ pkgname='wg_tool'
pkgdesc='Tool to manage wireguard server and user configs'
_gitname='wg_tool'
-pkgver=5.1.1
+pkgver=5.3.1
pkgrel=1
url="https://github.com/gene-git/wg_tool"
@@ -21,7 +21,15 @@ depends=('python>3.9' 'python-packaging' 'python-netaddr'
'python-tomli-w' 'python-qrcode' 'wireguard-tools'
'python-tomli'
)
-makedepends=('git' 'python-build' 'python-installer' 'python-wheel' 'python-poetry' 'rsync')
+optdepends=('python-sphinx: Docs'
+ 'python-myst-parser: Docs'
+ 'texlive-latexextra: PDF Docs')
+
+# To build docs uncommont the sphinx/myst/texlive
+makedepends=('git' 'python-build' 'python-installer' 'python-wheel' 'python-poetry' 'rsync'
+ #'python-sphinx' 'python-myst-parser' 'texlive-latexextra' # Docs
+ )
+
_mkpkg_depends=('python>minor')
source=("git+https://github.com/gene-git/${_gitname}#tag=${pkgver}")
sha512sums=('SKIP')
@@ -30,6 +38,12 @@ build() {
cd "${_gitname}"
/usr/bin/rm -f dist/*
/usr/bin/python -m build --wheel --no-isolation
+
+ # To build Docs - uncomment these and sphinx makedepends above
+# echo "Build docs"
+# cd ./Docs
+# make html
+# make latexpdf
}
package() {