summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorWorty2020-05-31 16:28:33 +0200
committerWorty2020-05-31 16:28:33 +0200
commitc6ea5b78688ccfb5dd8a02106ef096441022212f (patch)
tree15599e202164f2ad834d5d3153ed99389a2931ed
downloadaur-c6ea5b78688ccfb5dd8a02106ef096441022212f.tar.gz
Package submission
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD29
2 files changed, 42 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a9776e84d036
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = wgcf
+ pkgdesc = Generate WireGuard profile from Cloudflare Warp account
+ pkgver = 1.0.6
+ pkgrel = 1
+ url = https://github.com/ViRb3/wgcf
+ arch = x86_64
+ license = custom
+ makedepends = go
+ source = wgcf-1.0.6.tar.gz::https://github.com/ViRb3/wgcf/archive/v1.0.6.tar.gz
+ sha256sums = d3d3123d002c1b5dc5a321d4c122436981254951d1c46565575888a8bade44b3
+
+pkgname = wgcf
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..19ab22d78df6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: w0rty <mawo97 at gmail.com>
+
+pkgname=wgcf
+pkgver=1.0.6
+pkgrel=1
+pkgdesc='Generate WireGuard profile from Cloudflare Warp account'
+arch=('x86_64')
+url="https://github.com/ViRb3/wgcf"
+license=('custom')
+makedepends=('go')
+source=("${pkgname}-${pkgver}.tar.gz::${url}/archive/v${pkgver}.tar.gz")
+sha256sums=('d3d3123d002c1b5dc5a321d4c122436981254951d1c46565575888a8bade44b3')
+
+prepare(){
+ cd "$pkgname-$pkgver"
+ mkdir -p build/
+}
+
+build() {
+ export GOPATH="$srcdir"/gopath
+ cd "$pkgname-$pkgver"
+ export CGO_ENABLED="1"
+ go build -o build -trimpath -buildmode=pie -ldflags "-s -w"
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+ install -Dm755 build/$pkgname "$pkgdir"/usr/bin/$pkgname
+}