summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDarshit Shah2021-11-15 19:44:46 +0100
committerDarshit Shah2021-11-15 19:44:46 +0100
commit2e7ca4f2ead08b67ecc0d7ac84cdc02a5e55d722 (patch)
tree70b6d7fa5d6347655aab2cd8b03bbaf232acdbd8
parent5248b4c3e0205593eec3ca3ecda7887f3632630a (diff)
downloadaur-2e7ca4f2ead08b67ecc0d7ac84cdc02a5e55d722.tar.gz
Fix makedepends and catch-22 in build
-rw-r--r--PKGBUILD10
1 files changed, 7 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index f2b73e3e2766..fab785a03347 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
_gitname=wget
pkgname=$_gitname-git
-pkgver=1.21.r2.g5a7f2f7e
+pkgver=1.21.2.r4.g65e6d5b3
pkgrel=1
pkgdesc="A network utility to retrieve files from the Web"
arch=('i686' 'x86_64')
@@ -11,7 +11,7 @@ license=('GPL3')
depends=('libutil-linux' 'gnutls' 'libidn' 'libpsl' 'gpgme')
optdepends=("ca-certificates: HTTPS Downloads")
checkdepends=('perl' 'perl-http-daemon' 'perl-io-socket-ssl' 'python')
-makedepends=('git' 'perl' 'rsync')
+makedepends=('git' 'perl' 'rsync' 'gperf' 'autoconf-archive')
provides=('wget')
conflicts=('wget')
backup=('etc/wgetrc')
@@ -25,7 +25,11 @@ build() {
git submodule init
git config submodule.gnulib.url "$srcdir/gnulib"
git submodule update gnulib
- ./bootstrap
+ if command -v wget 2>&1 >/dev/null; then
+ ./bootstrap
+ else
+ ./bootstrap --skip-po
+ fi
autoreconf -fi
./configure --prefix=/usr --without-included-regex --enable-nls --enable-dependency-tracking --with-ssl=openssl --sysconfdir=/etc --with-metalink
make