summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authornoirscape2018-12-19 20:02:57 +0100
committernoirscape2018-12-19 20:02:57 +0100
commit728a26c543aab94721a9cc955122097b9e755231 (patch)
treeaf5778d3b456a401c52665a02f32dafa21f8923c
parent1970624f40643c2731698f1d9868e5d597bdd235 (diff)
downloadaur-728a26c543aab94721a9cc955122097b9e755231.tar.gz
Switch to using gnutls since openssl is broken
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD11
2 files changed, 10 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8c0a6f198b02..ba8ae6199e0f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,16 @@
pkgbase = wget-lua
pkgdesc = Wget with Lua scripting
pkgver = 1.14
- pkgrel = 1
+ pkgrel = 2
url = http://archiveteam.org/index.php?title=Wget_with_Lua_hooks
arch = i686
arch = x86_64
+ arch = armv6h
+ arch = armv7l
license = GPL
makedepends = git
makedepends = perl
- depends = openssl
+ depends = gnutls
depends = libidn
depends = pcre
depends = lua
diff --git a/PKGBUILD b/PKGBUILD
index 9f67acce0914..56d5eb83f620 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,16 +1,17 @@
-# Maintainer: Alastair Feille <me@alastair.se>
+# Maintainer: Valentijn V. <deepnavy at waifu dot club>
+# Contributor: Alastair Feille <me at alastair dot se>
pkgname=wget-lua
pkgver=1.14
-pkgrel=1
+pkgrel=2
pkgdesc="Wget with Lua scripting"
url="http://archiveteam.org/index.php?title=Wget_with_Lua_hooks"
license=('GPL')
-depends=('openssl' 'libidn' 'pcre' 'lua')
+depends=('gnutls' 'libidn' 'pcre' 'lua')
optdepends=("ca-certificates: HTTPS Downloads")
makedepends=('git' 'perl')
provides=('wget-lua')
-arch=('i686' 'x86_64' 'armv6h')
+arch=('i686' 'x86_64' 'armv6h' 'armv7l')
source=("http://warriorhq.archiveteam.org/downloads/wget-lua/wget-1.14.lua.LATEST.tar.bz2"
"lua.patch"
"ssl.patch")
@@ -22,7 +23,7 @@ build() {
patch -p0 -i $srcdir/lua.patch
patch -p0 -i $srcdir/ssl.patch
- ./configure --with-ssl=openssl --disable-nls
+ ./configure --with-ssl=gnutls --disable-nls
make
}