summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNoah Vogt2021-12-18 13:42:22 +0100
committerNoah Vogt2021-12-18 13:42:22 +0100
commitaeb71f828cee13b2170c82e3f9a718771db5de0d (patch)
tree22f0654a7dbbb6763f649574050212bfab054627
parentf0f49a3624d37e845f6ff98eb75be844114a5c6a (diff)
downloadaur-aeb71f828cee13b2170c82e3f9a718771db5de0d.tar.gz
fix pkg
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD11
2 files changed, 9 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f6564aad56b6..4b4d1dde50ff 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
-pkgbase = wget-xdg
+pkgbase = wget
pkgdesc = Network utility to retrieve files from the Web - but moving ~/.wget-hsts to $XDG_CACHE_HOME/wget/hsts
pkgver = 1.21.2
- pkgrel = 1
+ pkgrel = 2
url = https://www.gnu.org/software/wget/wget.html
arch = x86_64
license = GPL3
@@ -21,7 +21,7 @@ pkgbase = wget-xdg
provides = wget
conflicts = wget
backup = etc/wgetrc
- source = https://ftp.gnu.org/gnu/wget-xdg/wget-xdg-1.21.2.tar.lz
+ source = https://ftp.gnu.org/gnu/wget/wget-1.21.2.tar.lz
source = xdg-compliant-wget-hsts-file.patch
sha256sums = 1727a330a86acacb3e57615ce268f5f29978bf7adec4abe6a30d370207bc91b3
sha256sums = e7f03d1f253e4b66c38271f4a47ae8d849ac6241c60728b56be1a10b94611293
diff --git a/PKGBUILD b/PKGBUILD
index 23d8f8835a4b..dc8454f6ed05 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,9 +2,10 @@
# Maintainer: Levente Polyak <anthraxx[at]archlinux[dot]org>
# Maintainer: Eric BĂ©langer <eric@archlinux.org>
+pkgbase=wget
pkgname=wget-xdg
pkgver=1.21.2
-pkgrel=1
+pkgrel=2
pkgdesc='Network utility to retrieve files from the Web - but moving ~/.wget-hsts to $XDG_CACHE_HOME/wget/hsts'
url='https://www.gnu.org/software/wget/wget.html'
arch=('x86_64')
@@ -13,7 +14,7 @@ depends=('glibc' 'zlib' 'gnutls' 'libidn2' 'libidn2.so' 'util-linux-libs' 'libuu
'libpsl' 'libpsl.so' 'pcre2' 'nettle' 'libnettle.so')
optdepends=('ca-certificates: HTTPS downloads')
backup=('etc/wgetrc')
-source=(https://ftp.gnu.org/gnu/${pkgname}/${pkgname}-${pkgver}.tar.lz
+source=(https://ftp.gnu.org/gnu/${pkgbase}/${pkgbase}-${pkgver}.tar.lz
xdg-compliant-wget-hsts-file.patch)
sha256sums=('1727a330a86acacb3e57615ce268f5f29978bf7adec4abe6a30d370207bc91b3'
'e7f03d1f253e4b66c38271f4a47ae8d849ac6241c60728b56be1a10b94611293')
@@ -24,7 +25,7 @@ provides=('wget')
conflicts=('wget')
prepare() {
- cd ${pkgname}-${pkgver}
+ cd ${pkgbase}-${pkgver}
patch -p1 -i ../xdg-compliant-wget-hsts-file.patch
cat >> doc/sample.wgetrc <<EOF
# default root certs location
@@ -33,7 +34,7 @@ EOF
}
build() {
- cd ${pkgname}-${pkgver}
+ cd ${pkgbase}-${pkgver}
./configure \
--prefix=/usr \
--sysconfdir=/etc \
@@ -45,7 +46,7 @@ build() {
package() {
- cd ${pkgname}-${pkgver}
+ cd ${pkgbase}-${pkgver}
make DESTDIR="${pkgdir}" install
}