summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndy Weidenbaum2015-06-09 11:41:58 -0700
committerAndy Weidenbaum2015-06-09 11:41:58 -0700
commit216740396e7cd63edf20210df325f263526564a0 (patch)
treec579ff08a30b50ec14f89c9d6b97b29a59bdf23c
downloadaur-216740396e7cd63edf20210df325f263526564a0.tar.gz
Initial import
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD18
-rwxr-xr-xwgetpkg6
3 files changed, 38 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..38957cecfeca
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = wgetpkg
+ pkgdesc = Downloads AUR packages with wget
+ pkgver = 0.1.0
+ pkgrel = 2
+ url = https://github.com/atweiden/wgetpkg
+ arch = any
+ license = UNLICENSE
+ depends = wget
+ provides = wgetpkg
+ source = wgetpkg
+ sha256sums = 8a74204727bd752f0bfd90a8eb5f567456c148d3540ae86632c66c762e9bf63d
+
+pkgname = wgetpkg
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b514014ec004
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,18 @@
+# Maintainer: Andy Weidenbaum <archbaum@gmail.com>
+
+pkgname=wgetpkg
+pkgver=0.1.0
+pkgrel=2
+pkgdesc="Downloads AUR packages with wget"
+arch=('any')
+depends=('wget')
+url="https://github.com/atweiden/wgetpkg"
+license=('UNLICENSE')
+source=(wgetpkg)
+sha256sums=('8a74204727bd752f0bfd90a8eb5f567456c148d3540ae86632c66c762e9bf63d')
+provides=('wgetpkg')
+
+package() {
+ msg 'Installing executable...'
+ install -D -m755 "$srcdir/wgetpkg" "${pkgdir}/usr/bin/wgetpkg"
+}
diff --git a/wgetpkg b/wgetpkg
new file mode 100755
index 000000000000..e3099e0cc36e
--- /dev/null
+++ b/wgetpkg
@@ -0,0 +1,6 @@
+#!/bin/bash
+
+aurpkgs=$(< /dev/stdin)
+for aurpkg in "$@" "$aurpkgs"; do
+ wget https://aur.archlinux.org/packages/${aurpkg:0:2}/${aurpkg}/${aurpkg}.tar.gz
+done