summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorphire2021-08-03 02:53:53 +0200
committerphire2021-08-03 02:53:53 +0200
commita4c89cf473637eb10979dad289b30add6c9a088c (patch)
treee1850ef2b099cfb17ca4d885b2b33476cdc440b6
downloadaur-a4c89cf473637eb10979dad289b30add6c9a088c.tar.gz
Initial commit
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD17
2 files changed, 30 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3b5ba929c8ec
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = wgnord
+ pkgdesc = A NordVPN Wireguard ("NordLynx") client in POSIX shell
+ pkgver = 0.1.2
+ pkgrel = 1
+ url = https://git.phire.cc/me/wgnord
+ arch = any
+ depends = jq
+ depends = curl
+ depends = wireguard-tools
+ source = https://git.phire.cc/me/wgnord/archive/0.1.2.tar.gz
+ md5sums = ee015e5cd283b3c9ac5cfd73c33b7cae
+
+pkgname = wgnord
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6f9f24e3ba2c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,17 @@
+# Maintainer: phire <me@phire.cc>
+pkgname=wgnord
+pkgver=0.1.2
+pkgrel=1
+pkgdesc="A NordVPN Wireguard (\"NordLynx\") client in POSIX shell"
+arch=('any')
+url="https://git.phire.cc/me/wgnord"
+depends=('jq' 'curl' 'wireguard-tools')
+source=("git+https://git.phire.cc/me/wgnord.git")
+source=("https://git.phire.cc/me/$pkgname/archive/$pkgver.tar.gz")
+md5sums=("ee015e5cd283b3c9ac5cfd73c33b7cae")
+
+package() {
+ install -Dm644 "$srcdir/$pkgname/template.conf" "$pkgdir/var/lib/$pkgname/template.conf"
+ install -Dm644 "$srcdir/$pkgname/countries.txt" "$pkgdir/var/lib/$pkgname/countries.txt"
+ install -Dm755 "$srcdir/$pkgname/wgnord" "$pkgdir/usr/bin/wgnord"
+}