summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRONTheCookie2019-06-19 11:01:58 +0300
committerRONTheCookie2019-06-19 11:01:58 +0300
commitc2812058fac5fd5bdbb573b6902a3a95157dad2d (patch)
tree50b404cdb417e59a83a76ae7a5cd1295524a7df5
downloadaur-c2812058fac5fd5bdbb573b6902a3a95157dad2d.tar.gz
Inital commit
-rw-r--r--.SRCINFO15
-rw-r--r--.gitignore3
-rw-r--r--PKGBUILD23
3 files changed, 41 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3c95a62ee076
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = wgroute
+ pkgdesc = A tiny script to use if you want to route all of your packets through WireGuard without wg-quick
+ pkgver = 1.0.1
+ pkgrel = 1
+ url = https://github.com/RONTheCookie/wgroute
+ arch = any
+ license = MIT
+ makedepends = make
+ depends = iproute2
+ depends = wireguard-tools
+ source = wgroute-1.0.1.tar.gz::https://github.com/RONTheCookie/wgroute/archive/1.0.1.tar.gz
+ sha256sums = e9d65aaa36560dd21f552b9755552a079e8e7c6118a75629dd7f430b53a387eb
+
+pkgname = wgroute
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..244420686313
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,3 @@
+pkg
+src
+*.tar.* \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..68824adaf408
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# This is an example PKGBUILD file. Use this as a start to creating your own,
+# and remove these comments. For more information, see 'man PKGBUILD'.
+# NOTE: Please fill out the license field for your package! If it is unknown,
+# then please put 'unknown'.
+
+# Maintainer: Your Name <youremail@domain.com>
+pkgname=wgroute
+pkgver=1.0.1
+pkgrel=1
+pkgdesc="A tiny script to use if you want to route all of your packets through WireGuard without wg-quick"
+arch=('any')
+url="https://github.com/RONTheCookie/wgroute"
+license=('MIT')
+depends=('iproute2' 'wireguard-tools')
+makedepends=('make')
+source=("$pkgname-$pkgver.tar.gz::https://github.com/RONTheCookie/wgroute/archive/$pkgver.tar.gz")
+sha256sums=('e9d65aaa36560dd21f552b9755552a079e8e7c6118a75629dd7f430b53a387eb')
+
+package() {
+ cd "$pkgname-$pkgver"
+ make DESTDIR="$pkgdir" install
+ install -Dm644 LICENSE ${pkgdir}/usr/share/licenses/${pkgname}/LICENSE
+}