summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKr1ss2021-08-05 17:00:06 +0200
committerKr1ss2021-08-05 17:00:06 +0200
commit220d1f4562e28e1330599e2afb48afe806690e4f (patch)
treea11327d848b345a68ee26d6b851d8b6ee5d922d2
parent053c1855ab20592d38c346f36b8e6dde975ada1d (diff)
downloadaur-220d1f4562e28e1330599e2afb48afe806690e4f.tar.gz
update: whalebird-bin 4.4.2-1
upstream release
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD15
2 files changed, 11 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c6c2fe9552fc..850729400db0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = whalebird-bin
pkgdesc = Electron based multi-platform client for Mastodon, Misskey & Pleroma
- pkgver = 4.4.1
+ pkgver = 4.4.2
pkgrel = 1
url = https://whalebird.org
arch = x86_64
@@ -21,8 +21,7 @@ pkgbase = whalebird-bin
depends = libappindicator-gtk3
provides = whalebird
conflicts = whalebird
- source = https://github.com/h3poteto/whalebird-desktop/releases/download/4.4.1/Whalebird-4.4.1-linux-x64.rpm
- sha256sums = b51f7f56649a537941b41c8070a4f29c7d08638a811c91df8efbcacc3d59dbcb
+ source = https://github.com/h3poteto/whalebird-desktop/releases/download/4.4.2/Whalebird-4.4.2-linux-x64.rpm
+ sha256sums = 13ec6ddfa68a58c5b01597f5310c0dfc9eac957f4247dfaa8fb79ddfd1fc2399
pkgname = whalebird-bin
-
diff --git a/PKGBUILD b/PKGBUILD
index 2f7cd99b5f1c..d4551625c1b1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,30 +3,31 @@
pkgname=whalebird-bin
+_name="${pkgname%-bin}"
-pkgver=4.4.1
+pkgver=4.4.2
pkgrel=1
pkgdesc='Electron based multi-platform client for Mastodon, Misskey & Pleroma'
arch=('x86_64')
-url="https://${pkgname%-bin}.org"
+url="https://$_name.org"
license=('MIT')
-provides=("${pkgname%-bin}")
-conflicts=("${pkgname%-bin}")
+provides=("$_name")
+conflicts=("$_name")
depends=('c-ares' 'ffmpeg' 'gtk3' 'http-parser' 'libevent' 'libvpx' 'libxslt' 'libxss' 'minizip' 'nss' 're2' 'snappy' 'libnotify' 'libappindicator-gtk3')
-source=("https://github.com/h3poteto/${pkgname%-bin}-desktop/releases/download/$pkgver/Whalebird-$pkgver-linux-x64.rpm")
+source=("https://github.com/h3poteto/$_name-desktop/releases/download/$pkgver/Whalebird-$pkgver-linux-x64.rpm")
sha256sums=($(curl -sL https://github.com/h3poteto/${pkgname%-bin}-desktop/releases/download/$pkgver/sha256sum.txt | grep Whalebird-$pkgver-linux-x64.rpm | cut -d\ -f1))
package() {
- install -Dm644 opt/Whalebird/LICENSE* -t"$pkgdir/usr/share/licenses/${pkgname%-bin}/"
+ install -Dm644 opt/Whalebird/LICENSE* -t"$pkgdir/usr/share/licenses/$_name/"
cp -R usr/share/* "$pkgdir/usr/share/"
cp -R opt "$pkgdir/"
install -dm755 "$pkgdir/usr/bin"
- ln -s "/opt/Whalebird/${pkgname%-bin}" "$pkgdir/usr/bin/"
+ ln -s "/opt/Whalebird/$_name" "$pkgdir/usr/bin/"
}