summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorariasuni2018-04-09 12:37:26 +0200
committerariasuni2018-04-09 12:37:26 +0200
commit2d568dfc0b51785a2c14bae1b2d1d890b2296a20 (patch)
treea29f4f2aa4b5aba016611b9b688b7f8c77b7994d
downloadaur-2d568dfc0b51785a2c14bae1b2d1d890b2296a20.tar.gz
initial commit
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD17
2 files changed, 35 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c093f6fc2117
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = whalebird-bin
+ pkgdesc = An Electron based Mastodon client for Windows, Mac and Linux
+ pkgver = 0.3.1
+ pkgrel = 1
+ url = https://github.com/h3poteto/whalebird-desktop
+ arch = x86_64
+ license = MIT
+ depends = alsa-lib
+ depends = gconf
+ depends = gtk2
+ depends = libxss
+ depends = libxtst
+ depends = nss
+ source = https://github.com/h3poteto/whalebird-desktop/releases/download/0.3.1/Whalebird-0.3.1-linux-x64.rpm
+ sha256sums = 3df2baaee7afcecbd73b3248cb41fefc44f4b0cbc087e7a9dbb06d7d05363f26
+
+pkgname = whalebird-bin
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..bd66664e06aa
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,17 @@
+# Maintainer: Mélanie Chauvel (ariasuni) <perso@hack-libre.org>
+
+_appname=whalebird
+pkgname="$_appname-bin"
+pkgver=0.3.1
+pkgrel=1
+pkgdesc='An Electron based Mastodon client for Windows, Mac and Linux'
+arch=(x86_64)
+url=https://github.com/h3poteto/whalebird-desktop
+license=(MIT)
+depends=(alsa-lib gconf gtk2 libxss libxtst nss)
+source=("$url/releases/download/$pkgver/Whalebird-$pkgver-linux-x64.rpm")
+sha256sums=('3df2baaee7afcecbd73b3248cb41fefc44f4b0cbc087e7a9dbb06d7d05363f26')
+
+package() {
+ cp -R opt/ usr/ $pkgdir
+}