summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJean Lucas2019-07-20 03:30:13 -0400
committerJean Lucas2019-07-20 03:30:43 -0400
commit3cd52f6505f5f927bbbdcc054da6b7419778322b (patch)
treea288b0cc99d72402597023214d7b3ca5382ac151
parentff9a33378b1575eb0f97639fea4650f0ff23b9c7 (diff)
downloadaur-3cd52f6505f5f927bbbdcc054da6b7419778322b.tar.gz
2.8.0; add desktop entry, icons
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD25
-rw-r--r--whalebird.desktop9
3 files changed, 30 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ee15897fe11e..0a48a5684fab 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = whalebird-git
pkgdesc = Electron-based Mastodon/Pleroma client (git)
- pkgver = 2.7.5+r1+gae56ef4
+ pkgver = 2.8.0+r41+g76790c7
pkgrel = 1
url = https://whalebird.org
arch = i686
@@ -12,7 +12,9 @@ pkgbase = whalebird-git
conflicts = whalebird
conflicts = whalebird-bin
source = git+https://github.com/h3poteto/whalebird-desktop
+ source = whalebird.desktop
sha512sums = SKIP
+ sha512sums = 3e5f29fc6db305957b81abc8e4b4679fbd979bbf41ce0c190b19c31a96a3bfe03b624885961ce6d7410716d286c82548b960ebbc1e547c1cacc0b16175eecee2
pkgname = whalebird-git
diff --git a/PKGBUILD b/PKGBUILD
index 30d2b98a08ba..fca7c46ee6a3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Jean Lucas <jean@4ray.co>
pkgname=whalebird-git
-pkgver=2.7.5+r1+gae56ef4
+pkgver=2.8.0+r41+g76790c7
pkgrel=1
pkgdesc='Electron-based Mastodon/Pleroma client (git)'
arch=(i686 x86_64)
@@ -10,8 +10,10 @@ license=(MIT)
provides=(whalebird)
conflicts=(whalebird whalebird-bin)
makedepends=(git npm)
-source=(git+https://github.com/h3poteto/whalebird-desktop)
-sha512sums=('SKIP')
+source=(git+https://github.com/h3poteto/whalebird-desktop
+ whalebird.desktop)
+sha512sums=('SKIP'
+ '3e5f29fc6db305957b81abc8e4b4679fbd979bbf41ce0c190b19c31a96a3bfe03b624885961ce6d7410716d286c82548b960ebbc1e547c1cacc0b16175eecee2')
pkgver() {
cd whalebird-desktop
@@ -26,8 +28,17 @@ build() {
}
package() {
- install -d "$pkgdir"/usr/{share,bin}
- cp -a whalebird-desktop/build/linux-unpacked \
- "$pkgdir"/usr/share/whalebird-desktop
- ln -s /usr/share/whalebird-desktop/whalebird "$pkgdir"/usr/bin/whalebird
+ install -Dm 644 whalebird.desktop -t "$pkgdir"/usr/share/applications
+
+ cd whalebird-desktop/build
+
+ cp -a linux-unpacked "$pkgdir"/usr/share/whalebird
+
+ for i in 16 32 128 256 512; do
+ install -Dm 644 icons/icon.iconset/icon_${i}x${i}.png \
+ "$pkgdir"/usr/share/icons/hicolor/${i}x${i}/apps/whalebird.png
+ done
+
+ mkdir "$pkgdir"/usr/bin
+ ln -s /usr/share/whalebird/whalebird "$pkgdir"/usr/bin/whalebird
}
diff --git a/whalebird.desktop b/whalebird.desktop
new file mode 100644
index 000000000000..3f6ffab227d1
--- /dev/null
+++ b/whalebird.desktop
@@ -0,0 +1,9 @@
+[Desktop Entry]
+Version=1.0
+Type=Application
+Name=Whalebird
+Comment=Electron-based Mastodon/Pleroma client
+Exec=whalebird
+Icon=whalebird
+Categories=Network;
+Terminal=false