summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJean Lucas2019-06-23 20:59:22 -0400
committerJean Lucas2019-06-23 20:59:22 -0400
commitff9a33378b1575eb0f97639fea4650f0ff23b9c7 (patch)
tree720a5e6c5dcc6c0c37d4007144d3610511ac193c
parentbeeb838ddabf8fc19fb560ecc55a723b401f09b1 (diff)
downloadaur-ff9a33378b1575eb0f97639fea4650f0ff23b9c7.tar.gz
Version bump and fix build, update pkgver scheme, add provides
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD8
2 files changed, 7 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4a57233a8426..ee15897fe11e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,6 @@
-# Generated by mksrcinfo v8
-# Sat Apr 20 05:54:57 UTC 2019
pkgbase = whalebird-git
pkgdesc = Electron-based Mastodon/Pleroma client (git)
- pkgver = 2.7.0+107+gf819d49
+ pkgver = 2.7.5+r1+gae56ef4
pkgrel = 1
url = https://whalebird.org
arch = i686
@@ -10,6 +8,7 @@ pkgbase = whalebird-git
license = MIT
makedepends = git
makedepends = npm
+ provides = whalebird
conflicts = whalebird
conflicts = whalebird-bin
source = git+https://github.com/h3poteto/whalebird-desktop
diff --git a/PKGBUILD b/PKGBUILD
index b791686269c3..30d2b98a08ba 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,12 +1,13 @@
# Maintainer: Jean Lucas <jean@4ray.co>
pkgname=whalebird-git
-pkgver=2.7.0+107+gf819d49
+pkgver=2.7.5+r1+gae56ef4
pkgrel=1
pkgdesc='Electron-based Mastodon/Pleroma client (git)'
arch=(i686 x86_64)
url=https://whalebird.org
license=(MIT)
+provides=(whalebird)
conflicts=(whalebird whalebird-bin)
makedepends=(git npm)
source=(git+https://github.com/h3poteto/whalebird-desktop)
@@ -14,13 +15,14 @@ sha512sums=('SKIP')
pkgver() {
cd whalebird-desktop
- git describe --tags | sed 's#-#+#g'
+ git describe --tags | sed 's#-#+#g;s#+#+r#'
}
build() {
cd whalebird-desktop
npm install
- npm run build:dir
+ npm run build
+ npx electron-builder --dir
}
package() {