summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJon Gjengset2016-09-23 12:38:07 -0400
committerJon Gjengset2016-09-23 12:38:07 -0400
commit80e265b743708fc943f4320cd1b034cfc5274bec (patch)
tree39d3d85d893b7b6b3d3a240ba9ab1dde25f93685
downloadaur-80e265b743708fc943f4320cd1b034cfc5274bec.tar.gz
initial commit
-rw-r--r--.SRCINFO16
-rw-r--r--.gitignore3
-rw-r--r--PKGBUILD24
3 files changed, 43 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..996ab1bfb057
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+# Generated by mksrcinfo v8
+# Fri Sep 23 16:37:46 UTC 2016
+pkgbase = what-git
+ pkgdesc = An improved version of w that shows all processes associated with a TTY
+ pkgver = r8.589ce22
+ pkgrel = 1
+ url = https://github.com/mit-pdos/what
+ arch = any
+ license = MIT
+ makedepends = git
+ depends = python2
+ source = git+https://github.com/mit-pdos/what.git
+ md5sums = SKIP
+
+pkgname = what-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..a2a69f1bf998
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,3 @@
+*.pkg.tar.xz
+src/
+pkg/
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..432bec2deee2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Jon Gjengset
+pkgname=what-git
+pkgver=r8.589ce22
+pkgrel=1
+pkgdesc="An improved version of w that shows all processes associated with a TTY"
+arch=('any')
+url="https://github.com/mit-pdos/what"
+license=('MIT')
+depends=('python2')
+makedepends=('git')
+provides=("")
+conflicts=("")
+source=('git+https://github.com/mit-pdos/what.git')
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/${pkgname%-git}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd "$srcdir/${pkgname%-git}"
+ install -D what "$pkgdir/usr/bin/what"
+}