summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authormutantmonkey2015-06-28 10:13:57 -0700
committermutantmonkey2015-06-28 10:13:57 -0700
commit3cd8a53409cf6b6ce7571561bd4a86f71468b2ae (patch)
treecfc60d27e85a181880eb6f1777bce4ca04c86729
parent63708eeeb17e361d8fe7b6576ce2ef6f431d3285 (diff)
downloadaur-3cd8a53409cf6b6ce7571561bd4a86f71468b2ae.tar.gz
3.6-1
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD15
2 files changed, 18 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 315cca5923f8..9c11ba19ea63 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = whatmp3
pkgdesc = A small Python script that accepts a list of directories containing FLAC files as arguments and converts them to MP3 with the specified options. It can optionally create a torrent file.
- pkgver = 3.5.3
+ pkgver = 3.6
pkgrel = 1
url = http://logik.li/projects/whatmp3/
arch = any
@@ -8,12 +8,16 @@ pkgbase = whatmp3
depends = python
depends = mktorrent
depends = flac
- depends = lame
optdepends = vorbis-tools: OGG Vorbis support
+ optdepends = lame: MP3 support
optdepends = neroaacenc: AAC support
optdepends = neroaactag: AAC support
- source = http://logik.li/projects/whatmp3/whatmp3-3.5.3.tar.gz
- sha256sums = 2856215a99eefb8cb1eccbbaa0e7b06e8c97509b499d13cbd5392598bd2384ae
+ optdepends = mp3gain: ReplayGain support
+ optdepends = vorbisgain: ReplayGain support
+ optdepends = aacgain: ReplayGain support
+ optdepends = sox: dither support
+ source = https://github.com/RecursiveForest/whatmp3/archive/v3.6.tar.gz
+ sha256sums = a1f5ef28e2511aa47f4658f71a8a3afe3dda96e7dd6a1cf9d124daead0fed5fa
pkgname = whatmp3
diff --git a/PKGBUILD b/PKGBUILD
index 761e7792c2dd..c9b9aeedd54b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,17 +1,22 @@
# Maintainer: mutantmonkey <aur@mutantmonkey.in>
pkgname=whatmp3
-pkgver=3.5.3
+pkgver=3.6
pkgrel=1
pkgdesc="A small Python script that accepts a list of directories containing FLAC files as arguments and converts them to MP3 with the specified options. It can optionally create a torrent file."
url="http://logik.li/projects/whatmp3/"
arch=('any')
license=('MIT')
-depends=('python' 'mktorrent' 'flac' 'lame')
+depends=('python' 'mktorrent' 'flac')
optdepends=('vorbis-tools: OGG Vorbis support'
+ 'lame: MP3 support'
'neroaacenc: AAC support'
- 'neroaactag: AAC support')
-source=("http://logik.li/projects/${pkgname}/${pkgname}-${pkgver}.tar.gz")
-sha256sums=('2856215a99eefb8cb1eccbbaa0e7b06e8c97509b499d13cbd5392598bd2384ae')
+ 'neroaactag: AAC support'
+ 'mp3gain: ReplayGain support'
+ 'vorbisgain: ReplayGain support'
+ 'aacgain: ReplayGain support'
+ 'sox: dither support')
+source=("https://github.com/RecursiveForest/whatmp3/archive/v${pkgver}.tar.gz")
+sha256sums=('a1f5ef28e2511aa47f4658f71a8a3afe3dda96e7dd6a1cf9d124daead0fed5fa')
package() {
cd ${srcdir}/${pkgname}-${pkgver}