summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authormutantmonkey2013-08-31 16:33:29 -0700
committermutantmonkey2013-08-31 16:33:29 -0700
commit125f00bde3684907f953bfe17ad1edd54b617aa3 (patch)
tree133704045dd1925b9ea9c629e7d390c0a9d49639
downloadaur-125f00bde3684907f953bfe17ad1edd54b617aa3.tar.gz
add PKGBUILD for whatmp3-git
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD29
2 files changed, 51 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..cb3384e83ec5
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = whatmp3-git
+ pkgdesc = A small Python script that accepts a list of directories containing FLAC files as arguments and converts them to MP3 with the specified options. It can optionally create a torrent file.
+ pkgver = 53.a2d9d17
+ pkgrel = 1
+ url = http://logik.li/projects/whatmp3/
+ arch = any
+ license = MIT
+ depends = python
+ depends = mktorrent
+ depends = flac
+ depends = lame
+ depends = ffmpeg
+ optdepends = vorbis-tools: OGG Vorbis support
+ optdepends = neroaacenc: AAC support
+ optdepends = neroaactag: AAC support
+ provides = whatmp3=3.6
+ conflicts = whatmp3
+ source = git+https://github.com/RecursiveForest/whatmp3.git
+ sha256sums = SKIP
+
+pkgname = whatmp3-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..afb0463084cb
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: mutantmonkey <aur@mutantmonkey.in>
+pkgname=whatmp3-git
+_gitname=whatmp3
+pkgver=53.a2d9d17
+pkgrel=1
+pkgdesc="A small Python script that accepts a list of directories containing FLAC files as arguments and converts them to MP3 with the specified options. It can optionally create a torrent file."
+url="http://logik.li/projects/whatmp3/"
+arch=('any')
+license=('MIT')
+provides=('whatmp3=3.6')
+conflicts=('whatmp3')
+depends=('python' 'mktorrent' 'flac' 'lame' 'ffmpeg')
+optdepends=('vorbis-tools: OGG Vorbis support'
+ 'neroaacenc: AAC support'
+ 'neroaactag: AAC support')
+source=('git+https://github.com/RecursiveForest/whatmp3.git')
+sha256sums=('SKIP')
+
+pkgver() {
+ cd $_gitname
+ echo $(git rev-list --count master).$(git rev-parse --short master)
+}
+
+package() {
+ cd $_gitname
+ install -D whatmp3 ${pkgdir}/usr/bin/whatmp3
+}
+
+# vim:set ts=2 sw=2 et: