summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMubashshir2023-05-10 23:52:44 +0600
committerMubashshir2023-05-10 23:55:41 +0600
commit59f5c36bb668f8c7cf6f54dd9732401e4b529151 (patch)
tree597b5802444fe7bac2eab375e067c483a521188e
parent1d5190784beb0061330c34c7c65ed2e4081b9f0f (diff)
downloadaur-59f5c36bb668f8c7cf6f54dd9732401e4b529151.tar.gz
whatpulse: Release v5.4 with bundled Qt6
Fsck whatpulse, I'm gonna set rpath so that you won't run with system qt6 Signed-off-by: Mubashshir <ahmubashshir@gmail.com>
-rw-r--r--.SRCINFO29
-rw-r--r--PKGBUILD59
2 files changed, 59 insertions, 29 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 819db6c6022b..240a8a1dd050 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,22 +1,37 @@
pkgbase = whatpulse
pkgdesc = Measures your keyboard, mouse and application usage, network traffic and uptime.
- pkgver = 5.3
- pkgrel = 3
+ pkgver = 5.4
+ pkgrel = 1
url = http://www.whatpulse.org
arch = x86_64
license = custom:whatpulse_tos
makedepends = imagemagick
makedepends = patchelf
- depends = qt6-svg
- depends = qt6-charts
- depends = qt6-5compat
+ depends = freetype2
+ depends = xcb-util-image
+ depends = libxkbcommon
+ depends = libxkbcommon-x11
+ depends = xcb-util-renderutil
+ depends = gcc-libs
+ depends = dbus
+ depends = krb5
+ depends = xcb-util-wm
+ depends = glib2
+ depends = libx11
+ depends = fontconfig
+ depends = libglvnd
+ depends = xcb-util-keysyms
+ depends = openssl-1.1
+ depends = glibc
+ depends = libxcb
+ depends = zlib
depends = hicolor-icon-theme
optdepends = libpcap: for capturing network statistics
source = whatpulse.desktop
source = LICENSE
sha256sums = 5a4a6676a6b513824eeac8a2accd6de9e8bd2bc11b3e2967fa2b2a18d29fa35d
sha256sums = cfea47f15bb3ba2494a7b1d50367139dc12709fc1e8ba0b25d86ee5f09748619
- source_x86_64 = whatpulse-5.3-amd64.AppImage::https://releases.whatpulse.org/latest/linux/whatpulse-linux-latest_amd64.AppImage
- sha256sums_x86_64 = 78e40c4bb8167eb893cfda1d2e01d8d6f8ec481d1768629e4e9345bc83386e14
+ source_x86_64 = whatpulse-5.4-amd64.AppImage::https://releases.whatpulse.org/latest/linux/whatpulse-linux-latest_amd64.AppImage
+ sha256sums_x86_64 = 533b1b28120a25f3db625425f42dfbc559180a3dfb4e1f9c6156cf27b4a646f4
pkgname = whatpulse
diff --git a/PKGBUILD b/PKGBUILD
index 1d5313e0a99c..0cf5a1eff28e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,8 +5,8 @@
# Contributor: Pieter Kokx <pieter $at$ kokx $dot$ .nl>
_tag=latest
pkgname=whatpulse
-pkgver=5.3
-pkgrel=3
+pkgver=5.4
+pkgrel=1
pkgdesc="Measures your keyboard, mouse and application usage, network traffic and uptime."
arch=('x86_64')
@@ -14,17 +14,18 @@ url=http://www.whatpulse.org
license=(custom:whatpulse_tos)
depends=(
- qt6-svg
- qt6-charts
- qt6-5compat
+ freetype2 xcb-util-image libxkbcommon libxkbcommon-x11 xcb-util-renderutil gcc-libs dbus krb5
+ xcb-util-wm glib2 libx11 fontconfig libglvnd xcb-util-keysyms openssl-1.1 glibc libxcb zlib
hicolor-icon-theme
)
+
makedepends=(
imagemagick
patchelf
)
+
optdepends=(
- 'libpcap: for capturing network statistics'
+ 'libpcap: for capturing network statistics'
)
source=(
'whatpulse.desktop'
@@ -32,8 +33,8 @@ source=(
)
source_x86_64=("${pkgname}-${pkgver}-amd64.AppImage::https://releases.whatpulse.org/${_tag:-$pkgver}/linux/whatpulse-linux-${_tag:-$pkgver}_amd64.AppImage")
sha256sums=('5a4a6676a6b513824eeac8a2accd6de9e8bd2bc11b3e2967fa2b2a18d29fa35d'
- 'cfea47f15bb3ba2494a7b1d50367139dc12709fc1e8ba0b25d86ee5f09748619')
-sha256sums_x86_64=('78e40c4bb8167eb893cfda1d2e01d8d6f8ec481d1768629e4e9345bc83386e14')
+ 'cfea47f15bb3ba2494a7b1d50367139dc12709fc1e8ba0b25d86ee5f09748619')
+sha256sums_x86_64=('533b1b28120a25f3db625425f42dfbc559180a3dfb4e1f9c6156cf27b4a646f4')
_extract() {
./"${pkgname}-${pkgver}-amd64.AppImage" --appimage-extract "$1"
@@ -42,30 +43,44 @@ _extract() {
prepare() {
chmod +x "${pkgname}-${pkgver}-amd64.AppImage"
_extract usr/bin/whatpulse
+ _extract usr/lib
+ _extract usr/plugins
_extract 'whatpulse.png'
_extract 'usr/share/icons/hicolor/512x512/apps/whatpulse.png'
ln -sf squashfs-root sfs
- patchelf --remove-rpath sfs/usr/bin/whatpulse
+
+ find sfs/usr/lib -type f -not -name 'libQt6*.so.*' -not -name 'libicu*.so.*' -delete
+ find sfs/usr/plugins -type f -name 'libqsql*.so' -not -name 'libqsqlite.so' -delete
+
+ find sfs/usr/{bin,lib,plugins} -type f -not -name 'libicudata.so.*' \
+ -exec patchelf --set-rpath '/usr/lib/whatpulse/lib:/usr/lib' '{}' +
}
package() {
- install -Dm 755 sfs/usr/bin/whatpulse "${pkgdir}/usr/bin/whatpulse"
- install -Dm 644 whatpulse.desktop "${pkgdir}/usr/share/applications/whatpulse.desktop"
- install -Dm 644 LICENSE "${pkgdir}/usr/share/licenses/$pkgname/LICENSE"
+ install -Dm755 sfs/usr/bin/whatpulse "${pkgdir}/usr/bin/whatpulse"
+ # Qt6
+ find sfs/usr/lib -type f -exec install -Dm644 -t "${pkgdir}/usr/lib/whatpulse/lib" '{}' +
+ # Qt6 plugins
+ find sfs/usr/plugins -mindepth 1 -type d \
+ -not \( -name imageformats -or -name xcbglintegrations \) -printf '%f\0' |
+ xargs -0I '<>' find 'sfs/usr/plugins/<>' -type f \
+ -exec install -Dm644 -t "${pkgdir}/usr/lib/whatpulse/plugins/<>" '{}' +
+
+ install -Dm 644 whatpulse.desktop "${pkgdir}/usr/share/applications/whatpulse.desktop"
+ install -Dm 644 LICENSE "${pkgdir}/usr/share/licenses/$pkgname/LICENSE"
- # Set capabilities so that whatpulse can monitor network traffic
- # Disable network monitor caps to prevent segfaults
- # setcap cap_net_raw,cap_net_admin=eip "${pkgdir}/usr/bin/whatpulse"
+ # Set capabilities so that whatpulse can monitor network traffic
+ # Disable network monitor caps to prevent segfaults
+ # setcap cap_net_raw,cap_net_admin=eip "${pkgdir}/usr/bin/whatpulse"
# Generate and install icons
- for size in 16 20 22 24 28 32 36 44 48 64 72 96 128 150 192 256 310 384 512 1024
- do
+ for size in 16 20 22 24 28 32 36 44 48 64 72 96 128 150 192 256 310 384 512 1024; do
install -dm755 "${pkgdir}/usr/share/icons/hicolor/${size}x${size}/apps"
convert \
- +gravity -crop 615x680+0+0 +repage \
- -resize "${size}x${size}" -background none \
- -gravity center -extent "${size}x${size}" \
- sfs//whatpulse.png xc:"#656565" -channel RGB -clut \
- "${pkgdir}/usr/share/icons/hicolor/${size}x${size}/apps/whatpulse.png"
+ +gravity -crop 615x680+0+0 +repage \
+ -resize "${size}x${size}" -background none \
+ -gravity center -extent "${size}x${size}" \
+ sfs/whatpulse.png xc:"#656565" -channel RGB -clut \
+ "${pkgdir}/usr/share/icons/hicolor/${size}x${size}/apps/whatpulse.png"
done
}